+ Responder ao Tópico



  1. #1

    Padrão Script de Backup para Mikrotik

    Ola pessoal do forum,

    Esta semana me deparei com um problema nao muito legal, queimo um computador com mikrotik, e eu nao tinha backup dele, ou seja demorei um tempao até configurar tudo denovo. Eis que intao eu resolvi criar um scripitizinho bem basico, para todos meus mikrotiks, que envia todo dia a 00:00Hrs, um email pra mim, com uma copia do backup atualizado do mikrotik. segue abaixo as regras, caso alguem queira implemente no seu servidor =]

    # Configura Servidor de Email do Mikrotik
    /tool e-mail set server="servidor de email" from="conta de email"

    #Cria o Script pra Gerar o Backup
    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/system backup save name=Backup"

    #Cria o Script que manda o Backup
    /system script add name=Email_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/tool e-mail send file=Backup.backup to="email que vai ser mandado o backup" subject=Backup"

    #Marca o Horario que o Backup vai ser Criado, Nesse Caso as 00:00:00
    /system scheduler add name=Gera_Backup start-time=00:00:00 on-event=Gera_Backup

    #Marca o Horario que o Backup vai ser enviado para o Email, Neste Caso 00:00:00
    /system scheduler add name=Email_Backup start-time=00:00:10 on-event=Email_Backup

    Espero que seja util para alguem,

    Abracooo

  2. #2

    Padrão

    Citação Postado originalmente por hyperpotato Ver Post
    Ola pessoal do forum,

    Esta semana me deparei com um problema nao muito legal, queimo um computador com mikrotik, e eu nao tinha backup dele, ou seja demorei um tempao até configurar tudo denovo. Eis que intao eu resolvi criar um scripitizinho bem basico, para todos meus mikrotiks, que envia todo dia a 00:00Hrs, um email pra mim, com uma copia do backup atualizado do mikrotik. segue abaixo as regras, caso alguem queira implemente no seu servidor =]

    # Configura Servidor de Email do Mikrotik
    /tool e-mail set server="servidor de email" from="conta de email"

    #Cria o Script pra Gerar o Backup
    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/system backup save name=Backup"

    #Cria o Script que manda o Backup
    /system script add name=Email_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/tool e-mail send file=Backup.backup to="email que vai ser mandado o backup" subject=Backup"

    #Marca o Horario que o Backup vai ser Criado, Nesse Caso as 00:00:00
    /system scheduler add name=Gera_Backup start-time=00:00:00 on-event=Gera_Backup

    #Marca o Horario que o Backup vai ser enviado para o Email, Neste Caso 00:00:00
    /system scheduler add name=Email_Backup start-time=00:00:10 on-event=Email_Backup

    Espero que seja util para alguem,

    Abracooo
    Certo amigo.... mas e se o servidor de saida de emails requer autenticação? o email nao serah enviado...



  3. #3

    Padrão

    Exatamente, quando o servidor de e-mail requer autenticação, o script não funciona. Qual o e-mail nosso amigo hyperpotato está usando ?

  4. #4

    Padrão

    Pessoal eu estou usando o email do meu propio provedor

    @promitos.com.br

    nao necessita autenticacao

    =]



  5. #5

  6. #6

    Padrão

    eh o kaso
    vc nao precisa usa o seu email q vc sempre usa,

    cria um email, no teu provedor nem q seja soh para isso.

    ehhehehe aki nao foi necessario,
    mas que eh bom te um backup eh
    hehehehe

    flww



  7. #7

    Padrão

    Citação Postado originalmente por hyperpotato Ver Post
    eh o kaso
    vc nao precisa usa o seu email q vc sempre usa,
    cria um email, no teu provedor nem q seja soh para isso.
    ehhehehe aki nao foi necessario,
    mas que eh bom te um backup eh
    hehehehe
    flww
    A necessidade de autenticação é, a meu ver, o principal problema de se usar esse recurso do MK. A maioria não tem um servidor de email dentro de sua rede para que possa usá-lo sem autenticação e fora não existe servidor sem exigir autenticação pois o torna muito inseguro.

    Resumo: Onde achar um servidor que não exija autenticação sem que seja necessário criar um dentro de sua rede só para isso?

    Aos conhecedores de plantão uma pergunta: Não seria possível criar uma conta em um servidor público para uso restrito e sem autenticação? Exemplo: A conta de email teria um nome truncado, [email protected], sem senha e configurado para enviar emails para um único destino: [email protected].

    A conta não se tornaria público, pois não receberia emails, e não geraria spam no caso de ser descoberto pois só geraria para um único destino.

    É possível?

  8. #8

    Padrão

    Citação Postado originalmente por hyperpotato Ver Post
    eh o kaso
    vc nao precisa usa o seu email q vc sempre usa,

    cria um email, no teu provedor nem q seja soh para isso.

    ehhehehe aki nao foi necessario,
    mas que eh bom te um backup eh
    hehehehe

    flww
    Olá amigo... teria como vc criar uma conta ai no seu provedor pra mim? só pra eu usar a função do mkt pra enviar email pra mim mesmo?
    Abs



  9. #9

    Padrão

    Citação Postado originalmente por froyer Ver Post
    Olá amigo... teria como vc criar uma conta ai no seu provedor pra mim? só pra eu usar a função do mkt pra enviar email pra mim mesmo?
    Abs
    manoo eu ateh criaria mas nao da
    pq fora da minha rede interna os emails precisam de autenticacao, para mandar email,

    Mas eu vo estuda alguma coisa para mandar emaisl sem autenticacao
    para o pessoal q precisa de email para essa finalidade,

    Essa semana posto respostas
    =]

  10. #10

    Padrão

    Citação Postado originalmente por hyperpotato Ver Post
    manoo eu ateh criaria mas nao da
    pq fora da minha rede interna os emails precisam de autenticacao, para mandar email,

    Mas eu vo estuda alguma coisa para mandar emaisl sem autenticacao
    para o pessoal q precisa de email para essa finalidade,

    Essa semana posto respostas
    =]
    ok... vlw.......



  11. #11

    Padrão

    hyperpotato vc teria algum manual ou tutorial ensinando a criar um servidor de email sem autenticação? para q no possamos usar esse email interno para essa finalidade no mikrotik? agradeço desde já!

  12. #12

    Padrão

    Citação Postado originalmente por joelson854 Ver Post
    hyperpotato vc teria algum manual ou tutorial ensinando a criar um servidor de email sem autenticação? para q no possamos usar esse email interno para essa finalidade no mikrotik? agradeço desde já!
    Cara nao tenho nada nao,

    Mas procura ai, um servidorzinho ubuntu,
    Ta xeio de toturiais e manuais otimos na net

    =]

    Se alguem souber de outra solucao para este problema poste ai

    Abraco