+ Responder ao Tópico



  1. Olá pesso segui passo a passo o tutorial de instalacao do MRTG, tudo funcionou, porem quando fui inicializar o MRTG com o comando :
    ( uso o Fedora Core 5 ):

    Código :
    [root@server bin]# /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg


    Ocorreu o seguinte erro :

    Código :
     
    [root@server bin]# /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    ERROR: Mrtg will most likely not work properly when the environment
           variable LANG is set to UTF-8. Please run mrtg in an environment
           where this is not the case. Try the following command to start:
     
           env LANG=C /usr/local/mrtg-2/bin/mrtg /home/usuario/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    [root@server bin]# /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    ERROR: Mrtg will most likely not work properly when the environment
           variable LANG is set to UTF-8. Please run mrtg in an environment
           where this is not the case. Try the following command to start:
     
           env LANG=C /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    [root@server bin]#

    vejam como esta o arquivo mrtg.cfg :

    Código :
    # Created by 
    # ./cfgmaker --global "WorkDir: /var/www/html/mrtg" --global "Options[_]: bits,growright" --global RunAsDaemon:Yes --output /var/www/html/mrtg/mrtg.cfg public@(meu_ip)
     
     
    ### Global Config Options
     
    #  for UNIX
    # WorkDir: /home/http/mrtg
     
    #  or for NT
    # WorkDir: c:\mrtgdata
     
    ### Global Defaults
     
    #  to get bits instead of bytes and graphs growing to the right
    # Options[_]: growright, bits
     
    EnableIPv6: no
    WorkDir: /var/www/html/mrtg
    Options[_]: bits,growright
    RunAsDaemon:Yes
     
    ######################################################################
    # System: 
    # Description: 
    # Contact: 
    # Location: 
    ######################################################################

    Agradeço desde ja quem poder me ajudar.

  2. encontrei , estava na propria mensagem :


    env LANG=C /usr/local/mrtg-2/bin/mrtg /home/usuario/mrtg/mrtg.cfg



  3. Olá, Bom dia....

    Faz o seguinte, dá o comando export LANG=C

    Só precisa fazer isso que vai funcionar, o resto está correto.

    Se funcionar posta aí.....


    Abraços,


    Diego Araújo

    Citação Postado originalmente por smsfabio Ver Post
    Olá pesso segui passo a passo o tutorial de instalacao do MRTG, tudo funcionou, porem quando fui inicializar o MRTG com o comando :
    ( uso o Fedora Core 5 ):

    Código :
    [root@server bin]# /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg


    Ocorreu o seguinte erro :

    Código :
     
    [root@server bin]# /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    ERROR: Mrtg will most likely not work properly when the environment
           variable LANG is set to UTF-8. Please run mrtg in an environment
           where this is not the case. Try the following command to start:
     
           env LANG=C /usr/local/mrtg-2/bin/mrtg /home/usuario/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    [root@server bin]# /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    ERROR: Mrtg will most likely not work properly when the environment
           variable LANG is set to UTF-8. Please run mrtg in an environment
           where this is not the case. Try the following command to start:
     
           env LANG=C /usr/local/mrtg-2/bin/mrtg /var/www/html/mrtg/mrtg.cfg
    -----------------------------------------------------------------------
    [root@server bin]#

    vejam como esta o arquivo mrtg.cfg :

    Código :
    # Created by 
    # ./cfgmaker --global "WorkDir: /var/www/html/mrtg" --global "Options[_]: bits,growright" --global RunAsDaemon:Yes --output /var/www/html/mrtg/mrtg.cfg public@(meu_ip)
     
     
    ### Global Config Options
     
    #  for UNIX
    # WorkDir: /home/http/mrtg
     
    #  or for NT
    # WorkDir: c:\mrtgdata
     
    ### Global Defaults
     
    #  to get bits instead of bytes and graphs growing to the right
    # Options[_]: growright, bits
     
    EnableIPv6: no
    WorkDir: /var/www/html/mrtg
    Options[_]: bits,growright
    RunAsDaemon:Yes
     
    ######################################################################
    # System: 
    # Description: 
    # Contact: 
    # Location: 
    ######################################################################

    Agradeço desde ja quem poder me ajudar.






Tópicos Similares

  1. Erro ao executar o MRTG
    Por cleciorodrigo no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-10-2005, 07:32
  2. Erro ao executar make menuconfig?
    Por Hacinn no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-05-2004, 08:24
  3. erro ao executar programa....
    Por flush no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 25-03-2004, 09:06
  4. Erro ao executar o KSCD
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 10-10-2003, 19:23
  5. ERRO AO EXECUTAR MPLAYER
    Por Fabinho no fórum Servidores de Rede
    Respostas: 2
    Último Post: 16-12-2002, 11:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L