Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Prezados Amigos,

    Estou com um sério problema.
    O script ChangeIp não está funcionando no meu MKT. Estou usando a versão v3.0rc5 , não encontrei nada no site do MIkrotik à respeito sobre a versão 3 .
    Será que alguém tem a solução ?
    Uso MKT com um Link ADSL. Meu servidor faz PPPoe para o Modem.
    Está aí o script.

    :log info "DDNS: Begin"

    :global ddns-user "usuario"
    :global ddns-pass "senha"

    # Designa o nome do Prédio
    :global ddns-host "host"

    :global ddns-interface "pppoe-out1"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info "IP Atual"
    :log info $ddns-ip
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Última edição por fabiocp1984; 10-11-2007 às 22:52. Razão: erro ortografia

  2. Quando não consigo o número do ip faço o seguinte:


    Entro no msn vejo que clientes estão conectados (tem que ter clientes adicionados) e peço ao que tem menos conhecimento com a net para que clique nesse site e me passe o número que está em vermelho, eles geralmente perguntam o que é, digo que é um teste da rede e eles me passam o número...


    Isso é em uma situação de emergência!!!!!


    Aqui o site: MEU IP


    Abração.



  3. boa tarde, amigo

    Não sei se é um bug dessa versão que vc está usando, mas de qualquer forma, segue o script semelhante ao seu que eu uso na versão 2.9.27 e que está funcionando perfeitamente.

    :log info "DDNS: Begin"

    :global ddns-user "nome"
    :global ddns-pass "senha"
    :global ddns-host "*1"
    :global ddns-interface "VELOX"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Última edição por Ramde; 11-11-2007 às 17:30.

  4. amigos, se o nome da interface q recebe link, tiver em caixa alta, tem q por em caixa alta no script,

    segue o meu ai, pra conferir,, funfando blzaa.

    :log info "DDNS: Begin"

    :global ddns-user "user"
    :global ddns-pass "senha"
    :global ddns-host "*1"
    :global ddns-interface "LINK"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"



  5. Outra coisa que esqueci

    verifique essa linha do seu script, caso vc tenha copiado e colado e edite ela

    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]

    a parte onde aparece uma carinha, se vc copiar e colar não aparece no script correto, ele corta, o correto é [dois pontos pick , escrevi para não aparecer a carinha conforme aparece acima, se for isso, edite no seu script que deve funcionar.

    Espero ter ajudado

    Abraço






Tópicos Similares

  1. Respostas: 5
    Último Post: 28-09-2012, 10:16
  2. Ajuda no KERNEL
    Por duker no fórum Servidores de Rede
    Respostas: 3
    Último Post: 03-02-2003, 13:14
  3. urgente: ajuda no tomcat!! Por favor!!
    Por roggy no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-12-2002, 17:19
  4. AJUDA no WEBMAIL...
    Por soyeu no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-12-2002, 14:38
  5. AJUDA NO SQUID - RESTRIÇÕES
    Por soyeu no fórum Servidores de Rede
    Respostas: 4
    Último Post: 30-09-2002, 16:07

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L