Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Cache Full

    recebi de graça essas regras p/ CACHE FULL....

    testei e ta funcionando redondo...... as regras sao essas p/ quem quizer testar.....

    ______________________________________________________________________________________________________________________________

    /ip firewall mangle>

    add chain=output protocol=tcp src-port=3128 action=mark-connection \> new-connection-mark=proxy passthrough=yes comment="PROXYLIVRE" \> disabled=no

    add chain=output connection-mark=proxy action=mark-packet \> new-packet-mark=proxy passthrough=yes comment="PROXYLIVRE" disabled=no

    add chain=output connection-mark=proxy action=return comment="PROXYLIVRE" \> disabled=no

    /queuer simple

    add name="ProxyLivre" dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxy \ priority=1 queue=default/default limit-at=10000000/10000000
    max-limit=10000000/10000000 \ total-queue=default disabled=no

    ______________________________________________________________________________________________________________________________

    postem ai os resutados.... ou vamos melhorar essas regras

  2. #2

    Padrão

    qual a diferença entre essa regra e a que o david postou e que não tava servindo pra ninguém? Olhando rápido, não ví diferença



  3. #3

    Padrão

    Exatamente igual as regras já bem discutidas no tópico do david.
    Essas regras liberam sim, o proxy, mas junto tmb, o link.
    Fica tudo full, tanto o proxy quanto http, ou seja, os clientes navegam full mesmo o arquivos q não estão no proxy.

  4. #4

    Question Proxy full ....

    Qual a diferença do topico do david, pois até onde eu sei até agora nao se encontrou a soluçao para que o o link fique estavel!!!



  5. #5

    Padrão

    essa regra ai libera o trafego web 100% independente de ter objetos em cache ou nao !!

  6. #6

    Padrão

    Essas Regras Ai, Peguei No Forum Telenordeste



  7. #7

    Padrão Cache full

    Alguem já tentou fazer uma Brigde com squid instalado e antes do roteador?
    Num sei se funciona, mas a velocidade na brigde ficaria liberada e se controlaria a velocidade no roteador.... é só uma ideia .... ninguém precisa me bater por isso ....

  8. #8

    Padrão

    na bridge se vc colocar o tproxy.. fica show



  9. #9

    Padrão Cache full

    Então tá resolvido: 1 CPU com squid em tproxy funcionando com brigde, ligada a outra funcionando como router e controle de banda.

  10. #10

    Padrão cache full

    bom galera, sobre o cache full, na versão 2.9 é quase impossivel, dizer assim pra não colocar um ponto final, conversando com um DR. em mikrotik que leciona curso junto com MAIA da MD BRASIL, mim informou que so é possivel na versão 3.0, e que não tem muito detalhe sobre a função, pois ainda é beta, mas acredita que sera possivel fazer 3mb, com um link de 1mb. e completou dizendo ( mikrotik é muito bom, mas não faz milagre).

    acho que a galera que usa a versão 3.0, poderia começar a colocar pra funcionar e postar os resultados, que sera bem vindos.


    saip

    o sol nasce para todos, mas alguns dorme um pouco mais........



  11. #11

    Padrão

    da pra fazer com o 2.9 usando um metodo nao tradicional.. como mencionei.. o squid adiciona marcacoes no header de cada objeto.. indicando se este objeto esta sendo um HIT (do cache) ou um MISS (internet)

    basta usar o modulo de marcação de pacotes para detectar este header.. quando detectado.. ele marca a CONEXAO e joga fora do controle de banda...

  12. #12

    Padrão Eu tentei

    Bom pessoal eu migrei meu mk de 2.9.48 pra 3.10 nossa rodou legal fez o cache show mas não consegui ficar operando com ele por muito tempo pela quantidade de bugs e problemas que acontecia, eu acho muito cedo pra migrar um server em produção eu tentei em uma madrugada e rodou legal mas quando entrou todos ae começou reiniciar sozinho travar e etc

    acho melhor aguardar mais



  13. #13

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    da pra fazer com o 2.9 usando um metodo nao tradicional.. como mencionei.. o squid adiciona marcacoes no header de cada objeto.. indicando se este objeto esta sendo um HIT (do cache) ou um MISS (internet)

    basta usar o modulo de marcação de pacotes para detectar este header.. quando detectado.. ele marca a CONEXAO e joga fora do controle de banda...
    se for possivel, coloque as regras ai pra nos,

    obrigado

    saip

    o sol nasce para todos, mas alguns dorme um pouco mais..

  14. #14

    Padrão regras

    eu nao tenho regras so configurado mesmo tem como exportar o meu mk pra script se tiver eu coloco



  15. #15

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    eu nao tenho regras so configurado mesmo tem como exportar o meu mk pra script se tiver eu coloco
    tem sim, vc entra pelo wimbox, vai new terminal,

    vai ate o local da regra, por exemplo: ip firewall mangle, export.

    ok


    saip

    o sol nasce para todos, mas alguns dorme um pouco mais...

  16. #16

    Padrão mangle

    ip firewall mangle
    add chain=prerouting action=mark-packet new-packet-mark=test-up passthrough=no in-interface=Local comment="" disabled=yes
    add chain=forward action=mark-connection new-connection-mark=test-conn passthrough=yes comment="" disabled=yes
    add chain=forward action=mark-packet new-packet-mark=test-down passthrough=no in-interface=Public connection-mark=test-conn comment="" disabled=yes
    add chain=output action=mark-packet new-packet-mark=test-down passthrough=no out-interface=Local comment="" disabled=yes
    add chain=prerouting action=mark-connection new-connection-mark=ICMP_conn passthrough=yes protocol=icmp comment="ICMP" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=ICMP_Packet passthrough=no protocol=icmp connection-mark=ICMP_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=dns_conn passthrough=yes dst-port=53 protocol=udp comment="Dns" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=dns_packet passthrough=no dst-port=53 protocol=udp connection-mark=dns_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=http_conn passthrough=yes dst-port=80 protocol=tcp comment="Prioriza servi os web" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=http_packet_mark passthrough=no dst-port=80 protocol=tcp connection-mark=http_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=MSN_Connetcion passthrough=yes dst-port=1863 protocol=tcp comment="Msn Messenger" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=Msn_packet passthrough=no dst-port=1863 protocol=tcp connection-mark=MSN_Connetcion comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=https_connection passthrough=yes dst-port=443 protocol=tcp comment="Prioriza Https" \
    disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=https_packet passthrough=no dst-port=443 protocol=tcp connection-mark=https_connection comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=mk_conn passthrough=yes dst-port=8291 protocol=tcp comment="MK" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=mk_packet passthrough=no dst-port=8291 protocol=tcp comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=dhcp_conn passthrough=yes dst-port=67-68 protocol=udp comment="dhcp" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=dhcp_packet passthrough=no dst-port=67-68 protocol=udp connection-mark=dhcp_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=udp0_conn passthrough=yes dst-port=0 protocol=udp comment="TEst 0" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=zero_packet passthrough=no dst-port=0 protocol=udp connection-mark=udp0_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=ftp_conn passthrough=yes dst-port=20-21 protocol=tcp comment="Ftp" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=ftp_packet passthrough=no dst-port=20-21 protocol=tcp connection-mark=ftp_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=orkut_conn passthrough=yes protocol=tcp src-address-list=Orkut comment="Orkut testes \
    Prioridade" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=orkut_packet passthrough=no protocol=tcp connection-mark=orkut_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=udp_conn passthrough=yes dst-port=22 protocol=tcp comment="UDP " disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=udp_packet passthrough=no dst-port=22 protocol=tcp connection-mark=udp_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=Ms_conn passthrough=yes dst-port=1755 protocol=tcp comment="Ms" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=ms_packet passthrough=no dst-port=1755 protocol=tcp connection-mark=Ms_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=skype_conn passthrough=yes dst-port=5060 protocol=tcp comment="skype" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=skype_packet passthrough=no dst-port=5060 protocol=tcp connection-mark=skype_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=conquer_conn passthrough=yes dst-port=5816 protocol=tcp comment="Conquer" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=Conquer_packet passthrough=no dst-port=5816 protocol=tcp connection-mark=conquer_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=pop3_conn passthrough=yes dst-port=110 protocol=tcp comment="POP" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=pop3_packet passthrough=no dst-port=110 protocol=tcp connection-mark=pop3_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=SMTP_conn passthrough=yes dst-port=25 protocol=tcp comment="SMTP" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=SMTP_packet passthrough=no dst-port=25 protocol=tcp connection-mark=SMTP_conn comment="" disabled=no
    add chain=output action=mark-connection new-connection-mark=proxyfull passthrough=yes src-port=3126 protocol=tcp comment="PROXY FULL" disabled=yes
    add chain=output action=mark-packet new-packet-mark=proxyfull passthrough=yes connection-mark=proxyfull comment="" disabled=yes
    add chain=output action=return connection-mark=proxyfull comment="" disabled=yes
    add chain=prerouting action=mark-connection new-connection-mark=stream_conn passthrough=yes dst-port=554 protocol=tcp comment="Stream" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=stream_packet passthrough=no dst-port=554 protocol=tcp connection-mark=stream_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=youtube_conn passthrough=yes src-address-list=youtube comment="YOUTUBE traffic" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=youtube_packet passthrough=no connection-mark=youtube_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=p2p_conn passthrough=yes p2p=all-p2p comment="Marca P2P" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=p2p_packet passthrough=no p2p=all-p2p connection-mark=p2p_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=conn_restantes passthrough=yes comment="Marcando o restante das conex es" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=restante_packet passthrough=no connection-mark=conn_restantes comment="" disabled=no



  17. #17

    Padrão

    Cache FULL 100%????
    e melhor esperar a versao 3.0 do MK.
    nessa versao 2.9 nao funfa 100% nao

  18. #18

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    ip firewall mangle
    add chain=prerouting action=mark-packet new-packet-mark=test-up passthrough=no in-interface=Local comment="" disabled=yes
    add chain=forward action=mark-connection new-connection-mark=test-conn passthrough=yes comment="" disabled=yes
    add chain=forward action=mark-packet new-packet-mark=test-down passthrough=no in-interface=Public connection-mark=test-conn comment="" disabled=yes
    add chain=output action=mark-packet new-packet-mark=test-down passthrough=no out-interface=Local comment="" disabled=yes
    add chain=prerouting action=mark-connection new-connection-mark=ICMP_conn passthrough=yes protocol=icmp comment="ICMP" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=ICMP_Packet passthrough=no protocol=icmp connection-mark=ICMP_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=dns_conn passthrough=yes dst-port=53 protocol=udp comment="Dns" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=dns_packet passthrough=no dst-port=53 protocol=udp connection-mark=dns_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=http_conn passthrough=yes dst-port=80 protocol=tcp comment="Prioriza servi os web" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=http_packet_mark passthrough=no dst-port=80 protocol=tcp connection-mark=http_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=MSN_Connetcion passthrough=yes dst-port=1863 protocol=tcp comment="Msn Messenger" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=Msn_packet passthrough=no dst-port=1863 protocol=tcp connection-mark=MSN_Connetcion comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=https_connection passthrough=yes dst-port=443 protocol=tcp comment="Prioriza Https" \
    disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=https_packet passthrough=no dst-port=443 protocol=tcp connection-mark=https_connection comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=mk_conn passthrough=yes dst-port=8291 protocol=tcp comment="MK" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=mk_packet passthrough=no dst-port=8291 protocol=tcp comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=dhcp_conn passthrough=yes dst-port=67-68 protocol=udp comment="dhcp" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=dhcp_packet passthrough=no dst-port=67-68 protocol=udp connection-mark=dhcp_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=udp0_conn passthrough=yes dst-port=0 protocol=udp comment="TEst 0" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=zero_packet passthrough=no dst-port=0 protocol=udp connection-mark=udp0_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=ftp_conn passthrough=yes dst-port=20-21 protocol=tcp comment="Ftp" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=ftp_packet passthrough=no dst-port=20-21 protocol=tcp connection-mark=ftp_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=orkut_conn passthrough=yes protocol=tcp src-address-list=Orkut comment="Orkut testes \
    Prioridade" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=orkut_packet passthrough=no protocol=tcp connection-mark=orkut_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=udp_conn passthrough=yes dst-port=22 protocol=tcp comment="UDP " disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=udp_packet passthrough=no dst-port=22 protocol=tcp connection-mark=udp_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=Ms_conn passthrough=yes dst-port=1755 protocol=tcp comment="Ms" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=ms_packet passthrough=no dst-port=1755 protocol=tcp connection-mark=Ms_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=skype_conn passthrough=yes dst-port=5060 protocol=tcp comment="skype" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=skype_packet passthrough=no dst-port=5060 protocol=tcp connection-mark=skype_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=conquer_conn passthrough=yes dst-port=5816 protocol=tcp comment="Conquer" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=Conquer_packet passthrough=no dst-port=5816 protocol=tcp connection-mark=conquer_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=pop3_conn passthrough=yes dst-port=110 protocol=tcp comment="POP" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=pop3_packet passthrough=no dst-port=110 protocol=tcp connection-mark=pop3_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=SMTP_conn passthrough=yes dst-port=25 protocol=tcp comment="SMTP" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=SMTP_packet passthrough=no dst-port=25 protocol=tcp connection-mark=SMTP_conn comment="" disabled=no
    add chain=output action=mark-connection new-connection-mark=proxyfull passthrough=yes src-port=3126 protocol=tcp comment="PROXY FULL" disabled=yes
    add chain=output action=mark-packet new-packet-mark=proxyfull passthrough=yes connection-mark=proxyfull comment="" disabled=yes
    add chain=output action=return connection-mark=proxyfull comment="" disabled=yes
    add chain=prerouting action=mark-connection new-connection-mark=stream_conn passthrough=yes dst-port=554 protocol=tcp comment="Stream" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=stream_packet passthrough=no dst-port=554 protocol=tcp connection-mark=stream_conn comment="" \
    disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=youtube_conn passthrough=yes src-address-list=youtube comment="YOUTUBE traffic" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=youtube_packet passthrough=no connection-mark=youtube_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=p2p_conn passthrough=yes p2p=all-p2p comment="Marca P2P" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=p2p_packet passthrough=no p2p=all-p2p connection-mark=p2p_conn comment="" disabled=no
    add chain=prerouting action=mark-connection new-connection-mark=conn_restantes passthrough=yes comment="Marcando o restante das conex es" disabled=no
    add chain=prerouting action=mark-packet new-packet-mark=restante_packet passthrough=no connection-mark=conn_restantes comment="" disabled=no
    Olá carinha...
    essas suas regras ai...ele faz o (cache) ou o melhoramento da entrega do site Orkut e Youtube....

    pois montei eles aqui e não passa trafego por eles

    Grato pela atenção



  19. #19

    Padrão

    isso mesmo melhor esperar a V.3 pq na v2.9 o mk ñ sabe de ond vem da net ou do cache miss ou hit...para ser liberado em fullllllll...


    vamos aguardar a v.3 flws.....

  20. #20

    Padrão cache full

    qual a definição de cache full? acho que a galera não esta entendendo muito o que é cache full e como funciona.