+ Responder ao Tópico



  1. #1

    Padrão WebProxy no MK nao to conseguindo!

    Pessoal, estou com uma duvida, tenho um servidor no MK rodando webproxy ate configurar eu consegui, so q na hora de rodar a maquina ele nao fica transparente, tem q ir na configuracao do IE e colocar o proxy e a porta, como resolvo isso?
    grato
    Rafael

  2. #2

    Padrão

    cara vc fez o redirecionamento para o proxy na nat?
    veja se é este o problema, qualquer coisa posta as tuas conf aqui



  3. #3

    Padrão

    [[email protected]] ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=dstnat in-interface=ether1 protocol=tcp dst-port=80 action=redirect
    to-ports=8080


    copiei do tutorial daqui a regra, sera q tem algo errado!

  4. #4

    Padrão

    as duas regras para o nat


    1 chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 action=redirect
    to-ports=3128

    2 chain=srcnat out-interface=ether1 action=masquerade


    a primeira é o redirecionamento da porta 80 para o webproxy aqui eu utilizo a porta 3128
    a segunda é o mascaramento da interface de saida

    veja o seguinte a primeira regra é setada na placa de rede em que esta configurado a faixa de ips dos dos seus clientes.
    a segunda regra é a que esta configurada o ip da sua operadora (rede que vai pro roteador)

    as regras de nat são estas, coloque e teste se não funcionar mande as regras do webproxy pra nos analisarmos ...

    Aprender é saber compartilhar ...



  5. #5

    Padrão

    CONFIGURACAO DO WEBPROXY

    [[email protected]] ip web-proxy> print
    enabled: yes
    src-address: 0.0.0.0
    port: 8080
    hostname: "proxy"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "webmaster"
    max-object-size: 4096KiB
    cache-drive: system
    max-cache-size: 6144000KiB
    max-ram-cache-size: 358400KiB
    status: running
    reserved-for-cache: 6144000KiB
    reserved-for-ram-cache: 195584KiB
    [[email protected]] ip web-proxy>
    HTTP proxy

    CONFIGURACAO DO CACHE

    [[email protected]] ip web-proxy cache> print
    Flags: X - disabled, I - invalid
    0 ;;; don't cache dynamic http pages
    url=":cgi-bin \\\\?" action=deny

    1 url="https://" action=deny
    [[email protected]] ip web-proxy cache>



    CONFIGURACAO DO FIREWALL
    [[email protected]] ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=dstnat in-interface=ether1 protocol=tcp dst-port=80 action=redirect to-ports=8080

    1 chain=srcnat out-interface=ether2 action=masquerade
    [[email protected]] ip firewall nat>


    [email protected]] ip firewall filter> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; BLOQUEIO WEB PROXY EXTERNO
    chain=input in-interface=ether2 protocol=tcp dst-port=8080 action=drop
    [[email protected]] ip firewall filter>


    q que tem de errado nessas configuracoes?


    grato
    Rafael
    Última edição por rfferraz; 29-11-2007 às 18:34.

  6. #6

    Padrão

    chain=dstnat action=dst-nat to-addresses=xxx.xxx.xxx.xxx to-ports=3128 in-interface=!(seu link) src-address=!0.0.0.0/0
    dst-port=80 protocol=tcp



  7. #7

    Padrão

    adicione o mascaramento no nat

    2 chain=srcnat out-interface=ether1 action=masquerade

    ether1 é a inteface que vai pro roteador

  8. #8

    Padrão

    pessoal com esta configuraçao de nosso amigo eu montei meu web-proxy .......
    obrigado a todos pelo o topico ....... mas e agora como eu sei se esta funcionando ???



  9. #9

    Padrão

    Citação Postado originalmente por calangonet Ver Post
    adicione o mascaramento no nat

    2 chain=srcnat out-interface=ether1 action=masquerade

    ether1 é a inteface que vai pro roteador
    Funcionou com essa regra, mas qndo coloco o proxy nas configuracoes do IE ele responde mais rapido!oq pode ser?