+ Responder ao Tópico



  1. #1
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Clientes por trás do NAT não acessam FTP

    Saudações a todos.

    Estou com um problema onde clientes atrás do NAT no mikrotik não conseguem listar arquivos de FTP externos. A conexão é feita, mas na hora de listar ocorre um erro. Não existe nenhuma regra para porta 21. Alguem já passou por isso? Estou usando a versão crackeada 2.9.27.

    Agradeço desde já.

    Gabriel Mota

  2. #2

    Padrão

    Citação Postado originalmente por motacosta Ver Post
    Saudações a todos.

    Estou com um problema onde clientes atrás do NAT no mikrotik não conseguem listar arquivos de FTP externos. A conexão é feita, mas na hora de listar ocorre um erro. Não existe nenhuma regra para porta 21. Alguem já passou por isso? Estou usando a versão crackeada 2.9.27.

    Agradeço desde já.

    Gabriel Mota
    Amigo você usa hotspot?



  3. #3
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Não

    Não amigo,

    Uso aqui uma classe 172.16.0.0/30 e um webproxy transparente e NAT.

  4. #4

    Padrão

    Citação Postado originalmente por motacosta Ver Post
    Não amigo,

    Uso aqui uma classe 172.16.0.0/30 e um webproxy transparente e NAT.
    Poste seu firewall então ae não.. A porta FTP (21), não é bloqueada não, a não ser se tiver alguma regra de firewall bloqueando ela...



  5. #5
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Firewall

    Caro amigo,

    No NAT só tenho o masquarede e uma outra regra do proxy transparente da porta 80 para 3128

    Agradeço muito sugestões.

    Gabriel Mota
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         post.JPG
Visualizações:	80
Tamanho: 	64,9 KB
ID:      	1445  

  6. #6
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Complemento

    Só para complementar,

    O problema ocorre com ou sem o proxy

    Atenciosamente

    Gabriel Mota



  7. #7

    Padrão

    simples..

    o cliente ftp precisa estar ativado para conexoes passivas (pasv ou passive mode)...

    quando vc da um ls .. ele tenta abrir uma conexao no ip da maquina (no caso ip invalido) .. com o passivel mode ele abre usando o servidor e fazendo o nat !!


  8. #8
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Problema resolvido

    Caro amigo alexandre,
    Muito obrigado pela dica, agora funcionou. Eu já tinha tentado isso, mas era tarde da noite eu devia tá fazendo alguma besteira. Agora funcionou bem.

    Muito obrigado a todos.

    Att.

    Gabriel Mota



  9. #9
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Complementando

    A opção passive mode na verdade foi DESABILITADA no ruindows explorer.

    Valeu.

  10. #10
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    No caso especifico do MT, às vezes, por desconhecimento ou descuido, desativamos em ip/firewall/services o nat helper referente ao FTP (21), que por padrão vem habilitado. Se isso ocorrer terá problemas para acessar servidores FTP quando atrás de NAT.