Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Exclamation Iniciando.....

    Boa tarde pesso all,
    Estou tentando dar meu primeiro passo com o MK, até hoje sempre usei rádios com APRouter, mas recebí orientações que uma rede de acesso aa internet gerenciada com MK a coisa anda bem melhor, por isso estou aki pedindo o auxílio de vcs...
    Já fiz alguma coisa seguindo informações obtidas aqui mesmo no forum, já está instalado num Pentium 4 com DDR-2 de 1 GB e HD de 80, e 3 interfaces de rede conseguí fazer funcionar o NAT, renomeei as interfaces ativei o DHC server, criei uma rota de saída, configurei o web proxy e fiz um controle de banda simples, adicionei uma regra de bloqueio do proxy externo.... enfim, tudo aquilo que estava nos tutos.
    Tenho agora só umas mil perguntas pra fazer, mas vou devagar pois imagino com deve ser chato pra vocês (muito experientes e ocupadíssimos), aguentar perguntas tão básicas oriundas de iniciantes como eu kkk...
    Pra começar gostaria de saber como comprovar se meu web proxy de fato está funcionando ?? não sei se tem haver, mas nunca vejo atividade no HD do pc que está o MK, é assim mesmo ??
    Só pra testar instalei em casa mesmo, onde tenho uma ADSL compartilhada com uns 7 vizinhos.
    Aproveitando, gostaria de saber se tem mais alguma regra importante a implementar nesse primeiro instante ??

    Ficaria muito agradecido se alguém se dispusesse a me ajudar..

    [] to all,

    IRON

  2. #2

    Padrão

    Caro amigo Iron,

    Não é nenhum pouco chato ajudar os companheiros. O que sei, que é bem pouco, aprendi aqui no fórum nesses ultimos meses.

    Então nada mais justo que compartilhar de graça o que me foi dado de graça.

    Vamos lá:

    Pra comprovar se o teu webproxy ta funcionando: no winbox, vai em ip / webproxy / settings, lá embaixo é pra estar aparecendo RUNNING e na aba status vai te dar o UPTIME (Tempo rodando), clientes, requests etc.

    Agora seguinte:

    se o seu mikrotik tiver rodando depois de um proxy, como analogx, etc. (como você disse, está compartilhando internet adsl) não vai gravar nada, pois o proxy muda a porta de navegação de 80 para 6188 por exemplo.

    Além disso, você não pode esquecer que tem que criar uma regra no NAT direcionando todos os seus pacotes para a porta do webproxy.

    !! Ela tem que ser a primeira regra. !!

    Abaixo um exemplo:

    chain=dstnat action=redirect to-ports=3128 in-interface=!ether1 dst-port=80 protocol=tcp

    (explicando: redirecionar todas as requisições de porta 80 não provenientes da ether para a porta 3128, essa exclamação é como se fosse uma excessão = tudo menos isso. Com isso ao invés de fazer num redirecionamento pra cada interface, fazemos apenas 1)

    espero ter ajudado e pode postar as suas dúvidas!



  3. #3

    Padrão

    Citação Postado originalmente por anarchist Ver Post
    Caro amigo Iron,

    Não é nenhum pouco chato ajudar os companheiros. O que sei, que é bem pouco, aprendi aqui no fórum nesses ultimos meses.

    Então nada mais justo que compartilhar de graça o que me foi dado de graça.

    Vamos lá:

    Pra comprovar se o teu webproxy ta funcionando: no winbox, vai em ip / webproxy / settings, lá embaixo é pra estar aparecendo RUNNING e na aba status vai te dar o UPTIME (Tempo rodando), clientes, requests etc.

    Agora seguinte:

    se o seu mikrotik tiver rodando depois de um proxy, como analogx, etc. (como você disse, está compartilhando internet adsl) não vai gravar nada, pois o proxy muda a porta de navegação de 80 para 6188 por exemplo.

    Além disso, você não pode esquecer que tem que criar uma regra no NAT direcionando todos os seus pacotes para a porta do webproxy.

    !! Ela tem que ser a primeira regra. !!

    Abaixo um exemplo:

    chain=dstnat action=redirect to-ports=3128 in-interface=!ether1 dst-port=80 protocol=tcp

    (explicando: redirecionar todas as requisições de porta 80 não provenientes da ether para a porta 3128, essa exclamação é como se fosse uma excessão = tudo menos isso. Com isso ao invés de fazer num redirecionamento pra cada interface, fazemos apenas 1)

    espero ter ajudado e pode postar as suas dúvidas!

    OK amigo Anarchist,

    muito grato pelas info. Fui lá no web proxy e constatei que está running, UPtime, clients request etc... mas a regra que vc se referiu não é a primeira, a primeira é uma regra de NAT MASQUERAD, que foi a primeira que apareceu lá no tutorial. Depois da sua informação eu desabilitei essa primeira e parece que continua tudo normal. Apenas essa questão do sinal " ! " a minha regra do web não tem.
    Me diz, resumindo então como uso link de ADSL, na prática esse web proxy não vai adiantar nasda ??
    Nesse primeiro momento estou testando o mikrotik em casa, mas a intenção é levá-lo pra um condomínio onde tem uns 40 usuários pra duas ADSL de 1 Mega.
    Atualmente tenho lá 2 AProuters e os clientes divididos em 2 grupos, todo mundo na mesma rede porém cada gropo com seu gateway.
    Agora a pergunta chave: você acredita que com a implantação do mikrotik lá, vai acontecer alguma melhoria no acesso desses clientes ??
    Já que o web não está fazendo diferença (pq é ADSL), vc acha que apenas com o serviço de DNS no mikrotik pode haver uma melhori na performance da navegação pra esses clientes ??

  4. #4

    Padrão

    o webproxy funciona sim em adsl, o que resta é configurar direitinho...

    o que eu disse é que ele (webproxy) não roda se tiver depois de um outro proxy, se você utilizar proxy, então não rola... entendeu?

    A regra nat masquerad tem que vir após a regra de direcionamento do webproxy...

    A questão do sinal de "!" é o seguinte:

    aqui eu utilizo 3 interfaces. ai para não fazer uma regra de webproxy para cada uma (wlan1 wlan2 wlan3), eu utilizo essa regra de excessão, ou seja: todas as interfaces menos ether.

    Bom, o mikrotik quase sempre tem um desempenho superior aos aprouters, mas cada caso é um caso.

    o mikrotik apenas tem um cache dns, não iria mudar muita coisa na navegação não, apenas uma certa diminuição no tempo gasto em cada requisição.

    O que acho que iria melhorar era em horários de pico, mas como são 20 clientes para cada rádio, não era muita coisa também não.



  5. #5

    Padrão

    (ah, e desculpa a forma meio desorganizada que respondi, é que to de saida... hehehehe)

  6. #6

    Padrão

    AA sim..

    agora me animei mais a usar o MK, aki não tenho outro proxy, somente o mikrotik atrás do modem ADSL roteado.

    Anarchist teria alguma forma de mudar a ordem das regras ? ou tenho que apagar e fazer novamente ??

    Quando vc diz "configurar direitinho", é justamente isso que eu preciso, vc poderia me mandar as regras ??

    Uma observação: em determinados momentos achei que a navegação estava muito lenta e às vezes nem abria páginas ( muuuito piór do que quando estava só no aprouter ) daí desativei o web proxy hoje de manhã ) agora tá uma beleza 100%, poderia ser a ordem das regras que estava afetando o desempenho ?



  7. #7

    Padrão

    pode ser configurações...

    vc teria que postar tudo pra gente ver.

  8. #8

    Padrão coloca outra HD!

    cara o MK nao funciona o cache proxy no mesmo hd que o sistema esteja instaldo. adiciona outra HD, ti garanto que vai ficar show.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         cache-proxy.JPG
Visualizações:	67
Tamanho: 	181,0 KB
ID:      	1515   Clique na imagem para uma versão maior

Nome:	         webproxy.JPG
Visualizações:	64
Tamanho: 	178,0 KB
ID:      	1516  




  9. #9

    Padrão

    Negobob, obrigado pela informação, ví seus screens e entendí. Me diz uma coisa, ví algum colega comentar que instalou o MK num compact flash, ou memória flash num sei ao certo, vc saberia onde compro isso e como funciona ? pq nesse caso eu instalo o mk na flash e deixo um HD apenas pra web-proxy com cache o que vc acha ?
    Outra pergunta é a seguinte comprei um HD de 1600 GB ( SATA ), mas o mk não reconheceu quando fui instalar daí troquei por um IDE de 80 GB e instalei normal. esquecí de testar, mas será que o mk reconheceria o SATA como secundário apenas pra cache ?? pois ele está aki parado sem uso.

    abçs,

  10. #10

    Padrão

    Anarchist, desculpe a demora na resposta, eu nem tinha visto seu post.
    Já resolví o problema da lentidão do proxy, um amigo aki do fórum me deu a dica, eu fiz e deu tudo certinho: é que a regra do NAT masquerade estava em primeiro lugar, daí foi só inverter e agora tá jóia o proxy.

    Brigadão,



  11. #11

    Padrão

    tranquilo,
    se tiver mais dúvidas tamos ai hehehhe

    abraços

  12. #12
    Moderador Avatar de xandemartini
    Ingresso
    Nov 2005
    Localização
    Espumoso, Brazil
    Posts
    2.410
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por iron Ver Post
    Negobob, obrigado pela informação, ví seus screens e entendí. Me diz uma coisa, ví algum colega comentar que instalou o MK num compact flash, ou memória flash num sei ao certo, vc saberia onde compro isso e como funciona ? pq nesse caso eu instalo o mk na flash e deixo um HD apenas pra web-proxy com cache o que vc acha ?
    Outra pergunta é a seguinte comprei um HD de 1600 GB ( SATA ), mas o mk não reconheceu quando fui instalar daí troquei por um IDE de 80 GB e instalei normal. esquecí de testar, mas será que o mk reconheceria o SATA como secundário apenas pra cache ?? pois ele está aki parado sem uso.

    abçs,
    Compact Flash e o adaptador ide vc compra em Adaptador CF IDE + Compact Flash Card = FLASH IDE

    Pode tranquilamente instalar o MK no Flash e deixar o HD para o proxy somente..



  13. #13

    Padrão Compact Flash nao recomendo!

    cara de um geitinho de passar pra frente sua Hd SATA e bota IDE mesmo! velho compact flash esquenta que e uma blz eu ja usei aqui e tirei logo!

  14. #14
    Moderador Avatar de xandemartini
    Ingresso
    Nov 2005
    Localização
    Espumoso, Brazil
    Posts
    2.410
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por negobob Ver Post
    cara de um geitinho de passar pra frente sua Hd SATA e bota IDE mesmo! velho compact flash esquenta que e uma blz eu ja usei aqui e tirei logo!
    Chegou a dar algum problema no teu flash? Pq aqui ja uso há dois anos os mesmos, em 2 bases, e nunca dei um defeitinho sequer...



  15. #15

    Thumbs up ....

    Citação Postado originalmente por xandemartini Ver Post
    Chegou a dar algum problema no teu flash? Pq aqui ja uso há dois anos os mesmos, em 2 bases, e nunca dei um defeitinho sequer...

    o problema aqui foi aquecimento e travava que era uma blz, mas nao podemos generalizar ne cada caso e um caso, si com vc a bagaça funciona 100% entao vai funcionar pra outros tambem e questao de gosto mesmo particulamente nao uso mais!
    forte abraço amigao!! fuiii

  16. #16
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Citação Postado originalmente por iron Ver Post
    Anarchist, desculpe a demora na resposta, eu nem tinha visto seu post.
    Já resolví o problema da lentidão do proxy, um amigo aki do fórum me deu a dica, eu fiz e deu tudo certinho: é que a regra do NAT masquerade estava em primeiro lugar, daí foi só inverter e agora tá jóia o proxy.

    Brigadão,

    Opa blz??? me da uma dica pq aki meu mk ta com proxy tb e ta lento que vc fez ao certo???

    falow valew



  17. #17

    Padrão

    edcom,

    não fiz nada demais, seguí o que estava no tutorial, mas a regra do nat do web-proxy deve ser a primeira, foi só isso.

    abçs,

  18. #18

    Padrão

    negobob, obrigado pela dica, vou passar o sata pra frente então.

    Veja só tenho uns dois hd´s IDE de pequena capacidade, tipo 4.3 GB e 2.5, posso aproveitá-los nesse caso ao invés de comprar os CF, pois instalo o MK neles e coloco um outro maior pro cache, desse jeito econtro uma utilidade pra eles, já que por serem pequenos não teriam mais nenhuma serventia, o que vc acha ? ou melhor qual seria um tamanho mínimo pra instalar o MK ??

    abçs,



  19. #19

    Smile opa..

    Cara tenho um mk rodando com uma Hd de 4,5GB, nunca me deu problema, mas particularmente não utilizo esses tipo de HD ta tão barato uma HD nova com R$80conto vc compra um de 40gb 7200rpm.. pro cache e super importante a rotação da hd, pq si vc tiver uma boa quantidade de cliente o tempo de acesso diminui bastante, ja penso mais de 30 clientes requisitando um arquivo no HD? Alem disso pense em longo prazo cara esses hd ai de 4gb ja deu o que tinha que da; num vão durar muito. Essa e minha singela opinião comecei agora também na onda do mikrotik!

    Forte abraço amigo! T+

  20. #20

    Padrão

    Blz, negobob, concordo com vc totalmente, foi isso mesmo que eu quiz dizer, colocar um hd novo pro cache, e esse pequeno só pro sistema....
    De qualquer jeito valeu a dica.

    Bração,