+ Responder ao Tópico



  1. #13

    Padrão Re: Marcação de rota de saída de internet e failover

    Citação Postado originalmente por Bruno Ver Post
    Bom Dia
    Uso o check gateway a um bom tempo e sempre funcionou alias o netwatch vai trabalha da mesma forma
    esse check ping so faz teste de comunicação entre a rb e o router, nao com a internet, se for um dsl tira o cabo dsl pra ti ver como ele nao vai ficar down


    Sent from my iPhone using UnderLinux

  2. #14

    Padrão Re: Marcação de rota de saída de internet e failover

    Citação Postado originalmente por daniellannes Ver Post
    esse check ping so faz teste de comunicação entre a rb e o router, nao com a internet, se for um dsl tira o cabo dsl pra ti ver como ele nao vai ficar down


    Sent from my iPhone using UnderLinux
    Por favor leia:
    http://wiki.mikrotik.com/wiki/Advanc...hout_Scripting


    Enviado de meu SM-G800H usando Tapatalk



  3. #15

    Padrão Re: Marcação de rota de saída de internet e failover

    Citação Postado originalmente por fhayashi Ver Post
    Vi lá @eduardomazolini,

    É o que faço por aqui para forçar alguns pacotes fluirem por determinado gateway. Assim consigo monitorar meus links pfsense no zabbix.

    Mas no post anterior, pelo meu pífio conhecimento dos comandos do MT, ele está checando o gateway, certo?

    /ip route
    add distance=1 gateway=link1 routing-mark=link1 check-gateway=ping
    add distance=2 gateway=link2 routing-mark=link1 check-gateway=ping

    add distance=1 gateway=link2 routing-mark=link2 check-gateway=ping
    add distance=2 gateway=link1 routing-mark=link2 check-gateway=ping
    Sim ele testa o Gateway, perfeito.
    A pergunta correta é quem é o gateway?

    Lá no link o exemplo é:
    /ip route
    add dst-address=Host1A gateway=GW1 scope=10
    add dst-address=Host1B gateway=GW1 scope=10
    add dst-address=Host2A gateway=GW2 scope=10
    add dst-address=Host2B gateway=GW2 scope=10

    Enviado de meu SM-G800H usando Tapatalk

  4. #16
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    4.045
    Posts de Blog
    1

    Padrão Re: Marcação de rota de saída de internet e failover

    Citação Postado originalmente por eduardomazolini Ver Post
    Por favor leia:
    http://wiki.mikrotik.com/wiki/Advanc...hout_Scripting


    Enviado de meu SM-G800H usando Tapatalk

    Cara
    Abandona querer que alguém deste fórum leia, nunca faram isto
    eu postei a fonte o cara não leu, eu falei que uso check vem outro falar que não funciona kkk comedia

    Introduction

    Let us suppose that we have several WAN links, and we want to monitor, whether the Internet is accessible through each of them. The problem can be everywhere.
    If your VPN cannot connect - then there's no problem, your default route with gateway=that-vpn-connection will be inactive.
    If your ADSL modem is down - then check-gateway=ping is on stage, and no problem again.
    But what if your modem is up, and telephone line is down? Or one of your ISP has a problem inside it, so traceroute shows only a few hops - and then stops...
    Some people use NetWatch tool to monitor remote locations. Others use scripts to periodically ping remote hosts. And then disable routes or in some other way change the behaviour of routing.
    But RouterOS facilities allow us to use only /ip routes to do such checking - no scripting and netwatch at all!


    ja que não tem coragem de traduzir vou traduzir pra vocês

    Introdução

    Vamos supor que temos vários links WAN, e queremos monitorar, se a Internet é acessível através de cada um deles. O problema pode estar em toda parte.
    Se a sua VPN não pode conectar - então não há problema, a sua rota padrão com porta = que-vpn-conexão ficará inativa.
    Se o seu modem ADSL é para baixo - em seguida, verificar-gateway = ping no palco, e não há problema novamente.
    Mas e se o modem estiver ligado e a linha telefônica desativada? Ou um dos seus ISP tem um problema dentro dele, então traceroute mostra apenas alguns saltos - e depois pára ...
    Algumas pessoas usam a ferramenta NetWatch para monitorar locais remotos. Outros usam scripts para fazer o ping de hosts remotos periodicamente. E, em seguida, desativar rotas ou de alguma outra forma alterar o comportamento de roteamento.
    Mas instalações RouterOS nos permitem utilizar apenas as rotas / IP para fazer essa verificação - nenhum scripting e NetWatch em tudo!



    Vamos supor que temos dois uplinks: GW1, GW2. Pode ser endereços de modems ADSL (como 192.168.1.1 e 192.168.2.1), ou endereços de interfaces PPP (como pppoe-out1 e PPTP-out1). Então, temos algumas regras de roteamento política, então todo o tráfego de saída está marcado com ISP1 (que vai para GW1) e ISP2 (que vai para GW2) marcas. E queremos monitorar Host1 via GW1 e Host2 via GW2 - aqueles que podem ser alguns sites populares da Internet, como Google, Yahoo, etc.
    Primeiro, crie rotas para esses hosts através de gateways correspondentes:

    / Ip route adicionar dst-address = gateway de Host1 = GW1 scope = 10 adicionar dst-address = gateway de Host2 = GW2 scope = 10Agora vamos criar regras para ISP1 marca de roteamento (um para principal porta de entrada, e outra para failover):

    / Ip route adicionar à distância = 1 porta de entrada = Host1 roteamento-mark = ISP1 check-porta = pingue adicionar à distância = 2 de gateway = Host2 roteamento-mark = ISP1 check-porta = pingueEssas rotas serão resolvidos de forma recursiva (ver Manual: IP / Route # Nexthop_lookup ), e será ativo somente se HostN é pingable.
    Em seguida, as mesmas regras para a marca ISP2:

    / Ip route adicionar à distância = 1 porta de entrada = Host2 roteamento-mark = ISP2 check-porta = pingue adicionar à distância = 2 de gateway = Host1 roteamento-mark = ISP2 check-porta = pingue


    isto se chama rota recursiva


    ai vem estes caras que caíram de paraquedas no fórum atrás de receita de bolo o under-linux virou o programa da ana maria braga pra provedor , estes novatos ai deveria ter mais respeito com o nohau de outros
    maldita inclusão digital, os cara pensa que provedor de internet e redes é igual vc tocar um bar que só vende pinga, por isto que os provedores estão queimado, o mercado cada vez mais prostituído,







  5. #17

    Padrão Re: Marcação de rota de saída de internet e failover

    OK me mandem:
    - o IP dos 2 gateways;
    - 2 IPs de uso privado de uma rede que você não possui.
    - 4 IPs de servidores da Internet que você confia e se 2 deles caírem vamos considerar que a Internet caiu.

    Enviado de meu SM-G800H usando Tapatalk

  6. #18

    Padrão Re: Marcação de rota de saída de internet e failover

    Citação Postado originalmente por eduardomazolini Ver Post
    Sim ele testa o Gateway, perfeito.
    A pergunta correta é quem é o gateway?

    Lá no link o exemplo é:
    /ip route
    add dst-address=Host1A gateway=GW1 scope=10
    add dst-address=Host1B gateway=GW1 scope=10
    add dst-address=Host2A gateway=GW2 scope=10
    add dst-address=Host2B gateway=GW2 scope=10

    Enviado de meu SM-G800H usando Tapatalk
    @eduardomazolini,
    Puuutz, agora que entendi, ele adiciona uma rota para o host e depois define ele mesmo como um gateway. Caraca, nunca tinha visto isso, até porque o que costumo testar não são roteadores mas IPs de alguns domínios que "considero" de alta disponibilidade. No PFSense eu faço uma regra para só ping de um host específico sair por um dos gateways, assim quando o zabbix manda o ping, na verdade ele está testando o link 'X'
    @Bruno,
    não é porque tem gente de provedor aqui que o fórum se resume a isso. Não tenho nada a ver com ISP mas acho o under-linux uma tremenda referência quando preciso de informações sobre redes em geral. Afinal, nem sou técnico de redes, minha área é mais de gestão mas todo mundo que nasce técnico gosta de escovar uns bits. Nem sei quantas vezes fiz uma coisa baseada nas especificações de um manual e depois de 3 horas vi que esqueci de algo e estava bem debaixo do nariz. Como vc é da área, tenho certeza que já passou por isso também.