Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Script para remover o virus CoinHive do Mikrotik

    Aqueles que tiveram seus Mikrotiks infectados pelo virus CoinHive e precisa remover....
    Siga os procedimentos abaixo:

    1 - Copie e cole o script abaixo em seu Mikrotik:
    Código :
    /ip firewall filter remove [find comment=sysadminpxy]
    /ip firewall nat remove [find comment=sysadminpxy]
    /ip proxy set enabled=no
    /ip service disable ftp,www-ssl,api,api-ssl
    /user remove ftu
    /user group remove ftpgroupe
    /system scheduler remove [find where name~"upd"]
    /file remove u113.rsc
    /system package update set channel=bugfix
    :log info "Verificando versao...";
    /system package update
    check-for-updates once
    :delay 1s;
    :if ([get installed-version] != [get latest-version]) do={
         :log info "Atualizando versao";
         install;
         } else={
         :log info "Nenhuma atualizacao de versao necessaria"
         }
     
    :log info "Verificando firmware...";
    /system routerboard
    :if ([get current-firmware] != [get upgrade-firmware]) do={
         :log info "Atualizando firmware";
         upgrade;
         :delay 15s;
         /system reboot
         } else={
         :log info "Nenhuma atualizacao de firmware necessaria"
         }

    OBS: Repita o passo acima 2x.
    Pois na primeira, ele irá remover o vírus e atualizar a RB para a ultima versão Bugfix.
    Na segunda, ele irá verificar se precisa atualizar o firmware também.

    2 - Altere todas as suas senhas.

    3 - Atualize seu Winbox.


    Pronto, virus removido.
    Agora, não esqueça de manter seus equipamentos atualizados e evitar esse transtorno.
    Caso deseje, segue script para atualização em massa dos equipamentos mikrotik:
    https://under-linux.org/showthread.php?t=190145

  2. #2

    Padrão Re: Script para remover o virus CoinHive do Mikrotik

    Muito bom Andrio



  3. #3

    Padrão Re: Script para remover o virus CoinHive do Mikrotik

    E se não tiver mais acesso ao mikrotik devido ao vírus ter alterado os usuarios e senhas? nem por ssh, nem por mac telnet da acesso, o identify da RB ficou como "test"

  4. #4

    Padrão Re: Script para remover o virus CoinHive do Mikrotik

    Citação Postado originalmente por Slipminal Ver Post
    E se não tiver mais acesso ao mikrotik devido ao vírus ter alterado os usuarios e senhas? nem por ssh, nem por mac telnet da acesso, o identify da RB ficou como "test"
    Nesse caso, só com reset.



  5. #5

    Padrão Re: Script para remover o virus CoinHive do Mikrotik

    Ola @AndrioPJ ácrito que estamos do mesmo lado pensando nisso fiz uma ferramenta para ajudar na descoberta dos famosos vírus e esta online se puder passe a diante.
    Link da ferramenta
    https://bylltec.com.br/site/gestorserver/antivirus/

    Fis um post
    https://under-linux.org/showthread.php?t=190231

    Lembrando que a pagina de erro.html do proxy esta sendo afetada para mineração tem que tirar.

  6. #6

    Padrão Re: Script para remover o virus CoinHive do Mikrotik

    Ata! Tu quer que o povo informe a senha de seus equipamentos no teu site? Mas que bondoso!

    Gente olho aberto e cinto apertado! Mesmo que a intenção seja boa, você está informando os dados de acesso de seus roteadores e dando acesso a um desconhecido. Eu não estou criticando nada, mas eu não farei. E alerto a ninguém fazer.