+ Responder ao Tópico



  1. #181

    Padrão re: Configurar BGP

    Pessoal.

    Nesse post do Alexandre https://under-linux.org/f143/bgp-em-...38/#post355944 onde ele ensina passo a passo a configurar o bgp no Mk, tenho uma dúvida.

    1 - Ele cita la apenas pra 1 operadora, certo? E pra essa primeira coloco o ip 189.200.200.1 na ether que vai entrar essa operadora certo? E esse Ip também é o que falei pra operadora?

    2 - No caso de outra operadora, teria que passar outro ip (poderia ser o 189.200.200.2?) e colocar ele na outra ether onde essa segunda operadora vai entrar, certo?

    3 - Assumindo que tenho um bloco /20. Nos 2 itens acima, como que seria feito a mascara?
    Como quero redundancia (/21 em cada operadora e caso alguma caia, delegue o /20 pra que estiver on), tenho que fazer como exatamente?

    Muito obrigado.
    abraços.

  2. #182
    Moderador Avatar de xandemartini
    Ingresso
    Nov 2005
    Localização
    Espumoso, Brazil
    Posts
    2.410
    Posts de Blog
    1

    Padrão re: Configurar BGP

    Pessoal, deixa eu aproveitar o tópico e fazer uma pergunta. Tenho sessão BGP com 2 operadoras, OI e Unotel. Anuncio em ambas o seguinte:
    Unotel:
    Código :
     #   NETWORK              SYNCHRONIZE
     0   187.XXX.64.0/21       no         
     1   187.XXX.65.0/24       no         
     2   187.XXX.66.0/24       no         
     3   187.XXX.67.0/24       no         
     4   187.XXX.72.0/22       no         
     5   187.XXX.68.0/24       no

    OI:
    Código :
     #   NETWORK              SYNCHRONIZE
     0   187.XXX.64.0/21       no         
     1   187.XXX.68.0/22       no         
     2   187.XXX.64.0/24       no         
     3   187.XXX.68.0/24       no

    Como podem perceber, anuncio o /21 em ambas, e anuncios específicos para distribuir os clientes nos 2 links. Acontece que os clientes do bloco 187.XXX.68.0/24, por exemplo (acontece também em outros blocos anunciados na OI), não estão conseguindo acessar sites como hotmail.com, fiat.com.br, americanas.com, etc.. Até estou anunciando esse 187.XXX.68.0/24 em ambas operadoras para contornar esse problema temporariamente. O que poderia ser?

    Outra coisa esquisita que está acontecendo é o seguinte: este anuncio do bloco 187.XXX.68.0/24 não existia na OI, ele estava dentro do 187.XXX.64.0/22, mas depois q anunciei ele uma vez, se tento remover agora, os clientes q estão nele não navegam mais, mesmo estando contidos dentro do anuncio maior /22. O que pode ser?



  3. #183

    Padrão re: Configurar BGP

    Amigos primeiro parabéns pelo tópico está realmente muito interessante e rico em informações valiosas!!!!! Me ajudou demais na ativação do meu ASN com a operadora.

    Estou com algumas dúvidas que vou descrever a seguir:

    A minha seção BGP já está rodando e funcionando, porém a operadora não conseguiu estabelecer a seção via interface loop-back então pergunto tem algum problema a seção ficar via serial mesmo ou terei algum tipo de problema no futuro?? Está FULL-ROUTING Estou usando Mikrotik 4.10.


    Tenho uma rede bem extensa, atualmente tenho vários blocos de ip´s com a Embratel, mas pretendo retirar todos eles e passar a usar os do meu CIDR, sempre usei roteamento estático para distribuição das rotas, recebendo esse link via BGP terei alguma vantagen em distribuir dentro da minha rede usando OSPF?? Ou roteamento estático continuara me atendendo bem??


    Quais cuidados devo tomar ao anunciar as rotas?? Que filtros utilizar?? Quais as melhores práticas ??


    Inicialmente anunciei um /24 do meu CIDR, e está perfeito, pretendo deixar esse primeiro bloco como a WAN dos meus servidores e apontar um /26 na LAN pra dentro de cada um deles mantendo uma classe de ip´s pra cara servidor na rede e ai fazer NAT ou mesmo atribuir ip´s públicos de acordo com a necessidade e demanda, estou correto? Existe uma maneira melhor de se manusear esses blocos ??

    Outra coisa que gostaria de saber é com relação a não propagação de rotas não abertura de sites etc... Uma maneira de saber por exemplo se meu router tem acesso a tudo na internet e vice versa alguma maneira analisar, vi alguns comentários de sites que não abriam por falta de propagação essas coisas.




    Desde já muito obrigado a todos!!

  4. #184

    Padrão re: Configurar BGP

    pessoal,

    alguem pode me dar uma luz para poder fazer com que tais blocos saiam por tais operadoras? é marcando pacote?
    e quanto a um link parar e outro assumir?

    Obrigado



  5. #185

    Padrão re: Configurar BGP

    Galera,
    Adquiri o AS, recebi o bloco e o ASN do registro. E agora?
    Na pagina do registro estão me pedindo o as-in e as-out, mas não aceita o AS do meu provedor. Li a RFC mas não entendi:
    RFC 1786 Traduo Portugus.

    Obrigado

  6. #186

    Padrão re: Configurar BGP

    as-in e as-out no registro.br nao precisa preencher

    o que vc precisa eh entrar em contato com as operadoras que te atendem e solicitar sessão bgp.. somente assim voce publica seu bloco pelo seu ASN



  7. #187

    Padrão re: Configurar BGP

    Citação Postado originalmente por alexandrecorrea Ver Post
    o que vc precisa eh entrar em contato com as operadoras que te atendem e solicitar sessão bgp.. somente assim voce publica seu bloco pelo seu ASN
    Obrigado pela atenção Alexandre, recebi os formulários de ambas as operadoras. Eu preciso fechar um iBGP entre elas ou posso simplesmente fazer com uma e depois com outra?
    Essa duvida apareceu porque estão questionando no formulario:
    Blocos CIDR Neighbors do AS do Cliente:

    Obrigado,

  8. #188

    Padrão re: Configurar BGP

    iBGP vc usa somente se voce for fechar BGP entre os SEUS roteadores (no caso de ter mais de 1)

    com as operadoras voce fecha é eBGP !

    pode fazer com uma.. e depois com a outra !



  9. #189

    Padrão re: Configurar BGP

    Alexandre,
    [editado] Resolvi o problema que tinha. Fechei com a segunda operadora e ta 100%.

    Obrigado,
    Última edição por brick; 27-07-2010 às 17:19. Razão: Resolvido

  10. #190

    Padrão re: Configurar BGP

    Caros Colegas,
    Situação é a seguinte, com a ajuda do forum o BGP tá configurado e funcionando, só que estou com uma pendecia no PTT, eles pediram para eu segmentar o Bloco em /21 e aunciar na minha operadora 200.200.0.0/20 e no PTT 200.200.0.0/21 e no 200.200.8.0/21, para que o tráfego tenha preferencia pelo PTT para todos os participantes, o que está acontecendo é que estou com dificuldades de aplicar os filtros, alguem tem uma ideia de como fazer isso ??? Obrigado pela atenção



  11. #191

    Padrão re: Configurar BGP

    Citação Postado originalmente por pabloferretti Ver Post
    Caros Colegas,
    Situação é a seguinte, com a ajuda do forum o BGP tá configurado e funcionando, só que estou com uma pendecia no PTT, eles pediram para eu segmentar o Bloco em /21 e aunciar na minha operadora 200.200.0.0/20 e no PTT 200.200.0.0/21 e no 200.200.8.0/21, para que o tráfego tenha preferencia pelo PTT para todos os participantes, o que está acontecendo é que estou com dificuldades de aplicar os filtros, alguem tem uma ideia de como fazer isso ??? Obrigado pela atenção
    Se você colocar as configurações como eles estão agora fica mais fácil de ajudarmos em ver o que está faltando.

  12. #192

    Padrão re: Configurar BGP

    é so voce cria um filtro descartando o anuncio desses prefixos para os seus upstreams.



  13. #193

    Padrão re: Configurar BGP

    Citação Postado originalmente por rubensk Ver Post
    Se você colocar as configurações como eles estão agora fica mais fácil de ajudarmos em ver o que está faltando.
    Segue:

    /routing bgp instance
    set default as=65530 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=no redistribute-ospf=no \
    redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=0.0.0.0 routing-table=""
    add as=262000 client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=bgp-operadora out-filter=OUT_OPERADORA redistribute-connected=no redistribute-ospf=no \
    redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=200.0.0.1 routing-table=""
    add as=262000 client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=bgp-ptt out-filter=OUT_PTT redistribute-connected=no redistribute-ospf=no \
    redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=200.219.0.1 routing-table=""
    /routing bgp network
    add comment="" disabled=no network=200.0.0.0/20 synchronize=no
    add comment="" disabled=no network=200.0.0.0/21 synchronize=no
    add comment="" disabled=no network=200.0.8.0/21 synchronize=no

    /routing bgp peer
    add address-families=ip as-override=no comment="" default-originate=never disabled=yes hold-time=3m in-filter="" instance=bgp-ptt interface=vlan1-PTT multihop=no name=peer1 \
    nexthop-choice=default out-filter="" passive=no remote-address=200.219.0.252 remote-as=20001 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default update-source=\
    vlan1-PTT use-bfd=no
    add address-families=ip as-override=no comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=bgp-ptt interface=vlan1-PTT multihop=no name=peer2 \
    nexthop-choice=default out-filter="" passive=no remote-address=200.219.0.253 remote-as=26000 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default update-source=\
    vlan1-PTT use-bfd=no
    add address-families=ip as-override=no comment="" default-originate=never disabled=yes hold-time=3m in-filter="" instance=bgp-ptt interface=vlan1-PTT multihop=no name=peer3 \
    nexthop-choice=default out-filter="" passive=no remote-address=200.219.0.254 remote-as=26000 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default update-source=\
    vlan1-PTT use-bfd=no
    add address-families=ip as-override=no comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=bgp-operadora multihop=yes name=peer4 nexthop-choice=default \
    out-filter="" passive=no remote-address=200.148.0.251 remote-as=16001 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default use-bfd=no
    add address-families=ip as-override=no comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=bgp-operadora multihop=yes name=peer5 nexthop-choice=default \
    out-filter="" passive=no remote-address=200.148.0.250 remote-as=16001 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default use-bfd=no
    /routing filter
    add action=discard chain=OUT_PTT comment="" disabled=no invert-match=no prefix=200.0.0.0/20
    add action=discard chain=OUT_OPERADORA comment="" disabled=no invert-match=no prefix=200.0.0.0/21
    add action=discard chain=OUT_OPERADORA comment="" disabled=no invert-match=no prefix=200.0.8.0/21
    Última edição por pabloferretti; 21-09-2010 às 13:28.

  14. #194

    Padrão re: Configurar BGP

    Bom e tem outro detalhe tambem, o pessoal do PTT falou que estou enviando as rotas que recebo de volta " /routing bgp> peer print status
    name="peer1" instance=bgp-ptt remote-address=200.219.0.252 remote-as=20001 tcp-md5-key="" nexthop-choice=default multihop=no route-reflect=no hold-time=3m ttl=defau
    in-filter="" out-filter="" address-families=ip update-source=vlan1-PTT interface=vlan1-PTT default-originate=never remove-private-as=no as-override=no passive=no use-
    remote-id=200.219.0.252 local-address=200.219.0.168 uptime=33m24s prefix-count=0 updates-sent=2120 updates-received=0 withdrawn-sent=286 withdrawn-received=0
    remote-hold-time=3m used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established

    Como bloquear isso ?



  15. #195

    Padrão re: Configurar BGP

    pablo.

    voce deve criar filtros permitindo o anuncio somente do seu CIDR e descartar todo o restante. bem como descartar o recebimento do seu CIDR pelos upstreams.

    E referente ao PTT, porque criou outra instancia?

  16. #196

    Padrão re: Configurar BGP

    Citação Postado originalmente por anjunior Ver Post
    pablo.

    voce deve criar filtros permitindo o anuncio somente do seu CIDR e descartar todo o restante. bem como descartar o recebimento do seu CIDR pelos upstreams.

    E referente ao PTT, porque criou outra instancia?
    Bom referente a segunda instancia, foi uma maneira que encontrei para criar os filtros, anunciando na primeira instancia 2 blocos /21 e na segunda instancia um bloco /20, mas aceito recomendações... to perdidinho no cisco é tranquilo tem um monte de referencia agora no MK tá meio complicado, se puder postar algum exemplo de script para essa minha configuração...



  17. #197

    Padrão re: Configurar BGP

    /routing filter
    add action=discard chain=OUT_OPERADORA comment="" disabled=no invert-match=yes prefix=200.0.0.0/20
    add action=passthrough chain=OUT_PTT comment="" disabled=no invert-match=no prefix=200.0.0.0/21
    add action=discard chain=OUT_PTT comment="" disabled=no invert-match=yes prefix=200.0.8.0/21

    E não tem porque usar duas instâncias, use uma só.

  18. #198

    Padrão re: Configurar BGP

    faz como o rubens passou.
    no entanto voce nao aplica o filtro na instancia, so precisa aplicar nos peers.

    voce so usa na instancia se fosse filtro comum a todos os peers.



  19. #199

    Padrão re: Configurar BGP

    Citação Postado originalmente por rubensk Ver Post
    /routing filter
    add action=discard chain=OUT_OPERADORA comment="" disabled=no invert-match=yes prefix=200.0.0.0/20
    add action=passthrough chain=OUT_PTT comment="" disabled=no invert-match=no prefix=200.0.0.0/21
    add action=discard chain=OUT_PTT comment="" disabled=no invert-match=yes prefix=200.0.8.0/21

    E não tem porque usar duas instâncias, use uma só.
    Vou aplicar os filtros, e depois posto os resultados. obrigado.

  20. #200

    Padrão re: Configurar BGP

    Seguinte esses filtros não deu certo, usei como referencia o site abaixo:

    MikroTik RouterOS • View topic - BGP routing filter syntax

    Agora tá 100%

    Obrigado a todos