+ Responder ao Tópico



  1. #201

    Padrão re: Configurar BGP

    Pessoal para futuras consultas dos parceiros, o cenario abaixo anuncia 1 bloco /20 na Operadora e 2 Blocos /21 no PTT, isso é foi solicitado pelo PTT porque o anuncio de menor bloco tem preferencia,

    0 chain=OUT_OPERADORA prefix=200.200.0.0/20 invert-match=no action=accept
    1 chain=OUT_OPERADORA invert-match=no action=discard
    2 chain=OUT_PTT prefix=200.200.0.0/21 invert-match=no action=accept
    3 chain=OUT_PTT prefix=200.200.8.0/21 invert-match=no action=accept
    4 chain=OUT_PTT invert-match=no action=discard

    Qualquer duvida ou sujestão é só chamar, obrigado.
    Última edição por pabloferretti; 22-09-2010 às 09:30.

  2. #202

    Ingresso
    Sep 2005
    Localização
    Cascavel, Parana, Brazil, Brazil
    Posts
    41

    Padrão re: Configurar BGP

    Olá pessoal,

    Atualmente estou implantando o seguinte cenário aqui. Tenho dois Routers em duas cidades distintas.
    Na cidade A tenho BGP com a GVT e OI, Full e Partial respectivamente anunciando um /21 em ambas.
    Na cidade B tenho BGP com OI, Partial e anunciando o /21 restante do meu /20.
    Neste modelo, tem funcionado bem conforme pode ser observado neste tópico.

    Agora, por motivos $$ preciso interligar a cidade A e B, e manter estes links.
    Criei uma nova instancia BGP entre os roteadores A e B e no roteador A redistribute other bgp esta habilitado em ambas as instancias. Assim, o BGP é estabelecido entre os 2 roteadores e os anuncios enviados. Desativo o BGP com a Oi da cidade B e tudo funciona normalmente.
    Tenho problemas quando ativo a seção BGP do roteador B com a Oi. De fora não consigo chegar aos ips do anuncio do roteador B. Fazendo testes a partir do roteador B saio pelos 2 links normalmente (Roteador A e link local Oi).
    Testando pelo looking glass da GVT o tracert chega ao ip de destinho. Já por qualquer outra não é encontrado.
    Preciso que os clientes da Cidade B saiam pela Cidade A e pelo link local também.

    Alguma sugestão do que posso estar fazendo de errado? Abaixo as configs (ips ficticios) e o mapa da estrutura.

    Desde já agradeço a atenção.



    Router A:
    Código :
    /routing bgp instance
    add as=1234 client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=bgp_provedor out-filter=AS_provedor-out redistribute-connected=yes \
        redistribute-ospf=no redistribute-other-bgp=yes redistribute-rip=no redistribute-static=yes router-id=10.10.6.1 routing-table=""
    add as=65531 client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=interno out-filter="" redistribute-connected=no \
        redistribute-ospf=no redistribute-other-bgp=yes redistribute-rip=no redistribute-static=no router-id=192.168.123.1 routing-table=""
    /routing bgp network
    add comment="" disabled=no network=10.10.6.0/21 synchronize=no
    /routing bgp peer
    add address-families=ip,ipv6 as-override=no comment="" default-originate=never disabled=no hold-time=3m in-filter=BOGONS instance=bgp_provedor multihop=yes \
        name=peer_brt nexthop-choice=default out-filter=AS_OI-out passive=no remote-address=201.40.xxx.xxx remote-as=8167 remove-private-as=no route-reflect=no \
        tcp-md5-key="" ttl=255 update-source=loopback use-bfd=no
    add address-families=ip,ipv6 as-override=no comment="" default-originate=never disabled=no hold-time=3m in-filter=BOGONS instance=bgp_provedor multihop=yes \
        name=peer_gvt nexthop-choice=default out-filter=AS_GVT-out passive=no remote-address=201.47.xxx.xxx remote-as=18881 remove-private-as=no route-reflect=no \
        tcp-md5-key="" ttl=default update-source=loopback use-bfd=no
    add address-families=ip as-override=no comment="" default-originate=never disabled=yes hold-time=3m in-filter="" instance=interno max-prefix-limit=16 \
        multihop=yes name=ibgp_provedor nexthop-choice=default out-filter=out passive=no remote-address=192.168.123.2 remote-as=65531 remove-private-as=yes \
        route-reflect=no tcp-md5-key=Netprovedor! ttl=default update-source=vlan2 use-bfd=no
    Router B:
    Código :
    /routing bgp instance
    add as=1234 client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=bgp_provedor out-filter="" redistribute-connected=yes \
        redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=10.10.14.1 routing-table=""
    add as=65531 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=interno out-filter=AS_provedor-out redistribute-connected=no \
        redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=192.168.123.2 routing-table=""
    /routing bgp network
    add comment="" disabled=no network=10.10.14.0/21 synchronize=no
    /routing bgp peer
    add address-families=ip as-override=no comment="" default-originate=never disabled=no hold-time=3m in-filter=BOGONS instance=bgp_provedor multihop=yes name=\
        peer_brt-cidade_b nexthop-choice=default out-filter=AS_OI-out passive=no remote-address=201.40.xxx.xxx remote-as=8167 remove-private-as=no route-reflect=no \
        tcp-md5-key="" ttl=255 update-source=loopback use-bfd=no
    add address-families=ip as-override=no comment="" default-originate=never disabled=yes hold-time=3m in-filter=BOGONS instance=interno multihop=yes name=\
        ibgp_provedor nexthop-choice=default out-filter=ibgp-out passive=no remote-address=192.168.123.1 remote-as=65531 remove-private-as=yes route-reflect=no \
        tcp-md5-key=Netprovedor! ttl=255 update-source=vlan2 use-bfd=no
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         gif_1.gi.gif
Visualizações:	193
Tamanho: 	23,5 KB
ID:      	15522  
    Última edição por michellantunes; 25-10-2010 às 23:25.



  3. #203

    Padrão re: Configurar BGP

    Ajuda.
    Sou novato em BGP

    /routing bgp instance> print

    name="bgp_arena" as=xxxxx router-id=<IP do meu roteador> redistribute-connected=no redistribute-static=no redistribute-rip=no
    redistribute-ospf=no redistribute-other-bgp=no out-filter="" client-to-client-reflection=no ignore-as-path-len=no
    routing-table=""

    /routing bgp peer> print status

    Flags: X - disabled, E - established
    0 E name="peer_embratel" instance=bgp_arena remote-address=<IP da EMBRATEL> remote-as=4230 tcp-md5-key=""
    nexthop-choice=default multihop=yes route-reflect=no hold-time=3m ttl=default in-filter="" out-filter=""
    address-families=ip update-source=ether12 interface=ether12 default-originate=never remove-private-as=no
    as-override=no passive=no use-bfd=no remote-id=200.244.41.180 local-address=<IP do meu Roteador> uptime=4d20h34m32s
    prefix-count=1 updates-sent=33 updates-received=3 withdrawn-sent=14 withdrawn-received=0 remote-hold-time=3m
    used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established


    /routing bgp network> print
    0 189.xxx.xx.0/20 yes
    1 189.xxx.xx.0/24 no
    2 189.xxx.xx.0/24 no
    3 189.xxx.xx.0/24 no
    4 189.xxx.xx.0/24 no
    5 189.xxx.xx.0/24 no
    6 189.xxx.xx.0/24 no
    7 189.xxx.xx.0/24 no
    8 189.xxx.xx.0/24 no
    9 189.xxx.xx.0/24 no
    10 189.xxx.xx.0/24 no
    11 189.xxx.xx.0/24 no
    12 189.xxx.xx.0/24 no
    13 189.xxx.xx.0/24 no
    14 189.xxx.xx.0/24 no
    15 189.xxx.xx.0/24 no
    16 189.xxx.xx.0/24 no

    Perguntas:

    1. Gostaria de saber se a quebra de blocos em "network" está certo?
    2. Como eu faço o roteamento desse blocos para outros servidores?

    Graça ao "alexandrecorrea" na pagina 2 foi que consegui configurar.

  4. #204

    Padrão re: Configurar BGP

    como voce tem um peer so.. basta voce anunciar o /20 .. remova os /24 da listagem do "networks" e tambem mude o "yes" para "no" !!



  5. #205

    Padrão re: Configurar BGP

    Agradeço alexandre.
    Nao busando, mas sobre a segunda pergunta?

    ja tentei rotear pelo /ip route> e nao da certo
    a linha no /ip route, que fala do "bgp" esta azul com as letras "Db", esta certo?




    Citação Postado originalmente por alexandrecorrea Ver Post
    como voce tem um peer so.. basta voce anunciar o /20 .. remova os /24 da listagem do "networks" e tambem mude o "yes" para "no" !!

  6. #206

    Padrão re: Configurar BGP

    rotear o q ?

    vc nao precisa por rota nenhuma, elas sao isntaladas pelo BGP..



  7. #207

    Padrão re: Configurar BGP

    Link- ether1
    |
    Roteador-BGP Mikrotik
    |
    ether2|-----------------------> servidor-mk 1 ------->clientes zona1
    ether3|-----------------------> servidor-mk 2 -------> clintes zona2
    ether4|-----------------------> servidor-mk 3 -------> clients zona3

    Deixa eu ver se entendi... Deculpe pelas minha "nobeza". Vou no "servidor-mk 1" e ponho lá um ip/30 ou /24. o BGP ja faz o serviços?
    Última edição por fsoaress76; 23-11-2010 às 18:30.

  8. #208

    Padrão re: Configurar BGP

    vc deve ta confundindo bgp com ospf...



  9. #209

    Padrão re: Configurar BGP

    Eu so configurei o bgp graça ao Alexandre. Agora preciso quebra esse bloco/20 e mandar para outros servidores e servir os clientes. so que nao sei como fazer?

    Citação Postado originalmente por terencerocha Ver Post
    vc deve ta confundindo bgp com ospf...

  10. #210

    Padrão re: Configurar BGP

    ainda vc tem de criar as rotas para esses ip's partindo do seu servidor que fecha o bgp...pode ser por rotas estaticas ou por ospf...
    /ip route
    add dst-address=200.x.x.0/24 gateway=200.x.x.1

    mais ou menos por ai...



  11. #211

    Padrão re: Configurar BGP

    Terencerocha, obrigado por me agudar...
    Estou fazendo desta forma, porem quando eu vou no site Meu ip - Qual

    Esta saindo o ip do meu roteador. e nao do BGP

    Citação Postado originalmente por terencerocha Ver Post
    ainda vc tem de criar as rotas para esses ip's partindo do seu servidor que fecha o bgp...pode ser por rotas estaticas ou por ospf...
    /ip route
    add dst-address=200.x.x.0/24 gateway=200.x.x.1

    mais ou menos por ai...

  12. #212

    Padrão re: Configurar BGP

    entao eh pq vc ta fazendo nat pros seus ips do bgp na saida do roteador...



  13. #213

    Padrão re: Configurar BGP

    Certo.
    Mas Esta fazendo nat por ip e nao por interface.

    Quando eu redireciono uma faixa de ip do BGP para um ip q nao esta fazendo NAT nao navega, ou seja nao tem saida
    PS: Verifique que tem uma linha em ip router referente ao BGP | Db 0.0.0.0/0
    Está linha esta em AZUL

    #####################ROTEADOR
    /ip address
    add address=192.168.10.1/30 broadcast=192.168.10.3 comment=""

    /ip firewall nat
    add action=masquerade chain=srcnat comment=empresa disabled=no src-address=192.168.10.0/30

    /ip router
    add comment="" disabled=no distance=1 dst-address=189.YYY.XX.0/26 gateway=192.168.10.2 scope=30 target-scope=10

    /routing bgp network
    add comment="" disabled=no network=189.xxx.xx.0/20 synchronize=no
    add comment="" disabled=no network=189.YYY.XX.0/26 synchronize=no "/ip que vai para outro servidor teste"
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.0/24 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.64/26 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.128/26 synchronize=no
    add comment="" disabled=no network=189.xxx.xx.192/26 synchronize=no


    #################servidor Teste

    /ip address
    add address=189.YYY.XX.1/30 broadcast=189.YYY.XX.3 comment=BGP disabled=yes interface=ether2 network=189.YYY.XX.0

    /Nao faz nat
    ################## Cliente

    IP: 189.YYY.XX.2/30
    gw: 189.YYY.xx.1/30
    dns: 8.8.4.4
    Última edição por fsoaress76; 25-11-2010 às 13:02.

  14. #214

    Padrão re: Configurar BGP

    Olha eu recomendo o seguinte, escolha uma faixa de preferência a primeira só mesmo a nível de entendimento, pra que você coloque logo em produção e entenda como funciona, vamos supor que essa faixa seja 200.xxx.xxx.0/24, seguimos o exemplo:

    1º ) No BGP coloque na LAN dele um bloco de ip que vc anunciou 200.xxx.xxx.1/24

    2º ) ROTEADOR 200.xxx.xxx.2/24
    GW 200.xxx.xxx.1

    3º ) No seu servidor BGP aponte agora os blocos para esse ROTEADOR

    /ip route
    add comment="Bloco1" disabled=no distance=1 dst-address=201.xxx.xxx.0/24 gateway=200.xxx.xxx.2 scope=30 target-scope=10

    201.xxx.xxx.0/24
    202.xxx.xxx.0/24
    203.xxx.xxx.0/24
    204.xxx.xxx.0/24

    ( Aqui me refiro às suas redes que fazem parte do teu AS e foram anunciadas la no seu BGP)


    Ai nesse roteador vc tera todas as suas redes prontinhas para serem apontadas para onde quiser.



  15. #215

    Padrão re: Configurar BGP

    fsoares, em networks vc coloca só o seu /20 !!!

    como vc tem um peer so.. precisa anunciar somente o seu /20 !!!

  16. #216

    Padrão re: Configurar BGP

    Agradeco a ajuda...
    Mas, vou abrir um chamado junto a embratel para averiguar o problema de nao ter saida.

    Como aqui é uma RB1100, coloquei uma faixa /24 em uma porta livre.
    ex:
    1. BGP
    add address=189.yyy.yy.1/24 broadcast=189.225.80.255 comment="BGP teste soares" disabled=no interface=ether6 network=189.225.80.0

    2.No meu no netbook
    189.yyy.yy.2/24
    Gw 189.yyy.yy.1
    dns 8.8.4.4

    Nao tem rota ou seja nao navega.

    Como essa AS esta paralelas as outas rotas da embratel, (ip utilizados ) deve ter algumas coisa errada
    Última edição por fsoaress76; 25-11-2010 às 17:05.



  17. #217

  18. #218

    Padrão re: Configurar BGP

    Vou testar amanhã. Mas só adiantando: nao pinguei na Gw do netbook daqui de casa.

    Desculpe pela pergunta, mas onde vejo se os ip da AS esta sendo anuciado?

    Citação Postado originalmente por Michael Ver Post



  19. #219

    Padrão re: Configurar BGP

    Voltei para contar o que o "NOC" embratel informaou.

    Segundo o tec da embratel, (NOC) o nosso serviço faz parte de um "bgp lite" o mesmo só divulga os blocos ip contratado da embratel.
    Ou seja: filtra.
    Quando nos fizemos o primeiro pedido para divulgar a AS, informaram que nossa rede nao suportava essa tecnologia. que tinha que fazer um upgrade, fizemos. passei 5 dias aqui apanhando por icompetencia desse caras. Dependendo do que aconteça trago as novidades
    Última edição por fsoaress76; 26-11-2010 às 08:45.

  20. #220

    Padrão re: Configurar BGP

    [[email protected]] /routing bgp network> print

    Aqui vão aparecer os blocos que você anunciou, mas isso não significa que realmente a operadora entendeu e fez a parte dela anunciando como você pediu, para saber isso você pode pingar usando aquele endereço que passei acima, ou de outro local para ver se seus blocos estão realmente disponíveis ou não para a internet.