Página 2 de 16 PrimeiroPrimeiro 1234567 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão



    posta uns print screen ai das telas da conf e das rotas recebidas pra ficar completinho os screen-shots

  2. #22

    Padrão

    pessoal

    em relação ao redistribute-static ou connected, li um documento da cisco que nao sei se entendi mto bem mas nao aconselha a usar... olhem na página 103... por ali

    o documento esta neste link ftp://ftp.registro.br/pub/gter/gter20/TutorialBGP/
    nome: UnicastRFP.pdf

    []'s



  3. #23

    Padrão

    Subi um bgp esta semana no mikrotik fazendo peering com a oi e tive que pedir pra eles habilitarem o ebgp multihop do cisco dele pra subir a sessâo. Esta tudo tranquilo tem 5 dias .. outra coisa, utilizem o routing filter pra nao anunciar rotas que não devem. Outra coisa é que se você so tem uma operadora e recebe partial routing , tem que ter uma rota default que vai ser o loopback do bgp da operadora pra poder alcançar as redes que vc nao recebeu.

  4. #24

    Padrão

    amigos me desculpe resucitar a discusão, mais eu tenho um provedor e esta atingido grandes escalas, e penso em adquirir um ASN, tenho CCNA e já estudei um pouco sobre esse protocolo de roteamento, mais tenho algumas duvidas, vou numera-las para ficar mais facil

    1) o que seria mais indicado para BGP, um roteador cisco ou mk?
    2) qual é o consumo tanto de memoria quanto de processamento ao se ter um BGP no mk?
    3) hoje compro link da telefonica, eu teria que entra em contato com a telefonica ou outra empresa para comprar um ASN?
    4) qual seria o custo?

    amigo muito obrigado pelo seu tempo, agradeço a todos do forum pela ajuda que tenho recebido

    T+



  5. #25

    Padrão

    Citação Postado originalmente por j34nsch Ver Post
    amigos me desculpe resucitar a discusão, mais eu tenho um provedor e esta atingido grandes escalas, e penso em adquirir um ASN, tenho CCNA e já estudei um pouco sobre esse protocolo de roteamento, mais tenho algumas duvidas, vou numera-las para ficar mais facil

    1) o que seria mais indicado para BGP, um roteador cisco ou mk?
    2) qual é o consumo tanto de memoria quanto de processamento ao se ter um BGP no mk?
    3) hoje compro link da telefonica, eu teria que entra em contato com a telefonica ou outra empresa para comprar um ASN?
    4) qual seria o custo?

    amigo muito obrigado pelo seu tempo, agradeço a todos do forum pela ajuda que tenho recebido

    T+
    J34nsch,

    Não peça desculpa, temos sim que reativar os tópicos que temos dúvidas, isso ajudaria muito nossas buscas pela net e simplificaria mais as nossas vidas..rs... Bom vamos lá....

    O protocolo BGP não é complicado de configurar, como vc já tem conhecimento de CCNA, assim como eu, fica mais fácil de entender o conceito mesmo o assunto 'BGP' sendo abordado mais detalhadamente no CCNP.


    Hoje tenho um BGP de 30Mb partial routing da Telefônica com aproximadamente 6 mil rotas (pois é um parcial), atualmente o MK esta atendendo bem as necessidades da rede com roteamento interno, QoS e firewall.


    Suas dúvidas.

    1) o que seria mais indicado para BGP, um roteador cisco ou mk?
    Infelizmente preciso de mais informações como: qual tipo de BGP que irá utilizar (full ou partial); qual será a banda do link, quantos clientes possui, o roteamento dos clientes ( se for utilizar) sera feito pelo proprio roteador que recebera o BGP ou tera outros equipamentos fazendo isso em sua estrutura etc etc.

    2) qual é o consumo tanto de memoria quanto de processamento ao se ter um BGP no mk?
    Depende do tipo de seu BGP e das informações que te passei acima, logico que o full o consumo é bem maior por receber quase 65mil rotas (ou algo assim não tenho certeza da precisão)

    3) hoje compro link da telefonica, eu teria que entra em contato com a telefonica ou outra empresa para comprar um ASN?
    No meu caso comprei 4 mil IPs com a LACNIC, logo me disponibilizaram a locação de ASN e os IPs, depois pedi o BGP junto com a Telefonica repassando minhas informações de ASN e IPs para publicação mundial pela mesma. Veja o site que possui bastantes informações para esclarecer suas dúvidas.

    4) qual seria o custo
    Infelizmente não tenho os valores, mas posso conseguir.

    Já o Mikrotik a licença para BGP é em torno de 200 reais mais a maquina para instalação do mesmo (algo em torno de 1.500).

    Um roteador Cisco da Serie 2800 com link WAN de ate 30Mb e 2 FastEthernet esta em torno de U$6.000 (dólares). Não se esqueça de adquirir SLA, equipamento de redundância ou substituição do equipamento caso ocorra algum problema em plena operação (isso eu não cotei e é o que costuma ser mais caro).

    Agora depende muito de qual tipo de BGP esta em questão e do potencial da empresa, um Cisco claro seria o ideal se o problema não for investimento, logo MK é bem mais bem mais barato e formas de redundância, backup, equipamento reserva é o que não falta para essa solução.

    Para curiosidade tenho um colega que possui BGP Full de 4 operadores Telefônica, Embratel, Intelig, CTBC com mais de 4 milhões de rotas tudo rodando em MK e segundo ele nunca deu problema.


    Qualquer duvida peço por favor que escreva novamente pois existe muito pouco material sobre isso na net e qualquer ajuda será muito bem vinda.

    Pessoal, se escrevi algo de errado no post me corrijam, por favor, e assim mantermos sempre a qualidade no Under-Linux.


    Ate

    --Kalz--

  6. #26

    Padrão

    amigo no meu caso é o seguinte, tenho um link de apenas 10 mb para os meus clientes, e vou comprar por questão de redundância link de um grande provedor que esta no meu estado vizinho, que tem BGP e redundância com 3 operadoras, ou sejá a minha redundância vai ser bem grande, no caso do meu servidor to com problemas na placa mãe do meu mk central, ou seja, vou comprar ou 2 pcs ou duas RB 1000.

    nos cliente vou disponibilizar ips públicos dinâmicos, em alguns caso vou fixar, e uso hotspot e pppoe (para empresas) autenticando na torres, consultado o meu servidor radius incorporado ao sistema financeiro, a as torres são todas rateadas utilizando OSPF, pois estou montando links backup em 2,4 entre elas para suprir caso tenha falha em algum link 5,8. Tenho torres em 8 cidades.

    estou em duvida se devo usar full ou parcial

    e amigo muito obrigado pela ajuda

    T+



  7. #27

    Padrão

    Entendi,

    Bom se vc esta comprando por questão de contingência e a outra operado que vc vai adquirir já possui redundância com mais 3 operadoras, acretido que fique mais viável o parcial (questão de valores), o full só será util se vc possui mais operadoras e assim vc podera redimensionar suas rotas para os destinos que tiverem menos hops, mais desempenho, redundância caso uma operadora fique fora do ar etc etc .... mas acredito que no seu caso a redundância será controlada por essa operadora que vc esta comprando os 10Mb, correto ?

    A diferença de valores de um full e parcial é mto grande?


    --Kalz--
    Última edição por kalz; 13-12-2008 às 11:58.

  8. #28

    Padrão Duvida

    Ola amigos estou tentando fazer um ibgp para minha rede interna para quando um link caia o outro assuma automaticamente mas estou com um pouco de dificuldade se alguem souber de algum link ou tiver alguma ideia de como funciona fico grato



  9. #29

    Padrão

    oi amigo, onde foi que vc comprou sua ASN e quanto foi a /20.

  10. #30

    Padrão rotas

    a operadora aki me repassou 271453 rotas...



  11. #31

    Padrão

    Citação Postado originalmente por Aldo.mau Ver Post
    Ola amigos estou tentando fazer um ibgp para minha rede interna para quando um link caia o outro assuma automaticamente mas estou com um pouco de dificuldade se alguem souber de algum link ou tiver alguma ideia de como funciona fico grato
    Cara, comprei na LACNIC, agora preço infelizmente ficarei te devendo que já faz um tempo e não sei os valores atual...

  12. #32

    Padrão

    Citação Postado originalmente por Aldo.mau Ver Post
    Ola amigos estou tentando fazer um ibgp para minha rede interna para quando um link caia o outro assuma automaticamente mas estou com um pouco de dificuldade se alguem souber de algum link ou tiver alguma ideia de como funciona fico grato

    o ASN no primeiro ano fica 2.100 reais +-- (600 do processo + 1500/ano) .. voce precisa especificar o uso de pelomenos 2000 ips ... precisa ter link com 2 ou mais operadoras, etc etc
    Registro .br


    ----

    sobre a configuração do ibgp com fail-over.. tenta assim:

    Código :
    [FONT=Tahoma]router bgp NNNN
     no synchronization
     bgp log-neighbor-changes
     network 200.200.200.0 mask 255.255.240.0
     redistribute connected
     neighbor yyy.yyy.yyy.yyy remote-as XXXX
     neighbor yyy.yyy.yyy.yyy prefix-list anunciar out
     neighbor zzz.zzz.zzz.zzz remote-as ZZZZ
     neighbor zzz.zzz.zzz.zzz prefix-list anunciar out
     neighbor zzz.zzz.zzz.zzz route-map linkprepend out
     no auto-summary
    !
    ip prefix-list anunciar description Blocos a serem anunciados
    ip prefix-list anunciar seq 5 permit 200.200.200.0/20
    !
    route-map linkprepend permit 10
     match ip address prefix-list anunciar
     set as-path prepend NNNN NNNN
     
    [/FONT]


    onde:

    NNNN - seu AS
    XXXX - AS operadora 1
    ZZZZ - AS operadora 2
    200.200.200.0/20 -> seu bloco
    yyy.yyy.yyy.yyy -> ip do neigh da operadora 1
    zzz.zzz.zzz.zzz -> ip do neigh da operadora 2

    o que acontece fazendo prepend é, voce anunciar seu bloco pelas 2 operadoras... porem o anuncio que vai para a operadora ZZZZ (backup) vai com o PATH maior .. entao a preferencia sempre vai ser via XXXX porem se a operadora 1 cair, o anuncio pela operadora 1 'morre' e o da operadora 2 fica valendo.. até que, o link volte !!





  13. #33

    Ingresso
    Sep 2005
    Localização
    Cascavel, Parana, Brazil, Brazil
    Posts
    41

    Padrão

    Pessoal,

    a BRT me passou um formulário onde eles solicitam a senha para a seção BGP. Este parametro no mikrotik seria o TCP MD5 Key?

    Grato

  14. #34

    Padrão

    exatamente.. eh uma chave para negociar a sessão bgp.



  15. #35

    Ingresso
    Sep 2005
    Localização
    Cascavel, Parana, Brazil, Brazil
    Posts
    41

    Padrão

    Obrigado alexandrecorrea,

    BGP estabelecido com a operadora (+6300 rotas) conforme auxilio de todos aqui no fórum.

    Código :
    /routing bgp instance
    add as=28xxx client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=bgp out-filter=dynamic-in \
        redistribute-connected=yes redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no redistribute-static=no \
        router-id=187.111.xxx.1
    /routing bgp network
    add disabled=no network=187.111.xxx.0/20 synchronize=yes
    /routing bgp peer
    add address-families=ip comment="" disabled=no hold-time=3m in-filter="" instance=bgp interface=Ethernet1 multihop=yes \
        name=peer_brt nexthop-choice=default out-filter="" remote-address=201.40.xxx.123 remote-as=8167 route-reflect=no \
        tcp-md5-key=SenhaSecao ttl=255 update-source=Ethernet1


    A principio, o meu loopback será o ip 187.111.xxx.1/32 o qual configurei na interface Ethernet1 e o IP 201.40.xxx.123 é o loopback informado pela operadora.
    Como deveria ficar a rota estática?

    é uma pergunta básica, mas não consegui visualizar o cenário e as rotas configuradas não funcionaram.

    Desde já agradeço.



  16. #36

    Padrão

    no mikrotik voce nao precisa setar o loopback nao.. !!


    adiciona rota ai para o ip da operadora sua... sempre sair pelo link da operadora..

    evitando assim, se um link cair, sua sessao continua estabelecida com o router da outra operadora que ficou down (atraves do outro link)...



  17. #37

    Ingresso
    Sep 2005
    Localização
    Cascavel, Parana, Brazil, Brazil
    Posts
    41

    Padrão

    No formulário enviado para a operadora, passei o ip 187.111.xxx.1 como meu neighbor. Na resposta da operadora, eles informaram entender que este IP é uma loopback e solicitam para que seja configurada uma rota estática. Deve estar configurado assim na outra ponta.

    Hoje, contamos com somente uma operadora e gostaríamos de o quanto antes devolver os poucos ips que nos foram alocados por ela.

    e agora josé?

  18. #38

    Padrão

    entao cara.. esse 187.111.x.1 eh do seu AS.. correto ?

    pronto.. eles falaram para que vc adicione uma rota para o ip do neighbor deles (201.x.x.x) forçando a sair pelo link DELES !!!

    olha o que acontece:

    vc tem operadora X e o neigh dela pra vc eh 200.100.100.100 e voce tem a operadora Y que o neigh dela pra vc eh 200.200.200.200...


    voce anuncia o seu bloco 187.x.x.0/20 para as duas operadoras.. entao o MUNDO sabe que pra chegar na sua rede .. existem 2 caminhos.. e vc sabe que pra SAIR voce tem 2 caminhos...

    a operadora X caiu... link entre ela e voce.. mas par ao mundo o ip do neigh dela (200.100.100.100) esta acessivel..

    a SUA sessão bgp como tem conectividade com outra operadora.. faz a convergencia.. e avisa "agora so sai por Y" ...

    a sua sessao BGP .. entre operadora X e Y nao vai cair.. pq pela operadora Y voce vai ter conectividade com a operadoa X !! e vai anunciar o seu bloco para os 2 caminhos...

    se vc adicionar as rotas estaticas... quando cair.. caiu mesmo um link, o bgp com a operadora eh fechado.. e vc anuncia apenas o caminho que esta UP...

    entendeu !?



  19. #39

    Ingresso
    Sep 2005
    Localização
    Cascavel, Parana, Brazil, Brazil
    Posts
    41

    Padrão

    Entendi,

    com seu auxílio e mais umas pesquisas acredito que agora esta ok. As rotas repassadas pela operadora que antes estavam com o gateway-state=unreachable agora esta recursive e as rotas ficaram ativas.

    Abaixo seguem os comandos que utilizei para criar a minha loopback e a rota para a loopback da operadora.

    Código :
    /interface bridge add name=loopback
    /ip address add address=187.111.xxx.1/32 broadcast=187.111.xxx.1 comment="" disabled=no interface=loopback network=187.111.xxx.1
    /ip route add bgp-origin=igp comment="Rota para loopback da operadora" disabled=no distance=1 dst-address= 201.40.xxx.123/32 gateway=201.40.xxx.xx3 scope=30 target-scope=10

    Após, alterei o update source da instancia bgp para o loopback.

    Muito obrigado Alexandrecorrea, e espero que minhas dúvidas auxiliem outras pessoas também.

    att

  20. #40