+ Responder ao Tópico



  1. #81

    Padrão

    Claro... switches l2 trabalham apenas na camadade de enlace, que é a camada a qual a ethernet faz parte... Ja switches l3 trabalham tabem com endereço ip e mascada de sub-rede, porem o foco principal do switche nao é ser uma aparelho com capacidade de roteamento e de camada de rede, mas sim um aparelho menos robusto e mais leve, com pacacidade de traabalhar com endereçamento mac. Se vc quer trabalhar com protocolos de camada de enlace, use um switch, se quiser trabalhar com camada de rede, use um roteador e nao um switch. É claro tbm que há casos, e casos.

  2. #82
    Não Registrado
    Visitante

    Padrão

    Bem galera, quagga por quagga mikrotik tambem é rsrsrsrs, poderia usar até mikrotik, mais nao sei se ele suporta bi-processamento e mais de 1Gb de ram, sem falar que os discos do servidor que adquiri da DELL são SAS em Raid5, e tambem esta com interfaces de fibra e fontes redundantes, acho que maquina é bem robusta para este proposito, Hoje tenho tres opções, Linux+Quagga, Vyatta=Debian+Quagga e Mikrotik, Atualmente um cisco ou um juniper com esses recursos não estão ao meu alcance r$r$r$r$, então gostaria da opnião de vcs para eu conseguir escolher a melhor opção,

    Obrigado.



  3. #83

    Padrão

    Citação Postado originalmente por Não Registrado Ver Post
    Bem galera, quagga por quagga mikrotik tambem é rsrsrsrs, poderia usar até mikrotik, mais nao sei se ele suporta bi-processamento e mais de 1Gb de ram, sem falar que os discos do servidor que adquiri da DELL são SAS em Raid5, e tambem esta com interfaces de fibra e fontes redundantes, acho que maquina é bem robusta para este proposito, Hoje tenho tres opções, Linux+Quagga, Vyatta=Debian+Quagga e Mikrotik, Atualmente um cisco ou um juniper com esses recursos não estão ao meu alcance r$r$r$r$, então gostaria da opnião de vcs para eu conseguir escolher a melhor opção,

    Obrigado.
    O Mikrotik 2.9 era Quagga. Os atuais ROS 3x. não são Quagga.

    Há outras opções como FreeBSD + OpenBGPd.

    Porque tanta capacidade de I/O de disco numa máquina que faz roteamento ?

  4. #84
    Ricardo Freitas
    Visitante

    Padrão

    Bem FreeBDS+OpenBGPd tambem é um opção, então na verdade esta maquina foi comprada no ano passado para ser backup do nosso firewall, mas como ela não esta sendo usada vamos usar ela como roteador, vc sabe me dizer se o mikrotik suporta mais de 1GB de ram? eu especifiquei errado qto o tamanho do link da telefonica, hj temos 100MB e estamos usando 86MB e ja estamos migrando para 155Mb, por isso uma maquina tao parruda, creio eu que uma RB1000 nao suporte este trafego...

    Obrigado



  5. #85

    Padrão

    Citação Postado originalmente por Ricardo Freitas Ver Post
    Bem FreeBDS+OpenBGPd tambem é um opção, então na verdade esta maquina foi comprada no ano passado para ser backup do nosso firewall, mas como ela não esta sendo usada vamos usar ela como roteador, vc sabe me dizer se o mikrotik suporta mais de 1GB de ram? eu especifiquei errado qto o tamanho do link da telefonica, hj temos 100MB e estamos usando 86MB e ja estamos migrando para 155Mb, por isso uma maquina tao parruda, creio eu que uma RB1000 nao suporte este trafego...

    Obrigado
    Tem gente com RB-1000 rodando com esse tráfego, mas x86 é melhor para o crescimento futuro.
    Minha questão era com o I/O de disco, com 2 discos SAS, enquanto para um appliance o melhor é usar CF-SATA.

    O Mikrotik ROS 3.x suporta 2GB em tese (nunca testei), e o ROS 4.x beta prevê suportar 3.5-4 GB.
    A limitação de 1GB era da versão 2.9.x. O que não significa que todo 3.x funcione com 2GB, foi um dos temas de bugs, supostamente corrigidos.

  6. #86

    Padrão

    quanto está o valor para um bgp com 155mbps?
    tava lendo uns papers da Oi e o de 155mbps tá mais de 100 Mil, isso pra troca de tráfego, não é link dedicado (eu acho), pois para troca não precisa contratar link dedicado, ou estou enganado?
    desculpem por upar o tópico, mas cada vez tenho me interessado mais por redes (tenho trabalhado com redes desde novembro do ano passado, mas sou - ou era hehe - programador).
    Falou



  7. #87

    Padrão

    Citação Postado originalmente por rossisolrac Ver Post
    quanto está o valor para um bgp com 155mbps?
    tava lendo uns papers da Oi e o de 155mbps tá mais de 100 Mil, isso pra troca de tráfego, não é link dedicado (eu acho), pois para troca não precisa contratar link dedicado, ou estou enganado?
    desculpem por upar o tópico, mas cada vez tenho me interessado mais por redes (tenho trabalhado com redes desde novembro do ano passado, mas sou - ou era hehe - programador).
    Falou
    Precisa de enlace para chegar até o ponto de presença da operadora. Se fornecido pela operadora, ela vai te cobrar... custa menos do que o link Internet, mas pode custar bastante.

  8. #88

    Padrão

    Aqui estou a menos de 2KM da central da Oi/Telemar, posso chegar lá fácil com cabos, fibras ou wireless (considerando o ponto onde quero instalar meu POP). Em linha reta, há uns 6KM da Embratel.

    OFF: Alguém sabe onde fica o POP da UNOTEL em São Luís? Mandei um e-mail e ainda não retornaram, procurei no site deles e aparece a mensagem de que está há 5KM da coordenada que coloquei. (2°28'06.08 Sul 44°13'38.04 Oeste)



  9. #89

    Padrão Ajuda

    Agmigos do forum...
    Estou tentando fechar um BGP com minha operadorua aqui mas creio que estou errando alguma coisa achei muita informação aqui no forum mas creio estar errando em algum lugar ..

    qureria ter certeza de como passar as informaçoes que a operadora me passou pra configurar em meu mikrotik me foi passado os itens . ..

    !
    !
    interface F0/0
    no ip address
    description WAN
    no ip redirects
    no ip unreachables
    no ip directed-broadcast
    no ip proxy-arp
    no ip mask-reply
    !
    !
    interface f0/0.xxxx
    description Principal
    encapsulation dot1Q xxxx
    ip address 189.xxx.xxx.xxx 255.255.255.252
    !
    !
    interface f0/0.xxxx
    description Backup
    encapsulation dot1Q xxxx
    ip address 189.xxx.xxx.xxx 255.255.255.252
    !
    !
    interface F0/1
    ip address xxx.xxx.xxx.xxx 255.255.255.128
    description LAN
    no ip redirects
    no ip unreachables
    no ip directed-broadcast
    no ip proxy-arp
    no ip mask-reply
    !
    !
    router bgp xxxxx
    Neighbor xxx.xxx.xxx.xxx remote-as xxxx
    Neighbor xxx.xxx.xxx.xxx FastEthernet0/0.xxxx
    Neighbor xxx.xxx.xxx.xxx soft-reconfiguration inbound
    Neighbor xxx.xxx.xxx.xxx remote-as xxxx
    Neighbor xxx.xxx.xxx.xxx update-source FastEthernet0/0.xxxx
    Neighbor xxx.xxx.xxx.xxx soft-reconfiguration inbound
    Neighbor xxx.xxx.xxx.xxx route-map COMMUNITY out
    Neighbor xxx.xxx.xxx.xxx send-community
    redistribute static
    redistribute connected
    !
    !
    ip classless
    !
    access-list 2 remark ANY_ROUTE_TO_BACKUP
    access-list 2 permit 0.0.0.0 255.255.255.255
    !
    route-map COMMUNITY permit 10
    match ip address 2
    set community xxxx:xxx internet
    !


    Na realidade queria como passar estes dados para se montar o bgp.. Minhas tentativas aqui nao estao dando certo ...
    Em Mikrotic é o primeiro Bgp que configuro..... gostaria de uma judinha de como se monta no Mikrotik

  10. #90

    Padrão

    Citação Postado originalmente por Cobausque Ver Post
    Agmigos do forum...
    Estou tentando fechar um BGP com minha operadorua aqui mas creio que estou errando alguma coisa achei muita informação aqui no forum mas creio estar errando em algum lugar ..

    qureria ter certeza de como passar as informaçoes que a operadora me passou pra configurar em meu mikrotik me foi passado os itens . ..

    !
    !
    interface F0/0
    no ip address
    description WAN
    no ip redirects
    no ip unreachables
    no ip directed-broadcast
    no ip proxy-arp
    no ip mask-reply
    !
    !
    interface f0/0.xxxx
    description Principal
    encapsulation dot1Q xxxx
    ip address 189.xxx.xxx.xxx 255.255.255.252
    !
    !
    interface f0/0.xxxx
    description Backup
    encapsulation dot1Q xxxx
    ip address 189.xxx.xxx.xxx 255.255.255.252
    !
    !
    interface F0/1
    ip address xxx.xxx.xxx.xxx 255.255.255.128
    description LAN
    no ip redirects
    no ip unreachables
    no ip directed-broadcast
    no ip proxy-arp
    no ip mask-reply
    !
    !
    router bgp xxxxx
    Neighbor xxx.xxx.xxx.xxx remote-as xxxx
    Neighbor xxx.xxx.xxx.xxx FastEthernet0/0.xxxx
    Neighbor xxx.xxx.xxx.xxx soft-reconfiguration inbound
    Neighbor xxx.xxx.xxx.xxx remote-as xxxx
    Neighbor xxx.xxx.xxx.xxx update-source FastEthernet0/0.xxxx
    Neighbor xxx.xxx.xxx.xxx soft-reconfiguration inbound
    Neighbor xxx.xxx.xxx.xxx route-map COMMUNITY out
    Neighbor xxx.xxx.xxx.xxx send-community
    redistribute static
    redistribute connected
    !
    !
    ip classless
    !
    access-list 2 remark ANY_ROUTE_TO_BACKUP
    access-list 2 permit 0.0.0.0 255.255.255.255
    !
    route-map COMMUNITY permit 10
    match ip address 2
    set community xxxx:xxx internet
    !


    Na realidade queria como passar estes dados para se montar o bgp.. Minhas tentativas aqui nao estao dando certo ...
    Em Mikrotic é o primeiro Bgp que configuro..... gostaria de uma judinha de como se monta no Mikrotik
    pessoal desculpem .. consegui fazer funcionar .rs .. vacilo meu aqui com alguns parametros ...



  11. #91

    Padrão

    pessoal,

    fiz o passo-a-passo do jeito q vcs informaram, mas n funcionou aqui. as rotas ficaram em azul.
    se puderem me ajudar agradeco.

    ether2 - interface local
    ether1 - interface publica

    ip address
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 ;;; loopback
    187.49.xxx.5/32 187.49.xxx.5 187.49.xxx.5 ether2
    1 ;;; enlace - operadora
    189.89.xxx.74/30 189.89.xxx.72 189.89.xxx.75 ether1

    routes
    # DST-ADDRESS PREF-SRC GATEWAY-STATE GATEWAY DISTANCE INTERFACE
    2 A S 189.89.xxx.3/32 reachable 189.89.xxx.73 ether1 1

    instances
    1 name="ebgp" as=28xx4 router-id=187.49.xxx.5 redistribute-connected=yes
    redistribute-static=yes redistribute-rip=no redistribute-ospf=no
    redistribute-other-bgp=no out-filter=dynamic-in
    client-to-client-reflection=no ignore-as-path-len=no

    peers
    0 name="peer_its" instance=ebgp remote-address=189.89.xxx.3 remote-as=28xx6
    tcp-md5-key="" nexthop-choice=default multihop=yes route-reflect=no
    hold-time=3m ttl=255 in-filter="" out-filter="" address-families=ip
    update-source=ether2 interface=ether2

    network
    0 189.45.xxx.0/20 yes

  12. #92

    Padrão

    Olá Alexandre, tudo bem ? Amigo estou precisando digamos de uma consultoria para criação do meu BGP, pois como vários amigos do fórum tiveram problemas com relação ao número de ips válidos tb sofro deste mal . Estou com meu AS e um bloco /20, recebo link de duas operadoras INTELIG e OI . Li vários posts com relação as configurações de BGP, mas mesmo assim fico com receio de fazer tais configurações no servidor que está em produção . Como podemos fazer, pelo que vi vc trabalha com consultoria .

    Fico no seu aguardo .



  13. #93

    Padrão

    Citação Postado originalmente por FEenuX Ver Post
    Olá Alexandre, tudo bem ? Amigo estou precisando digamos de uma consultoria para criação do meu BGP, pois como vários amigos do fórum tiveram problemas com relação ao número de ips válidos tb sofro deste mal . Estou com meu AS e um bloco /20, recebo link de duas operadoras INTELIG e OI . Li vários posts com relação as configurações de BGP, mas mesmo assim fico com receio de fazer tais configurações no servidor que está em produção . Como podemos fazer, pelo que vi vc trabalha com consultoria .

    Fico no seu aguardo .
    Além dos diversos consultores já citados no thread, veja também com o Mcosta:
    http://www.mcosta.eng.br

  14. #94

    Padrão Filtros

    Pessoal,

    Tenho um BGP rodando tudo OK ate o momento, tenho uma rede roteada com ips invalidos, claro, e destino IP validos, andei percebendo que de fora da rede quando faço um tracert para algum IP valido de minha rede acaba mostrando os IPs invalidos de meus roteadores durante o traçar das rotas.


    Alguem sabe se preciso habilitar algum filtro no BGP, se sim, qual?

    Abraços a todos

    --Kalz--



  15. #95

    Padrão

    cola um trace ai pra dar um exemplo...

  16. #96

    Padrão

    Ae Alexandre,

    obrigado pelo contato,


    Segue tracert

    traceroute to 201.55.XX.XX (201.55.XX.XX), 30 hops max, 60 byte packets
    1 192.168.0.252 (192.168.0.252) 8.918 ms 8.888 ms 8.859 ms
    2 187.11.136.1 (187.11.136.1) 57.550 ms 57.510 ms 56.654 ms
    3 * * *
    4 201.0.92.45 (201.0.92.45) 58.461 ms 60.234 ms 61.232 ms
    5 200.100.1.249 (200.100.1.249) 67.578 ms 67.555 ms 200.100.1.253 (200.100.1.253) 69.352 ms
    6 201.63.253.42 (201.63.253.42) 69.325 ms 201.63.253.62 (201.63.253.62) 49.608 ms 201.63.253.42 (201.63.253.42) 49.590 ms
    7 201.0.3.110 (201.0.3.110) 50.031 ms 200.204.20.158 (200.204.20.158) 52.738 ms 201.0.3.110 (201.0.3.110) 54.086 ms
    8 187-8-58-10.customer.tdatabrasil.net.br (187.8.58.10) 55.251 ms 57.050 ms 58.416 ms
    9 10.0.30.X (10.0.30.X) 393.728 ms 395.066 ms 398.217 ms
    10 10.20.1.X (10.20.1.XX) 405.058 ms 405.042 ms 404.975 ms
    11 10.20.1.X (10.20.1.XXX) 424.707 ms 431.185 ms 383.732 ms
    12 mail.XXX.ind.br (201.55.XX.XX) 385.284 ms 392.144 ms 390.324 ms



  17. #97

    Padrão

    Caros amigos, La vem eu ressuscitar de novo as duvidas.

    Minha empresa recentemente adquiriu ASN, li toda a discussão e estou testando tudo em laboratório antes de colocar em produção. Vou fechar BGP com a Embratel e com o PTT Metro via ANID.
    Tenho uma dúvida básica, para se fechar uma sessão BGP tem que se ter conectividade ip entre os 2 roteadores (Cliente e operadora) certo? Logo quando eu solicitar pra Embratel o BGP ela vai me fornecer uma faixa de ip do tipo 189.x.x.0/30 para esse enlace?
    Outra duvida é supondo que eu receba um bloco 187.x.x.0/20 na interface onde recebo o link tem que criar um loopback que poderia ser 187.x.x.1/32 e em uma outra interface poderia colocar 187.x.x.2/24 por exemplo para meus servidores se comunicar?
    E uma terceira duvida é com relação a se algum de vocês usa RB1000 para BGP, qual a banda, se é Full Routing ou Partial, quanto ta o processamento, etc
    Desde já agradeço a comunidade.

  18. #98

    Padrão

    rb1000 aguenta tranquilo...

    a configuração bgp voce pode fazer do jeito q citou sim... sem problemas



  19. #99

    Padrão

    Só para dar mais informações pra voces, hoje tenho um link de 60mb com embratel e vou entrar no PTT via ANID com talvez 30 a 40 MB.

    Alguem que usa PTT Metro quando em porcentagem da pra trafegar por la? Alguem tem essa media?

  20. #100

    Padrão

    Citação Postado originalmente por marcelovoax Ver Post
    Só para dar mais informações pra voces, hoje tenho um link de 60mb com embratel e vou entrar no PTT via ANID com talvez 30 a 40 MB.

    Alguem que usa PTT Metro quando em porcentagem da pra trafegar por la? Alguem tem essa media?
    Se estamos falando do PTT-Metro de SP, pode dar até 40% do seu tráfego total. Assim, sua proporção de Trânsito/peering parece boa e você tem boa chance de conseguir um tráfego total de 100Mbps.

    A ANID tem RB-1000 com mais tráfego do que isso... por sinal, seu tráfego para SP vai passar por algumas RB-1000. Mas eles usam partial, e eu recomendo que você faça o mesmo, ao invés de full-routing.