Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão

    muito boa a regra...soh uma duvida...
    como eu usaria para um perfil de 128k no hotspot?

  2. #22



  3. #23

    Padrão

    é isso aí Magsal! hehehe

  4. #24
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    kkkkkkkkkkkkkk
    Citação Postado originalmente por lucianogf Ver Post
    é isso aí Magsal! hehehe



  5. #25

    Padrão

    Magal, me tira so uma duvida.
    Tenho varios pops, sendo cada pop com uma faixa de rede para os clientes.
    Vi no exemplo que no meu caso o ideial seria usar o queue simple ao inves do mangle... So que eu precisava dividir meu link entre os pops, se eu colocar no queue simples a velocidade que eu quero nesse pop funcionaria?

    Abraços.

  6. #26

    Padrão

    Se você tem um servidor central, pode sim controlar a velocidade dos pops. Basta controlar o ip de cada um deles.



  7. #27

    Padrão

    Blz mestre, irei fazer isso entao... Tenho um mk central para controlar tudo.

  8. #28

    Padrão

    Essas 2 linhas...
    /queue type add name=”PCQ_download” kind=pcq pcq-rate=64000 pcq-classifier=dst-address
    /queue type add name=”PCQ_upload” kind=pcq pcq-rate=32000 pcq-classifier=src-address
    Servem para controlar todos os clientes a 64/32 ou seria o minimo que o cliente chegaria? Ou nada haver com as 2 reespostas? rs



  9. #29

    Padrão

    Este é apenas um tipo de controle criado, senda assim, eles não vão controlar apenas criando, tem que setar na queue="" também, mas é para isto mesmo controle de down/up de cada cliente, mas precisa setar o queue="PCQ_down ou PCQ_up" em todas as entradas que criar já que a mesma vem com o default.

  10. #30

    Padrão

    Deixa eu ver se entendi.
    No queue type coloco o controle de banda dos usuarios, no caso quero que todos naveguem a 300/150 ae coloco no queue type...
    E no queue simple coloco o valor total de link que a faixa poderia usar ao todo...

    Seria isso?



  11. #31

    Padrão

    Completando...
    O pcq não serve apenas para controle de clientes e também de serviços.

  12. #32

    Padrão

    Citação Postado originalmente por cooperrj Ver Post
    Deixa eu ver se entendi.
    No queue type coloco o controle de banda dos usuarios, no caso quero que todos naveguem a 300/150 ae coloco no queue type...
    E no queue simple coloco o valor total de link que a faixa poderia usar ao todo...

    Seria isso?
    Para fazer o controle por queue simple, precisaria usar apenas a etapa 3 listada na 1ª pag.



  13. #33

    Padrão

    Uma pergunta, caso meu link seja 4mb e tenha apenas um cliente logado baixando com p2p e gerenciador de donwload como orbit a toda banda, qual o tempo que o servidor demoraria para dividir a banda para o próximo cliente que acabou de logar, teria um delay, alguem ja testou?

  14. #34
    Rodrigo Rogobol
    Visitante

    Thumbs down Complicado d+ entender qual usar ou não

    Pessoal me desculpe ai mas acredito tem muita gente ai como eu ta com dificuldade de fazer o PCQ funcionar blz.
    1º Coisa é quando uso esse script:
    /queue type add name=”PCQ_download” kind=pcq pcq-rate=64000 pcq-classifier=dst-address
    /queue type add name=”PCQ_upload” kind=pcq pcq-rate=32000 pcq-classifier=src-address

    /queue tree add parent=global-in queue=PCQ_download packet-mark=all
    /queue tree add parent=global-out queue=PCQ_upload packet-mark=all

    /queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

    Aqui a pergunta como vou usar esse sem marcar todos pacotes??? eu coloquei ele assim ele nao pega nenhum pacote na queue tree fica em 0 tanto no download e Upload

    e acaba não dividindo a banda nenhuma.


    Alguem tem isso funcionando perfeitamente e testado com certeza ???

    se alguem puder me ajudar fico agradecido



  15. #35

    Padrão

    to com uma dúvida em relação, ao PCQ!
    eu preciso criar Queues Types para cada velocidade vendida?

    Se usar queue tree ele pega e divide automaticamente?
    Se usar queue simple 0/24 ele divide automaticamente pra toda a range?
    Se usar queue simple individual apenas setando o queue type para cada cliente ele faz o mesmo trabalho?


    Desculpe o monte de perguntas!

  16. #36



  17. #37

    Padrão

    1. Marque todos os pacotes com packet-mark all:

    /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no

    2. Configurar dois queue types PCQ - um para download e outro para upload. Dst-address é classificador do tráfego de download do usuário, src-address para o tráfego de upload:

    /queue type add name=”PCQ_download” kind=pcq pcq-rate=64000 pcq-classifier=dst-address
    /queue type add name=”PCQ_upload” kind=pcq pcq-rate=32000 pcq-classifier=src-address

    3. Finalmente, duas queue rules são necessárias, uma para download e um para upload:

    /queue tree add parent=global-in queue=PCQ_download packet-mark=all
    /queue tree add parent=global-out queue=PCQ_upload packet-mark=all
    Se você não gosta de usar mangle ou queue tree, você pode ignorar esta etapa 1, mantendo as etapas 2 e 3 e passaria a criar uma simple queue como mostrado aqui:

    /queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24
    Nesse exemplo do Magal, então cada cliente da faixa 192.168.0.0/24 teria 64/32 ou eles iriam dividar essa banda?

  18. #38

    Padrão

    Citação Postado originalmente por kilder Ver Post
    Nesse exemplo do Magal, então cada cliente da faixa 192.168.0.0/24 teria 64/32 ou eles iriam dividar essa banda?
    Neste exemplo do magal, como ele definiu o valor pcq-rate, entao cada usuario usará no maximo 64/32 de banda até atingir o maximo da banda disponivel, depois disso a banda será dividida igualmente entre todos os usuarios...
    Se o pcq-rate ficar setado em 0 (zero), e somente 1 usuario estiver conectado, ele vai poder usar toda a banda disponivel (se vc tiver um link de 2mb por exemplo, e cliente vai navegar nesta velocidade), se 2 usuarios estiverem conectado, cada um utilizará 1mb, e assim por diante...
    Repare que no exemplo do Magal, embora o link seja de 2mb por exemplo, mas mesmo que soh tenha 1 cliente conectado, o maximo q ele usara sera 64/32 ... pq como eu disse acima, este valor foi escolhido em pcq-rate...



  19. #39

    Padrão

    sera q alguem poderia citar um exemplo q ja esteja funcionando com varias banda, eu por exeplo tenho 75k/150k, 150k/300k, 300k/600k e 500k/1Mb, uso hotspot e servidor dhcp.

  20. #40

    Padrão

    Olá amigo,
    Você pode fazer quantas bandas quiser mas lembre-se que, se tratando de PCQ, será dividida entre os vários usuário. ex: se fizer um src-address de 256k e dst-address 512k com 10 usuários conectados, você terá o seguinte calcúlo:
    Código :
    256k / 10 = 25,6k de upload
    512k / 10 = 51,2k de download
    PCQ é ideal para QoS.
    Para fazer o que quer aqui está um exemplo(256k/512k):
    Citação Postado originalmente por PCQ Upload
    /que type add name="up-banda_B" kind=pcq pcq-rate=512k pcq-classifier=src-address
    Citação Postado originalmente por PCQ Download
    /que type add name="down-banda_B" kind=pcq pcq-rate=512k pcq-classifier=dst-address
    Aí só escolher este pcq para os usuários desejados. Para outras bandas, fazer novos pcq's.
    Última edição por Raniel; 16-10-2009 às 12:34.