+ Responder ao Tópico



  1. #1

    Padrão Horário

    Pessoal, um cliente meu solicitou que a NEt dele funcione das 11 da manhã as 23, alguém tem uma dica, ou um script para desabilitar o arp dele nesses horários?


    Obrigado.

  2. #2

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Pessoal, um cliente meu solicitou que a NEt dele funcione das 11 da manhã as 23, alguém tem uma dica, ou um script para desabilitar o arp dele nesses horários?


    Obrigado.
    habilita uma simple queue por horário com tráfego 0KB, Roberto.



  3. #3

    Padrão

    Citação Postado originalmente por JHONNE Ver Post
    habilita uma simple queue por horário com tráfego 0KB, Roberto.

    Não era bem assim que eu estava pensando, mas já é uma dica...obrigado e espararei por outras...

  4. #4

    Padrão

    ola roberto,
    existe sim um script que desativa e ativa o arp desse cliente seria assim
    Código :
    /ip arp disable tg
    Código :
    /ip arp enable tg
    sendo que tg é o comentario que tem pra esse usuario no arp. so que nao da certo porque quando ele vai ativar ele ativa normal no arp mas nao é ativo ele fica vermelho so ativa normal quando o mikrotk é reiniciado.

    voce pode faser no firewall uma regra blokeando,e na aba extra tem Time ai vc define o horario que a regra sera ativada e desativada.

    valewwwwwww.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         tg.JPG
Visualizações:	94
Tamanho: 	31,6 KB
ID:      	4045  



  5. #5

    Padrão

    Assim meu caro,

    Add um comentário para o cliente, tipo fulano:
    Código :
    /ip arp add mac-address=001122334455 interface=lan comment="fulano"

    Depois faz um script para bloquear:
    Código :
    /system script add name=block policy=ftp,password,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/ip arp disable [/ip arp find comment="fulano"]"
    Depois um para liberar:
    Código :
    /system script add name=unblock policy=ftp,password,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/ip arp enable [/ip arp find comment="fulano"]"
    Aí você cria os schedulers para o horário do block e unblock:
    Código :
    /system scheduler add name=unblock start-time=11h interval=1d on-event=unblock disabled=no comment="desbloqueia"
    Código :
    /system scheduler add name=block start-time=11h interval=1
    d on-event=unblock disabled=no comment="bloqueia"

    Desta forma funciona que é uma beleza.

  6. #6

    Padrão

    Fiz uns scripts para quem usa hotspot também, é só fazer uma busca nos meus post aí que vai achar.



  7. #7

    Padrão

    E aí Roberto, deu certo os scripts apresentado pelo mestre Raniel?

  8. #8



  9. #9

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Fiz uns scripts para quem usa hotspot também, é só fazer uma busca nos meus post aí que vai achar.
    Só um comentário:

    no hotspot, quando um cliente loga é setado a velocidade para ele de acordo com o profile, se vc quiser dar a ele outra velocidade é necessário atualizar/trocar o profile e desconectar o que cliente para que logue dnovo. É isso que faz o script?

    e se o cliente estive no meio de um download?

  10. #10

    Padrão

    Esta é a maneiro, mas no meu caso, eu não controlaria por hotspot dinamicamente.
    E se ele estiver em 99% já era.



  11. #11

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Esta é a maneiro, mas no meu caso, eu não controlaria por hotspot dinamicamente.
    E se ele estiver em 99% já era.
    Respeito seu projeto, sei que dá trabalho fazer script, mas no caso do hotspot acho que é desnecessário utilizar um script pra isto, visto que podemos criar o hotspot com um profile controle de banda e controla-la na simple queue que permite ser atividada ou desativada por horários sem interferir no dowload corrente do cliente

  12. #12

    Padrão

    Mas no caso citado, o usuário poderá usar quando quiser durante um período determinado e isto irá afetar o provedor, pois há pessoas que não usam diariamente e da forma que falei irá manter o horário. Mas o dito não deixa de ser uma boa opção. Poderia mostrar-nos esta maneira?