+ Responder ao Tópico



  1. #181
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Eu não sei o que aconteceu mais agora ta funcionando normal, as vezes da timeout, as vezes ~da erro de autenticação, mais ta funcionando!

    O PCC é uma maravilha, se vc não precisar acessar sua rede extenamente, se vc tem uma pagina hospedada, por exemplo, na mesma maquina que vc faz o cache, ou se precisar acessar o seu mk-controlador, ai ja era. Nesses quesitos prefiro o PFsense, esse papel ele faz certinho, tem tbm o ZeroShell, esse ainda eu não mexi, eu realmente vou abandonar o PCC do Mikrotik, estou muito descepcionado, ele não deixa passar nada, ja tentei varias regras que meus colegas me passaram mais mesmo assim não vai...
    Fica ai meu desabafo, o PCC é otimo, se vc não precisar de acessar nada que venha depois dele!

    é só você conectar no seu mk, e utilizar o telnet dele até o outro mk oras,
    ou você so mexe com a interface grafica?

  2. #182

    Padrão

    Citação Postado originalmente por Binhos5 Ver Post
    agora utilizando os classificadores (0,1,2 e portanto são 3) na interface de clientes criamos novas marcas de conexão (conn_ma0, conn_mb1, conn_mc2), notem que se tivessemos 4 links seria aquie que fariamos as alterações para (0,1,2,3 e portanto são 4) ficando 4/0, 4/1, 4/2, 4/3 ou ainda se tivessemos links assimétricos onde por exemplo:

    LinkX de 512k
    LinkY de 1024k
    LinkZ de 2048k

    somariamos todos os links e dividiriamos pelo valor do menor link então teriamos 3584k/512k=7 então teriamos 7 marcações de pcc indo de 7/0 até 7/6 das quais devemos direcionar a primeira pro link X, a segunda e terceira pro link Y e as quatro restantes para o link Z fazendo nosso sistema perfeitamente equilibrado, vale resaltar que sistemas do tipo ADSL não garantem a banda e portanto devemos fazer testes em cada um dos links para aferir as velocidades possíveis em cada um, já vi muitos casos onde um link desse tipo de 2Mb era melhor do que o de 4Mb da mesma operadora instalada no mesmo local, também se deve criar as marcações para input e output.




    Amigo vc poderia demostrar como faço pra colocar duas conexoes pra um link tres pra outro link e quatro pra outro link, nao leve a mau é pq tenho varios links q nao sao do mesmo valores ............
    Você mesmo já postou a resposta... basta ler o topico do inicio que encontrará inclusive as regras.. ai é só adaptar pra sua necessidade...



  3. #183

    Padrão Balanceamento

    Citação Postado originalmente por tiagomatias Ver Post
    Eu não entendo essa sua pergunta.

    Amigo é tipo assim: tenho dois links um de 1024kbps e outro de 512kbps. Somando e dividindo como mostra nosso amigo m4d3 da 3 marcações pcc. entao queria saber como faço pra colocar duas marcaçoes no link de 1024kbps e uma no link de 512kbps ..................

  4. #184

    Padrão

    Citação Postado originalmente por Binhos5 Ver Post
    Amigo é tipo assim: tenho dois links um de 1024kbps e outro de 512kbps. Somando e dividindo como mostra nosso amigo m4d3 da 3 marcações pcc. entao queria saber como faço pra colocar duas marcaçoes no link de 1024kbps e uma no link de 512kbps ..................
    basta vc repetir no /ip firewall mangle as regras aonde tem o both-addres jogando para a marcação dos links, repita jogando para a marcação q vc mais de uma vez.



  5. #185

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    basta vc repetir no /ip firewall mangle as regras aonde tem o both-addres jogando para a marcação dos links, repita jogando para a marcação q vc mais de uma vez.

    Amigo fiz exatamente isso no tato mesmo quebrando a cabeça, so precisava de uma confirmação. perfeito............

    Ainda nao testei o balanceamento so estou configurando tudo conforme o tuto de m4d3, assim q testar estarei aki falando e postando o q vai acontecer em tempo real.

  6. #186

    Padrão

    Citação Postado originalmente por Binhos5 Ver Post
    Amigo fiz exatamente isso no tato mesmo quebrando a cabeça, so precisava de uma confirmação. perfeito............

    Ainda nao testei o balanceamento so estou configurando tudo conforme o tuto de m4d3, assim q testar estarei aki falando e postando o q vai acontecer em tempo real.
    Só para ficar mais claro as regras q ira repetir de acordo com o manual do m4d3 são:

    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=both-addresses:2/1

    basta repetir elas como por exemplo acima repeti a regra jogando duas vezes para um link, como viu acoma basta vc fazer os calculos necessarios e fazer de acordo com sua necessidade



  7. #187

    Padrão Balanceamento

    Amigos gostaria de saber de vcs q usam o balanceamento mais com links de operadoras diferentes, qual dns vc usam q fique uma boa perfomace..........


    Jainstalei o balanceamento e pudi perceber q quando um link cai vc vai navegando abrindo paaginas mais uma hora da q a pagina nao pode ser exibiba, me parece q quando um link cai e a marcação vai pra ele nao passa pra outro link nao, alguem reparou isso.........
    Última edição por Binhos5; 28-10-2009 às 11:44.

  8. #188

    Padrão

    Citação Postado originalmente por Binhos5 Ver Post
    Amigos gostaria de saber de vcs q usam o balanceamento mais com links de operadoras diferentes, qual dns vc usam q fique uma boa perfomace..........


    Jainstalei o balanceamento e pudi perceber q quando um link cai vc vai navegando abrindo paaginas mais uma hora da q a pagina nao pode ser exibiba, me parece q quando um link cai e a marcação vai pra ele nao passa pra outro link nao, alguem reparou isso.........

    o ideal é vc ter um servidor dns para cada link, mas caso n tenha, coloca o primario DNS o DNS da operadora q tem o maior link, ou melhor link. Outra opção é quando um link cair faça um script para tirar o DNS da operadora q esta fora, isso vai resolver seu problema de expiraçào de pagina.



  9. #189

    Talking Deixo aqui minha comtribuição com o PCC

    Estou usando a Versao 4.2 do MK com PCC e esta Rodando 100% com PCC de 2 Links ADSL 4MiB

    Código :
    # nov/01/2009 00:45:02 by RouterOS 4.2
    #
     
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment=\
        "Interface da Rede Interna" disable-running-check=yes disabled=no \
        full-duplex=yes l2mtu=1600 mac-address=00:1F:D0:E8:83:D2 mtu=1500 name=\
        EthClientes speed=1Gbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment=\
        "Interface do Modem B " disable-running-check=yes disabled=\
        no full-duplex=yes mac-address=00:50:DA:7A:4F:13 mtu=1500 name=WanB \
        speed=100Mbps
    set 2 arp=enabled auto-negotiation=yes cable-settings=default comment=\
        "Interface do Modem A " disable-running-check=yes disabled=\
        no full-duplex=yes mac-address=00:50:DA:B6:0D:8E mtu=1500 name=WanA \
        speed=100Mbps
    /interface pppoe-client
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\
        "PPPOE do Link A" dial-on-demand=no disabled=no interface=\
        WanA max-mru=1492 max-mtu=1492 mrru=disabled name=EthLinkA password=\
        seu_password profile=default service-name="" use-peer-dns=no user=\
        [email protected]_provedor
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\
        "PPPOE do Link B" dial-on-demand=no disabled=no interface=\
        WanB max-mru=1492 max-mtu=1492 mrru=disabled name=EthLinkB password=\
        seu_password profile=default service-name="" use-peer-dns=no user=\
        [email protected]_provedor
     
    /ip firewall address-list
    add address=200.155.0.0/16 comment="" disabled=no list=BRADESCO
    add address=200.201.0.0/16 comment="" disabled=no list=CEF
    add address=170.66.0.0/24 comment="" disabled=no list=BB
    add address=200.220.0.0/16 comment="" disabled=no list=SANTANDER
    add address=200.196.0.0/16 comment="" disabled=no list=ITAU
    add address=189.56.0.0/16 comment="" disabled=no list=NOSSACAIXA
    add address=161.113.0.0/24 comment="" disabled=no list=HSBC
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO1
    add address=201.7.180.0/24 comment="" disabled=no list=GLOBO2
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO3
    add address=200.154.56.0/24 comment="" disabled=no list=TERRA
    add address=208.84.247.0/24 comment="" disabled=no list=TERRA
    add address=10.10.0.0/20 comment="" disabled=yes list=sem_balance
    add address=62.140.0.0/16 comment="" disabled=no list=rapidshare
     
    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
        dst-address-list=sem_balance in-interface=EthClientes
    add action=accept chain=prerouting comment="LIBERAR SITES HTTPS" disabled=no \
        dst-address-list=BB in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        BRADESCO in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        CEF in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        HSBC in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        ITAU in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        NOSSACAIXA in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        SANTANDER in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        GLOBO1 in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        GLOBO2 in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        GLOBO3 in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        TERRA in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
        rapidshare in-interface=EthClientes
    add action=mark-connection chain=input comment=\
        "********************Marca Novas Conexoes" connection-state=new disabled=\
        no in-interface=EthLinkA new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=EthLinkB new-connection-mark=conn_nb \
        passthrough=yes
    add action=mark-routing chain=output comment="Marcando Rotas" \
        connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
        disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment=Balanceando disabled=no \
        dst-address-type=!local in-interface=EthClientes new-connection-mark=\
        conn_ma0 passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=EthClientes new-connection-mark=\
        conn_mb1 passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment=\
        "********************Marca Rotas de Saida" connection-mark=conn_ma0 \
        disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=\
        no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
        disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=\
        no
    add action=mark-connection chain=forward comment="Marca p2p" disabled=no \
        new-connection-mark=p2p_conn p2p=all-p2p passthrough=yes
    add action=mark-packet chain=forward comment="" connection-mark=p2p_conn \
        disabled=no new-packet-mark=p2p passthrough=yes
    add action=mark-packet chain=forward comment="" connection-mark=!p2p_conn \
        disabled=no new-packet-mark=other passthrough=yes
    add action=change-mss chain=forward comment="Ajuste de Quadros para o MSN" \
        disabled=no new-mss=1380 protocol=tcp tcp-flags=syn
    add action=change-ttl chain=forward comment=\
        "BLOQUEIO DE TRACERT E TRACEROUTE" disabled=no new-ttl=set:30 protocol=\
        icmp
     
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="Macaramento dos Links" disabled=\
        no out-interface=EthLinkB src-address=10.10.0.0/20
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
        EthLinkA src-address=10.10.0.0/20
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
        disabled=no src-address=10.10.0.0/20
     
    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
        0.0.0.0/0 gateway=EthLinkA routing-mark=to_nra scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
        0.0.0.0/0 gateway=EthLinkB routing-mark=to_nrb scope=30 target-scope=10
    add check-gateway=ping comment="Rota padrao Modem B" disabled=no \
        distance=2 dst-address=0.0.0.0/0 gateway=EthLinkB scope=30 target-scope=\
        10
    add check-gateway=ping comment="Rota de sombra Modem A" disabled=\
        no distance=3 dst-address=0.0.0.0/0 gateway=EthLinkA scope=30 \
        target-scope=10

    by Load Balance PCC Geeek

  10. #190

    Padrão

    nao estou conseguindo fazer communicar a rb450 onde faço somente PCC com o pc/mikrotik onde faço controle dos cliente, que regras tenho que criar no pc/mikrotik.
    na rb450 consigo acessar normal internet pela saida Cliente. desde ja agradeço.



  11. #191

    Padrão

    Citação Postado originalmente por juliocfs Ver Post
    nao estou conseguindo fazer communicar a rb450 onde faço somente PCC com o pc/mikrotik onde faço controle dos cliente, que regras tenho que criar no pc/mikrotik.
    na rb450 consigo acessar normal internet pela saida Cliente. desde ja agradeço.
    O que o amigo quer com este post ? Por favor, refaça seu post com coerência, se quer ajuda indique onde e como precisa de ajuda, com clareza poderemos te ajudar e você a nos ajudar a manter o tópico limpo e organizado servindo ao propósito para o qual foi criado.

    Tenho certeza de que todos que leram o que você escreveu foi porque gostariam de ajudar, mas como vão ajudar se não dá pra saber qual é o problema? Você tem uma dúvida? Teve algum erro especifico durante a configuração? Seguiu as informações já contidas neste tópico? Se o problema for com o PCC este é o lugar certo senão, procure pelo assunto na busca do fórum pois existem grandes chances de alguém já ter respondido, senão, crie o tópico que tentaremos lhe ajudar.
    Última edição por m4d3; 02-11-2009 às 16:36.

  12. #192

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    O que o amigo quer com este post ? Por favor, refaça seu post com coerência, se quer ajuda indique onde e como precisa de ajuda, com clareza poderemos te ajudar e você a nos ajudar a manter o tópico limpo e organizado servindo ao propósito para o qual foi criado.

    Tenho certeza de que todos que leram o que você escreveu foi porque gostariam de ajudar, mas como vão ajudar se não dá pra saber qual é o problema? Você tem uma dúvida? Teve algum erro especifico durante a configuração? Seguiu as informações já contidas neste tópico? Se o problema for com o PCC este é o lugar certo senão, procure pelo assunto na busca do fórum pois existem grandes chances de alguém já ter respondido, senão, crie o tópico que tentaremos lhe ajudar.
    Vou explicar melhor minha dificuldade.
    RB450 somentePCC------>PC/mikrotik controle clientes----->Clientes
    A saida lan da rb450 que se comunica com o PC/mikrotik na interface cliente nao acessa internet. mais se colocar cabo de rede ligado do notebook na rb450 acessa normal internet, minha dificuldade e passar internet para o PC/mikrotik. teria que criar alguma regra de nat no PC/mikrotik que regras seriam.



  13. #193
    Não Registrado
    Visitante

    Padrão

    Amigo pelo que entendi seu problema está sendo apenas na routa para o Mk, ou seja o ip da lan que sai da RB450, terá que ser usado como o Gatway para o mikrotik que por sua vez deverá ter uma placa de rede wan na mesma faixa de ip da RB. ex: ip da placa de rede wan do MK: 192.168.200.2,
    ip da placa lan da rb 192.168.200.1. Em ip route fica assim:

    add dst-address=0.0.0.0/0 gateway=192.168.200.1 distance=1 scope=255 target-scope=10 comment="" disabled=no. Pronto agora é so configurar o DNS e boa sorte.

  14. #194

    Padrão

    queria agradecer a todos que colaboraram nesse topico.hoje consegui fazer funcionar o PCC com dois adsl e briged esta perfeito.



  15. #195

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Amigo marsilba fica complicado ele funcionar corretamente se não se configura corretamente...
    vamos aos fatos, quando se configura o mikrotik para discar os modens ADSL/VELOX etc com pppoe-outX as interfaces dos links n é mais a interface q esta conectado ao modem e sim o pppoe-outX que vc definiu para discar o modem. Pensando nesta lógica toda sua configuração aonde tem as interfaces EthLinkX mude para as respectivas interfaces pppoe-outX.

    Por isso seu balanceamento estava furado, ele n estava fazendo marcação corretamente.

    Em fim só para frisar, mude em toda sua configuração aonde tiver EthLinkX para os pppoe-outX, digo em:

    /ip firewall nat
    /ip firewall mangle
    /ip route

    Acredito que agora vc resolve seu problema,

    Volto a dizer o PCC é o melhor loadbalaced que a mikrotik tem excelente ferramente, mas lógico que bem configurado, n basta seguir um howto e não se adptar a sua realidade

    abraços
    Tiago usei as regras que você postou mas o trafego esta saindo mais pelo link 1 de 4

  16. #196

    Padrão

    Galera fiz esse balanceamento aki... qual a melhor forma de eu testar se esta funcionando certinho???

    Outra coisa fiz tudo certinho conforme o tutorial... funcionou mas o problema é que eu uso um gerenciador financeiro do bradesco e hora vai hora naum funciona... alguem esta passando por isso se puderem ajudar valeu... ai vai as minhas confs pra verem se tem algum erro...

    Mangle:
    chain=prerouting action=accept dst-address-list=sem_balance in-interface=Bridge Enlaces
    1 chain=input action=mark-connection new-connection-mark=conn_link-1 passthrough=yes connection-state=new in-interface=Link 1
    2 chain=input action=mark-connection new-connection-mark=conn_link-2 passthrough=yes connection-state=new in-interface=Link 2
    3 chain=output action=mark-routing new-routing-mark=to_r1 passthrough=no connection-mark=conn_link-1
    4 chain=output action=mark-routing new-routing-mark=to_r2 passthrough=no connection-mark=conn_link-2
    5 chain=prerouting action=mark-connection new-connection-mark=conn_ma0 passthrough=yes dst-address-type=!local in-interface=Bridge Enlaces
    per-connection-classifier=both-addresses:2/0
    6 chain=prerouting action=mark-connection new-connection-mark=conn_mb1 passthrough=yes dst-address-type=!local in-interface=Bridge Enlaces
    per-connection-classifier=both-addresses:2/1
    7 chain=prerouting action=mark-routing new-routing-mark=to_nr1 passthrough=no in-interface=Bridge Enlaces connection-mark=conn_ma0
    8 chain=prerouting action=mark-routing new-routing-mark=to_nr2 passthrough=no in-interface=Bridge Enlaces connection-mark=conn_mb1

    Nat:
    0 X ;;; place hotspot rules here
    chain=unused-hs-chain action=passthrough
    1 X ;;; masquerade hotspot network
    chain=srcnat action=masquerade src-address=10.0.0.0/8
    2 ;;; Mascaramento PCC
    chain=srcnat action=masquerade out-interface=Link 1
    3 chain=srcnat action=masquerade out-interface=Link 2

    Route:
    0 A S 0.0.0.0/0 172.50.1.1 1
    1 A S 0.0.0.0/0 201.16.145.30 1
    2 A S 0.0.0.0/0 201.16.145.30 2
    3 S 0.0.0.0/0 172.50.1.1 3

    Valeu
    Última edição por tarcisiomk10; 13-11-2009 às 17:26.



  17. #197

    Padrão

    Oi amigo Luciano

    PCC no balanço esta no Under-Linux, quando eu usar o modem de bridge, na configuração do mangle onde as conexões e rotas no interior, eu escrevo as regras de uso de interfaces de cada um modem adsl (pppoe1,pppoe2) ou utilizando o Ether1, ether 2 ?

    En español:
    en el balanceo PCC que esta en Under-Linux, cuando uso los modem en bridge, en la configuracion de mangle donde marco conexiones y rutas, debo escribir la reglas usando las interfaces pppoe de cada modem? o usando las ether1,ether2 del mikrotik???

    OBRIGADO

    OSVALDO
    ARGENTINA

  18. #198



  19. #199

    Padrão

    Cara, se eu pudesse te agradecia todo dia. Mas como podemos mostrar isso apenas uma vez foi feito.

    Seguindo seu tutorial a risca, sem tirar nem colocar, funciona perfeitamente. Muito bom mesmo. Procurei em diversos forums. Segui cada exemplo e o seu foi o melhor.

    Valeu cara... Continue assim.

    Efren Langsdorf Júnior
    Analista/Consultor JAVA
    [email protected] - Serviços em desenvolvimento de software e telecomunicações.
    Site: http://www.assinesuatv.net
    Última edição por efrenjunior; 28-12-2009 às 11:14. Razão: teste

  20. #200

    Padrão

    Citação Postado originalmente por efrenjunior Ver Post
    Cara, se eu pudesse te agradecia todo dia. Mas como podemos mostrar isso apenas uma vez foi feito.

    Seguindo seu tutorial a risca, sem tirar nem colocar, funciona perfeitamente. Muito bom mesmo. Procurei em diversos forums. Segui cada exemplo e o seu foi o melhor.

    Valeu cara... Continue assim.
    Mérito seu que soube seguir a risca o tutorial. Parabéns, espero que outros tb sigam o seu exemplo.