+ Responder ao Tópico



  1. #361

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Thiaggto, no começo do post esta falando sobre as versões se não em engano o pcc tem nas versões acima de 3.24. No post foi usada a 3.28 e eu uso aqui a 3.30.

  2. #362

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    amigo, na parte:
    Em rotas
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.1.10.129 scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.1.10.161 scope=30 target-scope=10
    add comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=10.1.10.193 scope=30 target-scope=10
    definimos 3 rotas padrão sendo que cada uma tem um custo diferente e portanto a primeira terá a preferencia, caso venha a faltar a segunda assume, em seguida a terceira

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.10.129 routing-mark=to_nra scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.10.161 routing-mark=to_nrc scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.10.193 routing-mark=to_nrb scope=30 target-scope=10
    em seguida todas as 3 rotas que utilizam marca de rotas (to_nra, to_nrb, to_nrc) dividem a carga que foi previamente marcada pelo mangle

    a segunda regra, nao esta invertida com a terceira ? uma vez qeu o to_nrc deveria ser do modem 193 e o to_nrb do modem 161 ?



  3. #363

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por thiaggto Ver Post
    esta regra funciona na versao 2.9.27 ? pq nao sai do lugar aqui.... abraços

    a versao 2.9.27 nao nao tem a funça pcc, que fica em ip>firewall>mangle>advance.

  4. #364

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por thiaggto Ver Post
    esta regra funciona na versao 2.9.27 ? pq nao sai do lugar aqui.... abraços
    Ja foi falado muuuitas vezes e tambem essa ultima estava pertinho. 3 post acima da sua pergunta,
    Citação Postado originalmente por mktguaruja Ver Post
    Amigo, eu acho que não vai funcionar certo porque para fazer o pcc tem que ser acima da 3.24 e você tem um backup da 2.9.6 tem regras que não vai funcionar aconselho você configurar do zero.
    Vamos ler os posts,, né
    Não funciona em mk abaixo do 3.24 aqui não ficou legal em nem uma versão. (mais comparei com debian)



  5. #365

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por dimensaonet Ver Post
    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=EthClientes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out1 new-connection-mark=conn_na \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out2 new-connection-mark=conn_nb \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out3 new-connection-mark=conn_nc \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out4 new-connection-mark=conn_nd \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nc \
    disabled=no new-routing-mark=to_rc passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nd \
    disabled=no new-routing-mark=to_rd passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_ma0 passthrough=yes per-connection-classifier=both-addresses:5/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_mb1 passthrough=yes per-connection-classifier=both-addresses:5/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_mb1 passthrough=yes per-connection-classifier=both-addresses:5/2
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_mc2 passthrough=yes per-connection-classifier=both-addresses:5/3
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_mc3 passthrough=yes per-connection-classifier=both-addresses:5/4
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=\
    no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=\
    no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mc2 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nrc passthrough=\
    no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mc3 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nrd passthrough=\
    no

    É ESSA AI AQUI TA FUNCIONANDO REDONDINHO QUALQUER COISA ESTAMOS AI PRA AJUDAR
    Amigo, me ajude
    consegui colocar o PCC pra rodar na RB, show de bola, balanceia que é uma beleza. Mas não conigo comunicar-me com o o meu servidor. ex:

    RB PCC 450G - - - - -MK controle - - - -Clientes

    Não consigo interligar minha RB pcc com minha RB controler, como faço?

  6. #366
    Avatar de dimensaonet
    Ingresso
    Feb 2010
    Localização
    São Francisco De Goiás, Goias, Brazil, Brazil
    Posts
    72

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    boa noite amigo tmelooliveira
    preciso muito de sua ajuda nesse script aqui poderia por favor mim esplicar melhor para eu tentar fazer funcionar aqui. é que eu sou novo nesse ngocio de mikrotik.

    vamos la ver se eu entendo...(PORTA QUE VAI SER ACESSADA 8291 JA TEM ELA LA NO MK NE?)
    (IP DA REDE LOCAL DO SERVIDOR É A PLACA DA SIADA DOS CLIENTES OU ENTRADA DO LINK?)
    (PORTA DO SERVIDOR PODE SER QUALQUER UMA? E ONDE EU ADD ELA?)
    pra mim ajudar melher alguem poderia postar essa regra completa? dai eu só mudo o ip da rede local pra minha.
    aguardo uma ajuda fique todos com Deus.

    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=PORTA QUE VAI SER ACESSADA \
    protocol=tcp to-addresses=IP DA REDE LOCAL DO SERVIDOR to-ports=PORTA NO SERVIDOR





  7. #367

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Amigo para se comunicar a rb e outro servidor, você trata com fosse um link roteado, colocar o ip e o gateway do mesmo no ip>route.

    Exemplo:
    PCC: ip >address> 192.168.88.1/24

    Controle: ip>address> 192.168.88.100/24
    ip>route> gateway> 192.168.88.1

    t+

  8. #368

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por mktguaruja Ver Post
    Amigo para se comunicar a rb e outro servidor, você trata com fosse um link roteado, colocar o ip e o gateway do mesmo no ip>route.

    Exemplo:
    PCC: ip >address> 192.168.88.1/24

    Controle: ip>address> 192.168.88.100/24
    ip>route> gateway> 192.168.88.1

    t+
    Valew Levy, meu camarada....show de bola, muito obrigado mesmo pela ajuda.

    esse cara é bom.



  9. #369

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Só tem um probleminha Levy, quando coloco ip.route e o gateway no Mk controle, cae na minha interface bridge, onde tenho minhas pontes de wds. Como colocar na interface de entrada certa?

  10. #370

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Entao mp3fm, voce tem que setar o gateway e o ip na porta de entrada onde antes voce recebi somente o link. Lembrando use classe diferentes do que voce usa ai no mk controle.t+



  11. #371

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Ressucitando o Debate, foi so eu q reparei q nas regras de ROUTE, o amigo M4D3 marco pacote das rotas como to_nra, t_nrb e to_nrc... e em MANGLE, tem 3 regras fazendo INPUT e OUTPUT, marcando a conexão de entrada fazendo ela sair pela marcaçao de rota to_ra, to_rb e to_rc. Onde no meu ver seria certo to_nra, to_nrb e to_nrc. As marcaçao de rota para to_ra, rb e rc nao foram feitas.... Esta certo as regras??

  12. #372

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por aka2005 Ver Post
    Ressucitando o Debate, foi so eu q reparei q nas regras de ROUTE, o amigo M4D3 marco pacote das rotas como to_nra, t_nrb e to_nrc... e em MANGLE, tem 3 regras fazendo INPUT e OUTPUT, marcando a conexão de entrada fazendo ela sair pela marcaçao de rota to_ra, to_rb e to_rc. Onde no meu ver seria certo to_nra, to_nrb e to_nrc. As marcaçao de rota para to_ra, rb e rc nao foram feitas.... Esta certo as regras??
    Na verdade acho que isso já foi discutido aqui, vc tem estas 4 opções:
    1 - eliminar as regras
    2 - criar as rotas
    3 - alterar pra ficar como as outras
    4 - deixar como está

    O balance irá funcionar de qualquer modo, tem ainda muitas opções que podem ser adicionadas a este balance o que queremos com o post é fazer que o usuário entenda o que é feito e chegando neste ponto ele pode tomar a decisão que quiser, fazendo o balance, somando a redundância, fixando rotas e muito mais.

    A propósito, li um dia um tópico seu ou onde você era o principal comentador sobre utilizar o mikrotik e as oid pra gerar os graficos de consumo via snmp, muito interessante se quiser debater me add no msn/skype ou envie um email.

    Abraço



  13. #373

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por m4d3 Ver Post
    Na verdade acho que isso já foi discutido aqui, vc tem estas 4 opções:
    1 - eliminar as regras
    2 - criar as rotas
    3 - alterar pra ficar como as outras
    4 - deixar como está

    O balance irá funcionar de qualquer modo, tem ainda muitas opções que podem ser adicionadas a este balance o que queremos com o post é fazer que o usuário entenda o que é feito e chegando neste ponto ele pode tomar a decisão que quiser, fazendo o balance, somando a redundância, fixando rotas e muito mais.

    A propósito, li um dia um tópico seu ou onde você era o principal comentador sobre utilizar o mikrotik e as oid pra gerar os graficos de consumo via snmp, muito interessante se quiser debater me add no msn/skype ou envie um email.

    Abraço
    SIm excelente topico o seu aki, vi as regras la, so comentei pra tirar duvidas mesmo, pois a explicaçao sua é completa... ai vai do desenvolvedor criar do jeito necessario dele. aki ja cheguei a balancear cerca de 48 links.... mas pensa num script longo pra monitorar puts... e memoria tbm do cpu pra uso dos mesmo, nada q um bom dedicado resolva tudo... Vlw, estou mesmo montando um CACTI bom pra monitoramento, pq o q chega de cliente reclamando que nao uso internet, e o grafico tira a "prova dos 9" dele rs.

  14. #374

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    amigo, eu tambem enfrento este problema, o cliente cai a internet, quando eu reinicio o modem, ele ja liga na hora bravo dizendo que ja tem 1 semana que nao esta navegando, eu fico puto da cara, se vc conseguir me ajudar com algo que eu possa provar que ele esta mentindo, vai ser ótimo.



  15. #375

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Aqui usamos o mk-auth, ele lista todas as conexões do login, assim como upload e downloads gastos, e data e tempo de utilização. Quando o cara liga dizendo esse tipo de coisa, imprimo esse relatório e falo pra ele... (ou você usou ou passou a senha pra alguem, pois aqui pova que alguem tá usando)
    Abraços.

  16. #376

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Prezados, agora meu PCC está funcionando blz, show de bola. Mas só com 1 empecíliio. Os vídeos da Globo.com ainda não funcionam. Fiz as regras aqui descritas mas continua sem funcionar.

    Outra coisa é que perdi meu acesso remoto ao Mikrotik. antes do PCC conseguia acessa-lo remotamente; agora não mais. Poderiam os feras judar-me nessa saga? Um abraço



  17. #377

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por mp3fm Ver Post
    Prezados, agora meu PCC está funcionando blz, show de bola. Mas só com 1 empecíliio. Os vídeos da Globo.com ainda não funcionam. Fiz as regras aqui descritas mas continua sem funcionar.
    Vc tem q tirar o globo.com do PCC, cria uma regra pra passar direto alguns ips, tipo caixa, video.globo, bancos.

    Outra coisa é que perdi meu acesso remoto ao Mikrotik. antes do PCC conseguia acessa-lo remotamente; agora não mais. Poderiam os feras judar-me nessa saga? Um abraço
    Roteamento seria o problema, pode ajuda ate q dá. mas diga como ta suas conf. amigo, bola d cristal ta dificil a gente ter. rs....

  18. #378

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Bom dia! Amigos , o meu problema é o seguinte, uso pcc tenho uma rb450g que passa o sinal para o pc-mikrotik(Controle) e uso tambem poxy paralelo ( MK-AUTH ) ja consegui fazer o redirecionamento para o MK-AUTH mas a rota não sustenta ou seja quando alguém de fora da rede acessa o site do mkauth outras pessoas não consegue acesso , alguém pode me explicar o que estou fazendo de errado meu link é http://wirelink-net.ddns.info:82 (alguns consegue acesso outros não ) se alguns consegue é porque as regras estão certas. Agradeço a quem puder me ajudar.Obrigado!

    Regras da RB450G
    add action=dst-nat chain=dstnat comment="WWW - Apache" disabled=no dst-address=0.0.0.0/0 dst-port=82 protocol=tcp to-addresses=192.168.6.2 to-ports=82

    Regras do Pc-mikrotik

    add action=dst-nat chain=dstnat comment="Acesso Remoto Mk-auth" disabled=no dst-port=82 protocol=tcp src-address=192.168.10.0/24 to-addresses=172.31.255.2 \
    to-ports=80
    Última edição por Sergiotec; 25-05-2010 às 11:12.



  19. #379

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Aqui está passando normalmente globo.com pelo balanceamento.

  20. #380

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Aqui o site da Globo.com passa fora do pcc, na lista que coloquei no IP>firewall>address-list.