Página 3 de 26 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão

    querido quero saber se estas regras que vc postou ela se atribui a versao mais antiga do mikrotik pra fazer um load balanc com 3 o 4 links por soma

  2. #42

    Padrão otimo

    vamos testar o bicho pra ver até onde nos podemos chegar,,parabens colega



  3. #43

    Padrão

    Citação Postado originalmente por DSSS Ver Post
    Thiago estou notando que minha marcação não esta funcionando. Veja nas figuras que a conexão Ethlink A não tem quase tráfego (esse é o link full de 2megas) ja a Interface PPPOe out1 o tráfego esta acima de 2 megas (esse é o ADSL com 8 megas). To notando que o trafego não esta sendo balanceado? mesmo eu marcando no mangle a conexão 4x para o PPPoe e 1x para Ethlink A. O que vc acha que deve ta errado?

    Abraços





    http://img2.imageshack.us/img2/2039/mk02.jpghttp://img2.imageshack.us/img2/9504/mk01.jpg
    Ola dsss,

    desculpe pela demora, estava apurado por aqui esses dias...

    amigo precisamos do exporto do seu mangle e rotas para podermos ver o q pode ser o erro. Isso caso ainda n tenha resolvido, mas caso já tenha resolvido, diga para o pessoal qual foi a solução

    abraços

  4. #44

    Padrão

    Estou com o mesmo problema que o seu. Tenho PCC com 2 adsl. Um fica lá em cima o link batendo 2 Mb o outro só as vezes que é acionado, e quando acionado vai até 300 Kbps e volta pro 0.00. O que pode ser?



  5. #45

  6. #46

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Ola dsss,

    desculpe pela demora, estava apurado por aqui esses dias...

    amigo precisamos do exporto do seu mangle e rotas para podermos ver o q pode ser o erro. Isso caso ainda n tenha resolvido, mas caso já tenha resolvido, diga para o pessoal qual foi a solução

    abraços
    Sem problemas Tiago, agradeço por responder! Veja só sempre que defino a rota com prioridade maior para um determinado link sempre consumo do link da rota é maior, até ai tudo bem, mas note que se eu fizer o inverso, pôr a rota para o link ADSL além de ter maior velocidade de download, o link full fica praticamente parado, mesmo como tendo dito anteriormente, fazendo a divisão correta pela marcação do mangle, segue ai meu mangle.



    /ip firewall mangle
    add action=accept chain=prerouting comment="Sem Balance" disabled=no dst-address-list=sem_balance in-interface=\
    EthClientes
    add action=mark-connection chain=input comment=PCC connection-state=new disabled=no in-interface=EthLinkA \
    new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=pppoe-out1 \
    new-connection-mark=conn_nb passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=EthLinkC \
    new-connection-mark=conn_nc passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=\
    no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=\
    no
    add action=mark-routing chain=output comment="" connection-mark=conn_nc disabled=no new-routing-mark=to_rc passthrough=\
    no
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=both-addresses:8/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=both-addresses:8/1
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=src-address:8/2
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=src-address:8/3
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=src-address:8/4
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mc2 passthrough=yes per-connection-classifier=src-address:8/5
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mc2 passthrough=yes per-connection-classifier=src-address:8/6
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes \
    new-connection-mark=conn_mc2 passthrough=yes per-connection-classifier=src-address:8/7
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 disabled=no in-interface=EthClientes \
    new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=EthClientes \
    new-routing-mark=to_nrb passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mc2 disabled=no in-interface=EthClientes \
    new-routing-mark=to_nrc passthrough=no


    /ip route


    add check-gateway=ping comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=200.249.152.129 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out1
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.249.152.129 routing-mark=to_nra scope=30 \
    target-scope=10
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=192.168.253.254 routing-mark=to_nrc scope=30 \
    target-scope=10
    add comment="" disabled=yes distance=4 dst-address=0.0.0.0/0 gateway=192.168.253.254 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_nrb
    add comment="" disabled=no distance=2 dst-address=200.249.152.129/32 gateway=EthLinkA

    Última edição por DSSS; 20-09-2009 às 02:27. Razão: por a rotas



  7. #47

    Padrão

    Amigos, voces usam nos clientes IP Valido ou Invalido? Fixo ou Dinamico?

    Mais uma coisa... estou usando esse PCC e agradeço ao autor, e parabens pelo tuto... porem....
    queria saber 2 coisa.

    Quando um link cai o outro nao eh para assumir? ou nao?
    Meus clientes sempre pegam o MESMO IP VALIDO, isso é correto?

    Abraços!
    Última edição por thiagotgc; 22-09-2009 às 12:15.

  8. #48

    Padrão

    Será que alguém poderia me ajudar. Tenho dois links adsl e fiz o balanceamento do início do forum, parece estar tudo certo, mas só um link fica rodando, o outro fica parado, só às vezes ele vai e puxa 400 Kbps ou um pouco mais e volta pro 0,00. Os dois links estão conectados e navegando normalmente. Quando tiro o cabo de um o outro assume e vice-versa. O que pode estar errado? Tenho certeza que conseguirei encontrar uma solução com as respostas aqui do fórum. Segue minha ip>firewall>mangle ip>route e ip>nat. A princípio, uso uma rb450g, só para saberem.

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=EthClientes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=EthLinkA new-connection-mark=conn_na \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=EthLinkB new-connection-mark=conn_nb \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=local in-interface=EthClientes new-connection-mark=\
    conn_ma0 passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=local in-interface=EthClientes new-connection-mark=\
    conn_mb1 passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=\
    no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=\
    no

    /ip route
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkA
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA \
    routing-mark=to_nra
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=EthLinkB
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB \
    routing-mark=to_nrb
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkA
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=EthLinkB
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA \
    routing-mark=to_nra
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB \
    routing-mark=to_nrb

    /ip firewall nat
    add action=accept chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=EthLinkA
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    EthLinkB
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    src-address=xx.xx.xx.xx/24



  9. #49

    Padrão pcc

    amigo veja que sua marcação na contagem esta faltando uns detalhes espero que releia os topicos que vera onde esta errando, não vou postar o erro pois o intuito e de voce ver e aprender pelo como colocar as regras no sistema ok. qualquer duvida poste ai.

  10. #50

    Padrão

    Amigo parece que voce esta repetindo 2 vezes as mesmas regras no /ip route ??

    /ip route
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkA
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA \
    routing-mark=to_nra
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=EthLinkB
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB \
    routing-mark=to_nrb

    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkA
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=EthLinkB
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA \
    routing-mark=to_nra
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB \
    routing-mark=to_nrb



  11. #51

    Padrão

    Pelo que vi está faltando uma exclamação antes do dst-address-type=local (!local) , mas realmente não sei para que serve. Alguém poderia explicar para que serve? Se existir outro erro favor relatar.

  12. #52

    Padrão

    Marquei a opção invert e está funcionando legal. A tal exclamação apareceu, mas não sei para que serve. As rotas que tinha feito duas vezes também tirei e mantive somente uma. A marcação está beleza em firewall connections, saindo pelo ma0 e mb1, mas o link 2 continua com pouca carga. O link 1 fica lá em cima direto e o 2 só às vezes é acionado e volta pro 0. O que pode ser isso? Me ajudem, está ficando quase redondo o PCC.



  13. #53

    Padrão

    por favor de um print, das telas aonde vc fala que só o link2 esta tendo carga maxima!

    PS: O meu tbm nao esta "somando" os links... ele só esta sobrecarregando um só!!!

    =/
    Última edição por thiagotgc; 24-09-2009 às 08:30.

  14. #54

    Padrão

    estou acompanhando esse post e o outro que tambem fala do pcc, e estudando os 2 estou tentando implentar aqui na minha rede,, tenho aqui 2 links, um de 256 e outo de 512.
    só que quando eu coloquei o pcc pra rodar o hotspot parou, não abre mais nem a pagina de autenticação, estive olhando os conceitos do outro topico, mas não consegui achar o erro das minhas configurações, vou postar elas abaixo, para que os amigos possam me dar uma luz..

    Att
    Helder



    Código :
     
     
    /ip address
    add address=172.16.0.254/24 broadcast=172.16.0.255 comment="Rede Local - Clientes Prefeitura" disabled=no interface="Rede Local" network=172.16.0.0
    add address=189.80.16.82/29 broadcast=189.80.16.87 comment="Ip Link 256" disabled=no interface="Oi UP 256" network=189.80.16.80
    add address=189.80.219.82/29 broadcast=189.80.219.87 comment="Ip Link 512" disabled=no interface="Oi UP 512" network=189.80.219.80
    add address=10.10.10.1/24 broadcast=10.10.10.255 comment="Rede Local - Clientes Rua" disabled=no interface="Rede Local" network=10.10.10.0
     
     
    / ip firewall mangle
    add chain=input in-interface="Oi UP 512" action=mark-connection new-connection-mark=Oi_UP_512_conn
    add chain=input in-interface="Oi UP 256" action=mark-connection new-connection-mark=Oi_UP_256_conn
    add chain=output connection-mark=Oi_UP_512_conn action=mark-routing new-routing-mark=to_Oi_UP_512
     
    add chain=output connection-mark=Oi_UP_256_conn action=mark-routing new-routing-mark=to_Oi_UP_256
    add chain=prerouting dst-address=189.80.219.80/29  action=accept in-interface=Rede Local
     
    add chain=prerouting dst-address=189.80.16.82/29  action=accept in-interface=Rede Local
    add chain=prerouting dst-address-type=!local in-interface="Rede Local" per-connection-classifier=both-addresses:2/0 \
        action=mark-connection new-connection-mark=Oi_UP_512_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface="Rede Local" per-connection-classifier=both-addresses:2/1 \
        action=mark-connection new-connection-mark=Oi_UP_256_conn passthrough=yes
    add chain=prerouting connection-mark=Oi_UP_512_conn in-interface="Rede Local" action=mark-routing new-routing-mark=to_Oi_UP_512
    add chain=prerouting connection-mark=Oi_UP_256_conn in-interface="Rede Local" action=mark-routing new-routing-mark=to_Oi_UP_256
     
    / ip route
    add dst-address=0.0.0.0/0 gateway=189.80.219.81 routing-mark=to_Oi_UP_512 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.16.81  routing-mark=to_Oi_UP_256 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.219.81 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.16.81  distance=2 check-gateway=ping
     
    / ip firewall nat 
    add chain=srcnat out-interface="Oi UP 512" action=masquerade
    add chain=srcnat out-interface="Oi UP 256" action=masquerade
    Última edição por exclusivenet; 24-09-2009 às 13:00. Razão: errei o code



  15. #55

    Padrão

    Ahh galera, e alem de nao "somar" os links, aqui ta dando problema com site de Bancos e outros... pois eles dizem que eu "mudei" de ip.

    Ja cadastrei o site do Banco no address list, e coloquei como "sem balance" ficando assim:

    /ip firewall address-list
    add address=200.155.80.0/24 comment="" disabled=no list=sem_balance
    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE DE DESTINO" disabled=no dst-address-list=sem_balance in-interface=LOCAL
    Quem pode ajudar?

  16. #56

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Ahh galera, e alem de nao "somar" os links, aqui ta dando problema com site de Bancos e outros... pois eles dizem que eu "mudei" de ip.

    Ja cadastrei o site do Banco no address list, e coloquei como "sem balance" ficando assim:

    /ip firewall address-list


    /ip firewall mangle


    Quem pode ajudar?
    Mude a faixa de IP sua para 200.155.80.0-200.155.255.255



  17. #57

    Padrão

    boa tarde galera...

    estou querendo colocar o pcc pra rodar aki no meu provedor, mas to com a versao 3.13 crackeada, como posso fazer a atualizacao pra poder ter a versao com o pcc?

    desde ja agradeco

  18. #58

    Padrão

    Citação Postado originalmente por JeffersonParre Ver Post
    boa tarde galera...

    estou querendo colocar o pcc pra rodar aki no meu provedor, mas to com a versao 3.13 crackeada, como posso fazer a atualizacao pra poder ter a versao com o pcc?

    desde ja agradeco


    atualize a mesma para ultima versão do mikrotik, uma das formas é vc baixar os arquivos no site oficial e atualizar.

    boa sorte!!!



  19. #59

    Padrão

    mas a minha é crackeada, eu tentei atualizar um aki pra teste mas nao deu certo, caso alguem tenha uma solucao, porfavor, me avise....


    vlw

  20. #60

    Padrão

    Citação Postado originalmente por JeffersonParre Ver Post
    mas a minha é crackeada, eu tentei atualizar um aki pra teste mas nao deu certo, caso alguem tenha uma solucao, porfavor, me avise....


    vlw
    tem sim,
    mas terá q comprar a licença