+ Responder ao Tópico



  1. #1

    Exclamation Problemas com Pool

    Salve todos, galera seguinte, meu servidor mk trabalha da seguinte maneira, meus clientes se autentica via hotspot, tudo funcionando direitinho, só que de uns tempos pra cá, ele vem apresentando aquela mensagem no log que diz que não tem mais endereço livre no pool, ja tentei aumentar mas sem sucesso. Atualmente uso a seguinte faixa de ips nos clientes 10.0.0.2 - 10.0.0.250, se algum amigo me der uma ajuda fico grato

    abraço a todos!

  2. #2

    Padrão

    Amigo,

    Você precisa veriicar 2 pools. O primeiro é o do Hotspot, caso tenha setado algum. O Segundo pool é o do servidor DHCP. Esse pool que você tá usando atende 248 HOSTS. Ou seja, dependendo do timeout alguns hosts que não estejam sendo utilizados ficarão no pool até que atinja o timeout. Se for esse o problema você pode setar um pool maior ou um segundo pool assim:

    pool maior: 10.0.0.2 - 10.0.1.254. Isso vai te dar 507 hosts
    dois pools: 10.0.0.2 - 10.0.0.250 / 10.0.1.2 - 10.0.1.250. Isso vai te dar 496 hosts.

    Fica a seu critério. Não sei como tá sua rede mas com qualquer das alterações vai resolver, ok?

    Abs.



  3. #3

    Padrão

    Então cara, eu fiz assim, já havia tentado aumentar o pool como vc descreveu acima''pool maior'', logo os clientes que se conectava nos endereços 10.0.1.x autenticava, mas não navegarão... o que pode ser

  4. #4

    Padrão

    Citação Postado originalmente por RenatoLima Ver Post
    Então cara, eu fiz assim, já havia tentado aumentar o pool como vc descreveu acima''pool maior'', logo os clientes que se conectava nos endereços 10.0.1.x autenticava, mas não navegarão... o que pode ser

    Segue imagens em anexoClique na imagem para uma versão maior

Nome:	         img3.jpg
Visualizações:	174
Tamanho: 	18,4 KB
ID:      	10972Clique na imagem para uma versão maior

Nome:	         img1.jpg
Visualizações:	142
Tamanho: 	13,1 KB
ID:      	10974Clique na imagem para uma versão maior

Nome:	         img2.jpg
Visualizações:	133
Tamanho: 	23,9 KB
ID:      	10973



  5. #5

    Padrão

    Aumenta a mascara da rede. Deve tá /24. Coloca um /23.

    Abs.

  6. #6
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Configura uma nova faixa de ip na interface dos clientes
    Ex: você ja tem 192.168.1.1/24 na ether clientes, agora você adiciona mais uma 192.168.2.1/24
    Vai em ip pool a add a faixa de ips que você quer que o dhcp vai distribuir ex: add name="dhcp_pool3" ranges=192.168.2.2-192.168.2.200
    Ainda em ip pool abre o pool da faixa 192.168.1.x e coloca em next pool a que você acabou de criar que no caso foi dhcp_pool3.

    Testa ai e nos diga se funcionou.

    Abraços a todos



  7. #7

    Padrão

    Caros seguinte, tanto no exemplo citado pelo amigo guilherme quanto do amigo edcomrocha não obtive sucesso, aconteceu um seguinte, os clientes que estiverão conectado na 10.0.0.x ficaram on line, logo os novos clientes que conectavam e eram atribuidos com segundo range 10.0.1.x, logava mas não navegava, exibia pagina de erro para eles...
    vou mecher aqui com mais calma e posto os resultados novamente!

  8. #8

    Padrão

    Renato,

    Faz o seguinte: ip -> adress -> Coloca o ip do gateway assim: 10.0.0.1/23 na interface: Rede_Local
    Obs.: Não esquece de apagar o que tem nos campos da máscara e do broadcast antes de aplicar.
    Refaz o pool assim: 10.0.0.2-10.0.1.254 com o nome "pool1"
    Refaz o servidor dhcp assim:

    /ip dhcp-server
    add add-arp=yes address-pool=pool1 authoritative=yes disabled=no interface=Rede_Local lease-time=3h name=dhcp1

    /ip dhcp-server network
    add address=10.0.0.0/23 gateway=10.0.0.1 netmask=32

    Faz assim que resolve, ok?

    Abs.



  9. #9

    Padrão Re: Problemas com Pool

    para que serve essas duas na pratica se eu deixa marcado essa impossibilita de trocarem o ip? (add-arp=yes) (authoritative=yes) se alguém poder me explicar agradeço...

  10. #10

    Padrão Re: Problemas com Pool

    Citação Postado originalmente por Nando Ver Post
    para que serve essas duas na pratica se eu deixa marcado essa impossibilita de trocarem o ip? (add-arp=yes) (authoritative=yes) se alguém poder me explicar agradeço...
    add-arp=yes server pra ajudar no gerenciamento. Assim que o ip for designado pra alguém, ele será adicionado na arp list como entrada dinâmica.

    authoritative=yes evita que o cliente requisite um endereço não disponível. Essa opção é boa devido a "falhas" em algumas versões do windows que gostam de se apossar de alguns ips pra sempre.

    OK? Abs.



  11. #11

    Padrão Re: Problemas com Pool

    o maia apresentou no mum 2009 alguma coisa sobre esse esgotamento de dhcp, pois muito dificil alguem ter uma rb que tenha 254 clientes conectados, o que acontece eh que "algum" cliente seu esta pegando todos os ips, fazendo assim esgotar, se procurar vai achar a apresentacao dele que existe uma forma de bloqueio disso

  12. #12

    Padrão Re: Problemas com Pool

    onde acho essa apresentação?



  13. #13

    Padrão Re: Problemas com Pool

    Nando,

    Segue o link: http://mum.mikrotik.com/presentation...mada2_Maia.pdf

    Mas reza pra não ser ataque de DHCP. Não pelo fato de ser um "ataque de dhcp" mas sim porque você tem um malandro na sua rede. E quando você resolver esse problema ele vai te arranjar outro.

    De qualquer forma, boa sorte.

    Abs.

  14. #14

    Padrão Re: Problemas com Pool

    vlw cara desde ja te agradeço ai...



  15. #15

    Cool Re: Problemas com Pool

    Muito obrigado amigo guilhermeramires sua dica está funcionando perfeitamente e resolveu o meu problema com dhcp esgotado agora a rede ta 100% já tem um monte de clientes pegando a segunda faixa de IPs e navegando normalmente, e melhor agora com essa netmask=32 isolei meus clientes de se enxergarem na rede isso eu já estava atrás alguns dias.

    Última edição por freitascs; 12-01-2012 às 08:53.