+ Responder ao Tópico



  1. #61

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por Luiz Paulo Ver Post
    Ao amigo RFJonas... Mais uma vez parabens.... aqui ta funcioando perfeitamente dessa forma.....

    Consegui com essas alterações aqui óóóó...

    /ip dns static
    add address=IP DO MK disabled=no name=MEU DNS ttl=5s


    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=manutencao\r\
    \n/ip hotspot active remove [/ip hotspot active find]\r\
    \n/ip hotspot cookie remove [/ip hotspot cookie find]\r\
    \n/ip hotspot host remove [/ip hotspot host find]\r\
    \n\r\
    \n"
    add name=LINK-UP policy=ftp,read,write,winbox source="/ip firewall nat disable\
    \_[find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=hotspot\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"


    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico on-event=\
    REMOVER-DNS-DINAMICO policy=\
    reboot,read,write,policy,test, password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00


    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enabl\
    e [/system scheduler find name=remover_dns_dinamico]\r\
    \n/ system script run LINK-UP\r\
    \n"

    com esse ficou 100% AQUI NO MEU server... (com clientes que usam login e senha)

    mais ainda estou com uma duvida... para clientes que estao configurados para logar automaticamente (AUTENTICAÇÃO POR MAC) não funciona... acredito eu.... que seja pelo fato desse tipo de autenticão nao ser redirecionado para pagina de login..... se eu estiver errado por favor me digam...

    então fica a pergunta....

    Tem como redirecionar esses tipos de clientes tambem...para essa pagina de manutenção quando solicitarem a pagina e nao houver link ?

    Aguardo e desde ja agradeço.....

    Abração...

    Att.
    Luiz Paulo
    Luiz Paulo, faltou a regra do nat

    /ip firewall nat
    add action=redirect chain=dstnat comment="MANUTENCAO" disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

    essa regra é responsavel pelo redirecionamento para a pagina de manutençao,o script diz que ela seja habilitada quando o link cair, ou seja tudo que vem da porta 80 vai para a porta 64873 que a porta http do seu hotspot.

    outra coisa, não não precisa remover os clientes ativos
    /ip hotspot active remove [/ip hotspot active find]
    /ip hotspot cookie remove [/ip hotspot cookie find]
    /ip hotspot host remove [/ip hotspot host find]
    essa opçao eu fiz para quem realmente quer derrubar todos os clientes para que eles se loguem novamente.

    use a regra do nat que resolve tudo.
    quem está logado vai para pagina de status.html e quem não está vai para pagina de login.html.

    outra questão, para os cliente não precisar logar para navegar faça como nosso amigo amilton sugeriu

    "Aqui cadastrei os clientes que não passam pelo hotspot no IP Binding e a página de queda do link aparece normal. Faz esse teste ai e vê se funfa."

    verifica ai e post os resultados.

    Jonas Oliveira
    Última edição por RFjonas; 26-10-2010 às 11:13.

  2. #62

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Glauter, pelo que eu entendi você usa mais de 1 profile no server profiles, tem que editar seu script para o tal,
    e no servers voce tem que definir qual profile esta usando.

    se não for esse o problema, então eu não entendi sua duvida.
    qualquer coisa post novamente.



  3. #63
    Luiz Paulo
    Visitante

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por RFjonas Ver Post
    Luiz Paulo, faltou a regra do nat

    /ip firewall nat
    add action=redirect chain=dstnat comment="MANUTENCAO" disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

    essa regra é responsavel pelo redirecionamento para a pagina de manutençao,o script diz que ela seja habilitada quando o link cair, ou seja tudo que vem da porta 80 vai para a porta 64873 que a porta http do seu hotspot.

    outra coisa, não não precisa remover os clientes ativos
    /ip hotspot active remove [/ip hotspot active find]
    /ip hotspot cookie remove [/ip hotspot cookie find]
    /ip hotspot host remove [/ip hotspot host find]
    essa opçao eu fiz para quem realmente quer derrubar todos os clientes para que eles se loguem novamente.

    use a regra do nat que resolve tudo.
    quem está logado vai para pagina de status.html e quem não está vai para pagina de login.html.

    outra questão, para os cliente não precisar logar para navegar faça como nosso amigo amilton sugeriu

    "Aqui cadastrei os clientes que não passam pelo hotspot no IP Binding e a página de queda do link aparece normal. Faz esse teste ai e vê se funfa."

    verifica ai e post os resultados.

    Jonas Oliveira

    Fala ai brother....

    Vamos lá... realmente esqueci de posta essa regra... pois ja uso sim...se nao seria impossivel.... o erro foi somente na postagem...ok.... esta funcionando 100% com aqueles scripts, faltando somente o nat na postagem...

    em relação aquelas tres regrinhas...no meu server so funcionou com elas..... ou seja só quando derrubava os clientes...
    em relação ao ipbinding o unico problema é que eles ficam sem banda.... ai eu teria que criar mais um conjunto de regras manualmente no queue simple para controla-los...

    Att.
    Luiz Paulo

  4. #64

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    bom amigos eu fiz umas 20 ou mais ainda tentando
    e observei q meu netwath fica no status dow direto eu tow fazendo internamente fiz um ip bindgs no meu servidor e montei outro

    o servidor ta com o 2.9.27 nele testei o o netwath e funfou beleza ja no interno so fica em down direto

    estow acessando por o servidor interno com o mk 3.30

    voceis tem alguma ideia doq esta acontecendo pra ele fikar dow direto?

    obs: ja troquei varios dns´s



  5. #65

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    RFJonas Venho aqui te agradecer eu consegui tive que fazer algumas modificaçoes no script pra poder fikar redondinho mais funciou legal

    e pra os outros

    amigos leiam bem testem as regras uma a uma como eu fiz e fui auterando de acordo com minha necessidade

    eu uso web proxy tive q fazer fazer mais 2 scripts um pra desativar o web e ativar a do hostpot e vise versa

    e outra muda totalmente os logins pq a pasta é outra so é prestar atenção

    tambem quebrei cabeça

    imagine nosso amigo RFjonas ?

    que com toda humildade postow aqui pra nois

    sim façam testes com um servidor interno como eu fiz é o conselho q dow a todos

    motem um interno coloquem o bacukap e faz um bindgs do seu server pra ele ai vc trabalha sem encomodar os clientes
    qq coisa tamos aqui

    vou agora tentar em um 2.9.27

  6. #66

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por Jnf00 Ver Post
    RFJonas Venho aqui te agradecer eu consegui tive que fazer algumas modificaçoes no script pra poder fikar redondinho mais funciou legal

    e pra os outros

    amigos leiam bem testem as regras uma a uma como eu fiz e fui auterando de acordo com minha necessidade

    eu uso web proxy tive q fazer fazer mais 2 scripts um pra desativar o web e ativar a do hostpot e vise versa

    e outra muda totalmente os logins pq a pasta é outra so é prestar atenção

    tambem quebrei cabeça

    imagine nosso amigo RFjonas ?

    que com toda humildade postow aqui pra nois

    sim façam testes com um servidor interno como eu fiz é o conselho q dow a todos

    motem um interno coloquem o bacukap e faz um bindgs do seu server pra ele ai vc trabalha sem encomodar os clientes
    qq coisa tamos aqui

    vou agora tentar em um 2.9.27
    Jnf00, obrigado por contribuir com o esse tópico e com o fórum,

    a verdade é essa cada caso é um caso, minha rede pode ser diferente da sua,e a sua diferente das demais...
    mais se agente prestar atenção nas regras, no script, vai entender tudo. se for preciso alterar fica bem mais fácil se entender o script primeiro.
    e as duvidas nos tiramos aqui, um ajudando ao outro!

    um conselho a todos! não testem direto em seu servidor onde tem cliente conectado,
    testem em bancada! pois se for preciso alterar vai ter tempo para isso.

    um dos segredo para um bom sucesso na sua rede
    é nunca deixar ela parar.



  7. #67

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    observei uma coisa RFJonas Naum sei se vc fez esse teste

    ou pode ser erro meu ainda tipo ta redondinho redondinho

    mais fiz esse teste aqui

    tirei o link e reiniciei o servidor pela a logica ele ia pra pagina de manutençao

    observei que ele faz tudo como esta no script

    mais naum redireciona pra pagina de manutenção

    voce entendeu

    fica assim
    se eu tiver com o pc ligado na hora q cair o link sem tar logado claro

    ele redireciona normalmente, mais vamos dizer se eu ligar depois q o link caiu

    ele naum ta redirecionando

    so quero saber ser voce ou alguem fez esse teste...

  8. #68

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por Jnf00 Ver Post
    observei uma coisa RFJonas Naum sei se vc fez esse teste

    ou pode ser erro meu ainda tipo ta redondinho redondinho

    mais fiz esse teste aqui

    tirei o link e reiniciei o servidor pela a logica ele ia pra pagina de manutençao

    observei que ele faz tudo como esta no script

    mais naum redireciona pra pagina de manutenção

    voce entendeu

    fica assim
    se eu tiver com o pc ligado na hora q cair o link sem tar logado claro

    ele redireciona normalmente, mais vamos dizer se eu ligar depois q o link caiu

    ele naum ta redirecionando

    so quero saber ser voce ou alguem fez esse teste...
    Jnf00, não tinha percebido essa falha para essa situação!
    mais vamos lá terá que remover alguns script para corrigir!
    em system script "REMOVER-DNS-DINAMICO" tem que remover
    em system scheduler "remover_dns_dinamico" tem que remover
    em tool netwatch "MONITORAR LINK" tem que remover

    e colocar esse outro aqui abaixo

    /system script
    add name=REMOVER-DNS-DINAMICO-OFF policy=ftp,read,write,winbox source="/ ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n"
    add name=REMOVER-DNS-DINAMICO-ON policy=ftp,read,write,winbox source="/ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_off]"

    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico_on on-event="/ system script run REMOVER-DNS-DINAMICO-ON" policy=read,write start-time=\
    startup
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico_off on-event="/ system script run REMOVER-DNS-DINAMICO-OFF\r\
    \n" policy=read,write start-time=startup

    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n/ system scheduler enable [/system scheduler find name=remover_dns_dinamico_off]\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script=\
    "/system scheduler enable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/ system script run LINK-UP\r\
    \n/ queue simple remove hs-<hotspot1>"

    peço desculpas a todos pois eu não tinha percebido essa falha para essa situação como citou o nosso amigo Jnf00 a cima.
    já corrigi no inicio do tópico tambem.
    qualquer duvida estamos ai!
    Última edição por RFjonas; 30-10-2010 às 13:13.



  9. #69

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    RF Jonas estow fazendo um arquivo DOCcom tudo bem detalhado tipo as coisas mais importantes doque vim acompanhando nesse topico
    e com sua autorização postarei

    acho que naum vai ficar mais nem uma duvida para quem quizer fazer

    tow marcando onde o script serve pra todos e onde pode ser feita as alteraçoes

    estow simulando varias

    situaçoes

    com web-proxy
    sem weby-proxy

    com mais de uma rede

    tipo rede interna e rede externa com e sem web-proxy

    apos eu fazer todas as simulaçoes possiveis

    como disse a cima postarei
    ai o cara so naum vai fazer se não souber ler
    rsrsrs

  10. #70

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    acompanhando...



  11. #71

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Eu e o RFjonas vimos que tem pequenas diferenças nos script´s da versão 4.xx
    e 3.xx

    porem tem partes que ficam exatamente iguais idependente das suas configuraçoes

    se voce ler todo o topico vera que a regras que são pra todos os tipos de versão...

    exemplo:

    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=provedor.com.br] addre\
    ss=189.124.1xx.xxx comment=\"\" disabled=no name=.* ttl=5s"
    add name=LINK-UP policy=ftp,read,write,winbox source="/ip firewall nat disable\
    \_[find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=10.100.0.1 comm\
    ent=\"\" disabled=no name=provedor.com.br ttl=5s\r\
    \n"


    leia com atenção que voce fará

  12. #72

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Pessoal, aqui está um script para versão 3.
    Arquivos Anexos Arquivos Anexos



  13. #73

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    amigos outro dia achei um pro de imcompatibilidade desse script com o win 7 falei com nosso Grande amigo RFJONAS e sai procurando na net e achei a solução

    ta nesse link aqui leiam que voceis vão entender deixando bem claro que não é erro do script sim incompatibilidade com algumas configuraçoes do win7 acho eu q o vista tambem porém so testei no win7

    Windows 7 Vs Samba NTLMv2

  14. #74

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    no caso eu tenho um servidor apache aqui do mk-auth o ip dele e assim

    172.31.255.2:89

    89 e a porta da pagina de manutenção como procedo nas regras obrigado.



  15. #75

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Não consegui fazer rodar de jeito nenhum. não sei se é aqui:
    -10.100.0.1 = seu dns statico em ip/dns/static/address (uma dica ao criar seu dns statico em TLL: coloque assim 00:00:05

    No meu dns ta mostrando 5 minutos e não consigo colocar para 5 segundo como na regra. ou eu tenho que colocar outra regra com 5 segundos?

  16. #76

    Thumbs down Re: Página de manutenção no Mikrotik sem usar servidor

    Eu tentei de varias formas na versão 5 e nada, fiz dowgrade para 4 e nada, se alguém tiver as modificações para a versão 4 por favor coloque ai.


    Abraços



  17. #77

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    e no caso eu que tenho um server separado com a pagina de sem link lá o ip desse server 172.31.225.2 porta 89
    Citação Postado originalmente por RFjonas Ver Post
    Olá pessoal! Como eu havia prometido em outro tópico que se eu colocasse para rodar página de manutenção no MK sem usar servidor externo “Linux/apache etc...” eu postaria tudo aqui.

    Então vamos lá! Para começar quero lembrar que estou usando RB 433ah com versão 4.10 outras versões não testei “fica a critério de cada um”, posso garantir que está rodando 100% há 2 meses em 20 torres com mikrotik, uso hotspot com freeradius levei 2 semanas para deixar tudo 100% e adaptar as configurações para as minhas necessidades, aqui no fórum tem vários tópicos mostrando como configurar o hotspot, não vou mostrar como configura e sim o sistema de monitoramento que desenvolvi com alguns conteúdos tirados daqui mesmo do fórum.

    Vou explicar como funciona, coloquei o netwatch para monitorar o dns do Google, se parar de responder por motivo de queda do link, enlace que parou ou até mesmo “desconectando o cabo de rede” o mikrotik executa o 1° script “DOWN-LINK” que cria um dns dinâmico em ip/dns/static “ .* ” com o address 189.124.1xx.xx meu dns, em ip/hotspot/Server profiles, ele muda o diretório HTML :hotspot para “ manutecao “ onde vai está sua página avisando que o seu provedor está em manutenção , também habilita uma regra que vai está em ip/ firewall/ Nat ” MANUTENCAO “ fazendo um dstnat da porta 80 para a porta 64873 do hotspot que redireciona para a tal página. o 2° script “LINK-UP” quando o link retornar desfaz tudo que o 1° script fez. O 3° script habilita em system/scheduler “remover_dns_dinamico” que executa em system/script ”REMOVER-DNS-DINAMICO” se por acaso na hora que faltar link, e seu mikrotik rebootar o hotspot vai criar outro dns static por padrão e na hora que o link retornar vai travar, então o script remove o dns dinâmico para não acontecer isso. Basicamente é isso que esse sistema de monitoramento vai fazer bem simples e funcional “tudo automático”

    Lembrando no Nat a regra de dstnat “MANUTENCAO” fica desabilitada, e em system scheduler “remover_dns_dinamico” também fica desabilitada, elas se habilitam automaticamente quando o link cair.

    Atenção edite o script onde está em vermelho antes de copiar e colar!

    -provedor.com.br = seu dns name que usa no ip/hotspot/server profiles/hsprof1
    -189.124.1xx.xxx = seu dns em ip/dns/settings/servers (só o primário)
    -10.100.0.1 = seu dns statico em ip/dns/static/address (uma dica ao criar seu dns statico em TLL: coloque assim 00:00:05
    -8.8.8.8 = aqui dns do Google altere se quiser
    -----------------------------------------------------------------------------------------------------
    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=provedor.com.br] addre\
    ss=189.124.1xx.xxx comment=\"\" disabled=no name=.* ttl=5s"
    add name=LINK-UP policy=ftp,read,write,winbox source="/ip firewall nat disable\
    \_[find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=10.100.0.1 comm\
    ent=\"\" disabled=no name=provedor.com.br ttl=5s\r\
    \n"
    add name=REMOVER-DNS-DINAMICO-OFF policy=ftp,read,write,winbox source="/ ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n"
    add name=REMOVER-DNS-DINAMICO-ON policy=ftp,read,write,winbox source="/ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_off]"
    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico_on on-event="/ system script run REMOVER-DNS-DINAMICO-ON" policy=read,write start-time=\
    startup
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico_off on-event="/ system script run REMOVER-DNS-DINAMICO-OFF\r\
    \n" policy=read,write start-time=startup
    ------------------------------------------------------------------------------------------------------
    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n/ system scheduler enable [/system scheduler find name=remover_dns_dinamico_off]\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script=\
    "/system scheduler enable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/ system script run LINK-UP\r\
    \n/ queue simple remove hs-<hotspot1>"
    -----------------------------------------------------------------------------------------------------
    /ip firewall nat
    add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873
    -----------------------------------------------------------------------------------------------------
    Outra coisa! Eu não removo os clientes do actve do hotspot para assim que o link retornar eles não vão precisar se autenticar novamente, tem um redirecionamento na minha pagina de manutenção quando volta o link direciona para meu site, mais quem quiser remover os clientes para eles logarem quando voltar o link só acrescentar essa 1° linha abaixo em “DOWN-LINK”
    -----------------------------------------------------------------------------------------------------
    /ip hotspot active remove [/ip hotspot active find] (remover ativos)
    -----------------------------------------------------------------------------------------------------
    /ip hotspot cookie remove [/ip hotspot cookie find] (remover cookie)
    -----------------------------------------------------------------------------------------------------
    /ip hotspot host remove [/ip hotspot host find] (remover host)
    -------------------------------------------------------------------------------------------------------------------
    Aqui vou deixar uma página simples de manutenção em html altere, ou se quiser fique a vontade para alterar todo conteúdo, em anexo vai a pasta com o diretório manutenção descompacte e altere com um editor html ou até mesmo o bloco de notas salve as com o nome de origem o login.html e status.html , os dois são a mesma pagina ex: login.html é para quem está chegando ao hotspot quando esta sem link e o status.html é para quem já estava no hotspot quando faltou link, depois de alterar e salvar as paginas use alguma ferramenta cliente ftp pode ser esse: FileZilla - Client Download para importar a pasta “manutencao” ou clique e araste para seu mikrotik em files
    Essa pagina tem um refresh de 60 segundos para redirecionar para algum site se ela não encontra o site então ela retorna após 60 segundos novamente ela requisita o tal site... até haver resposta ou seja o link voltar. Outra dica! Quanto mais leve for a sua página melhor! Aqui eu testei até com um vídeo em flash com publicidades ficou show de bola! Só que em alguns clientes onde o navegador estava desatualizado dava alguns erros, mais vai ai essa outra dica!
    Bem pessoal é isso ai espero ter colaborado com o fórum e ajudado aqueles que tinham essa dificuldade. E aos amigos que quiserem colaborar também se estiver percebendo algo errado por favor fiquem a vontade para esclarecer a todos, um abraço e qualquer coisa estamos ai!!!

  18. #78

    Padrão Página de manutenção no Mikrotik sem usar servidor

    Olá, muito boa essa idéia.
    Porem estou fazendo algo errado, tive dois problema. Primeiro salvei a pasta manutenção com o manutenção.html dentro na raiz(fora do rotspot) em server profiles directory esta mudando para manutencao normalmente, mas nao entra a pagina manutencao. E o outro e quando reboot o servidor, ele carrega o DNS dinamido( .*) mesmo o link estando UP ou Down.
    fiz esta conf.
    /system script
    add name=DOWN-LINK policy=read,write, source=
    /ip firewall nat enable [find comment=MANUTENCAO]
    /ip hotspot profile set HotsPot-User html-directory=manutencao
    /ip dns static set [/ip dns static find name=meuDNSname.com] address=8.8.4.4 comment=" " disabled=no name=.* ttl=5s
    /ip hotspot active remove [/ip hotspot active find]

    add name=LINK-UP policy=reboot,read,write, source=
    /ip firewall nat disable [find comment=MANUTENCAO]
    /ip hotspot profile set HotsPot-User html-directory=hotspot
    /ip dns static set [/ip dns static find name=.*] address=192.168.140.1 comment="" disabled=no name=meuDNSname.com ttl=5s

    add name=REMOVER-DNS-DINAMICO policy=read,write, source=
    /ip dns static remove [/ip dns static find dynamic=yes]
    /system scheduler disable [/system scheduler find name=remover_dns_dinamico]


    /system scheduler
    add comment=" " disabled=yes interval=5s name=remover_dns_dinamico on-event=
    /system script run REMOVER-DNS-DINAMICO
    policy=read,write start-time=Startup

    /ip firewall nat
    add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 protocol=tcp to-ports=64873

    /ip dns static add address=192.168.140.1 comment="" disabled=no name=meuDNSname.com ttl=5s

    /tool netwatch
    add comment="MONITORAR LINK" disabled=no
    host=8.8.4.4 interval=5s timeout=1000ms

    down-script=
    /system script run DOWN-LINK
    up-script=
    /system scheduler enable [/system scheduler find name=remover_dns_dinamico]
    /system script run LINK-UP
    /queue simple remove hs-<HotsPot-User>
    Obrigado.



  19. #79

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Amigao, boa noite, eu tenho uma RB 750 ver4.11 porem nao funcionou, tem como me ajudar? por favor, ja fiz de tudo, mas nao tem jeito. meu email é [email protected] msn : [email protected]

    espero poder mim ajudar. desde ja obrigado.

  20. #80

    Padrão Re: Página de manutenção no Mikrotik sem usar servidor

    Citação Postado originalmente por RFjonas Ver Post
    Pessoal estou desenvolvendo outro metodo para quem trabalha com RB em BRIDGE!
    vai ser "página de manutenção no mikrotik em bridge sem usar servidor externo e tal... e tal..."
    aguardem, já esta funfando, estou preparando o tuto...!
    Eai amigo, desenvolveu ai o método pra quem trabalha com RB em Bridge ? Pois acho que será muito util pra muita gente.. vlw..