Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão Re: Ajuda com P2P / MikroTik

    Citação Postado originalmente por trober Ver Post
    Olá Jailton.

    Que fique claro que de forma alguma estou dizendo que as regras que os demais colegas postaram estejam erradas. Essa incapacidade de controlar banda, baseado em filtros P2P, é limitação da maioria dos firewalls L7 (no qual o está incluso o filtro P2P do RouterOS). Aliada à incapacidade do filtro L7, tem a "malandragem" do RC4

    Quanto à obfuscuração, há vários clientes Torrent com essas características. O que recomendo, é fazer os seguintes testes:

    1) Instalar 10 clientes de Torrent no computador.
    2) Testar o tráfego dos 10 clientes, um de cada vez, com a criptografia (obfuscuração) desligada.
    3) Documentar os resultados.
    4) Testar o tráfego dos 10 clientes, um de cada vez, com a criptografia (obfuscuração) ligada.
    5) Documentar os resultados.
    6) Comparar resultados.

    O administrador que controla a banda, não pode presupor quais clientes de Torrent seus usuários irão (ou não) usar. Logo, filtrar por P2P, na esperança que a obfuscuração esteja desligada, é uma otimismo muito grande.

    Saudações,

    Trober
    -
    -
    -
    -
    -
    Trober e isso que quero dizer ...e como Ultra surf bloqueia uma porta eo danado vai pelo outro...tem que se testar com outro programa para discobrirmos se algo novo no utorrent que nao esta passando pela regra entende ...

  2. #22

    Padrão Re: Ajuda com P2P / MikroTik

    agora e que estou meio sem tempo estou subindo minha torre nova aqui em casa mas a noite vou fazer um teste no utorrent para ver a algo novo e tentaramos juntos uma soluçao ok isso se a soluçao rsrs...um abraço



  3. #23

    Padrão Re: Ajuda com P2P / MikroTik

    Citação Postado originalmente por jailtonnetlink Ver Post
    agora e que estou meio sem tempo estou subindo minha torre nova aqui em casa mas a noite vou fazer um teste no utorrent para ver a algo novo e tentaramos juntos uma soluçao ok isso se a soluçao rsrs...um abraço
    Tranquilo!

    Podemos combinar para compor, em conjunto, um artigo sobre o tema. Ao término, mediante exaustão dos argumentos e conclusão dos testes, publicar aqui no Under-Linux. Será uma excelente referência aos demais colegas

    Saudações,

    Trober
    -
    -
    -
    -
    -

  4. #24

    Padrão Re: Ajuda com P2P / Mikrotik

    Opa, trober! 100% o python e paramiko ta funcionando belezinha! eterna gratidão a você por isso!


    então, voltando ao p2p agora, realmente por enquanto so testei com o utorrent, vou tentar com outros programas e postar os resultados!



  5. #25

    Padrão Re: Ajuda com P2P / Mikrotik

    testei com utorrent e realmente nao limitou...vou ver o que descubro para solucionar se e que tem soluçao rsrs

  6. #26

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por jailtonnetlink Ver Post
    testei com utorrent e realmente nao limitou...vou ver o que descubro para solucionar se e que tem soluçao rsrs
    Opa! O Jailton tem Cacau[1] em casa! Nos chama para o café da tarde

    O cardápio é RC4 com biscoitos, hehehe.

    Sucesso nas tentativas.

    [1] http://nbcgib.uesc.br/cacau/
    [2] http://engenhariacivildauesc.blogspo...atividade.html
    [3] http://www.uesc.br/noticias/?acao=ex...d_noticia=2086

    Saudações,

    Trober
    -
    -
    -
    -
    -



  7. #27

    Padrão Re: Ajuda com P2P / Mikrotik

    kkkkkkkk esse trober e unico aqui

    percibi que nao e 100% ,alguns ele pega mas meio que ocilando o controle mas outros download passa direto(velocidade total contratado pelo cliente) mas fazero que andei pesquisando melhor a profundo e realmente nao uma soluçao completa para isso nao ...mas o cliente paga ne fazer o que e um direito do danado hehehe

    vlw trober passando aqui pelo tocantins passa aqui em casa para tomar um cafezinho(nao curti muito RC4 nao )kkkkk um abraço

  8. #28

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por jailtonnetlink Ver Post
    kkkkkkkk esse trober e unico aqui
    hehehehe

    Citação Postado originalmente por jailtonnetlink Ver Post
    percibi que nao e 100% ,alguns ele pega mas meio que ocilando o controle mas outros download passa direto(velocidade total contratado pelo cliente) mas fazero que andei pesquisando melhor a profundo e realmente nao uma soluçao completa para isso nao ...mas o cliente paga ne fazer o que e um direito do danado hehehe
    Sim, até pelo fato de que as regras de neutralidades[1] estão aí, batendo na portas dos ISPs.

    Citação Postado originalmente por jailtonnetlink Ver Post
    vlw trober passando aqui pelo tocantins passa aqui em casa para tomar um cafezinho(nao curti muito RC4 nao )kkkkk um abraço
    Pode deixar! Passo sim!

    [1] http://en.wikipedia.org/wiki/Network_neutrality

    Abraço!

    Trober
    -
    -
    -
    -



  9. #29

    Padrão Re: Ajuda com P2P / Mikrotik

    Jesus, preciso estudar mais! ahahahah to boiando aqui!

  10. #30

    Padrão Re: Ajuda com P2P / Mikrotik

    Sera que resolve trober ? achei isso em um forum, nao consegui desvendar essa regra .


    /ip/firewall/mangle
    add action=mark-connection chain=prerouting comment="===== P2P" disabled=no dst-port=!53 new-connection-mark=\
    UDP-P2P passthrough=yes protocol=udp src-port=!53
    add action=mark-packet chain=prerouting comment="" connection-mark=UDP-P2P disabled=no new-packet-mark=UDP-P2P \
    passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=512k max-limit=512k name=UDP-P2P \
    packet-mark="UDP-P2P" parent=global-out priority=8 queue=default



  11. #31

    Padrão Re: Ajuda com P2P / MikroTik

    Citação Postado originalmente por jailtonnetlink Ver Post
    Sera que resolve trober? achei isso em um forum, nao consegui desvendar essa regra.

    Código :
    /ip/firewall/mangle
    add action=mark-connection chain=prerouting comment="===== P2P" disabled=no dst-port=!53 new-connection-mark=\
        UDP-P2P passthrough=yes protocol=udp src-port=!53
    add action=mark-packet chain=prerouting comment="" connection-mark=UDP-P2P disabled=no new-packet-mark=UDP-P2P \
        passthrough=no
     
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=512k max-limit=512k name=UDP-P2P \
        packet-mark="UDP-P2P" parent=global-out priority=8 queue=default
    O que esse código faz é generalizar tráfego UDP, aplicando uma única exceção. O código pega tudo que não é DNS (veja o dst-port=!53) e trata como P2P! Uma ação generalista, que afeta, por exemplo, o protocolo NTP (Network Time Protocol), que atual na porta 123 UDP.

    Resumindo, esse código não serve como classificação P2P.

    Saudações,

    Trober
    -
    -
    -
    -
    -

  12. #32

    Padrão Re: Ajuda com P2P / MikroTik

    Citação Postado originalmente por trober Ver Post
    O que esse código faz é generalizar tráfego UDP, aplicando uma única exceção. O código pega tudo que não é DNS (veja o dst-port=!53) e trata como P2P! Uma ação generalista, que afeta, por exemplo, o protocolo NTP (Network Time Protocol), que atual na porta 123 UDP.

    Resumindo, esse código não serve como classificação P2P.

    Saudações,

    Trober
    -
    -
    -
    -
    -
    Cara, quando crescer vou ser tão foda quanto você!



  13. #33

    Padrão Re: Ajuda com P2P / Mikrotik

    entao ela prejudica tbm outros serviços ,no caso ai ele evita consumo excessivo mas prejudica tbm outros serviços certo?

  14. #34

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por zoom18 Ver Post
    Cara, quando crescer vou ser tão foda quanto você!
    O que é isso... tenho muito a aprender ainda. Recomendo inspirar-se em gente melhor

    Citação Postado originalmente por jailtonnetlink Ver Post
    entao ela prejudica tbm outros serviços ,no caso ai ele evita consumo excessivo mas prejudica tbm outros serviços certo?
    Isso. Para ter uma ideia dos serviços que serão atingidos, é só executar o comando abaixo, em algum sistema operacional BSD-Like ou distribuição GNU/Linux.
    Código :
    grep udp /etc/services
    Caso esteja usando sistema operacional Microsoft Windows, o comando é:
    Código :
    findstr /I udp %windir%\system32\drivers\etc\services
    Saudações,

    Trober
    -
    -
    -
    -
    -



  15. #35

    Padrão Re: Ajuda com P2P / Mikrotik

    ei trober nesta parte tbm sou leigo ..se nao for pedir demais para explicar a importancia do udp tbm nos clientes e em servidores ...fico grato

  16. #36

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por jailtonnetlink Ver Post
    ...se nao for pedir demais para explicar a importancia do udp tbm nos clientes e em servidores ...fico grato
    Jailton, é uma resposta muito ampla, mas vou sintetizar de forma bem simples. Vou considerar a restrição geral de UDP (exceto 53) em provedores, que vendem planos aos respectivos clientes. O que podemos encontrar em clientes:

    Cenário 1:
    O cliente jogando Combat Arms[1], da Nexon[2]. O jogo usa algumas portas TCP, e várias outras UDP[3].

    Cenário 2:
    O cliente estabeleceu um túnel L2TP[4]. Usa as portas 1701, podendo também usar 500 e 4500 (vide IKE, IPSec,...).

    Cenário 3:
    O cliente conversando com seus contatos, usando VoIP[5]. Com exceção da 5060 (ou 5061) TCP, todas as demais portas são UDP.

    Agora imagina tratar tudo isso como P2P, como a regra propôs (aquela do "exceto 53"). É ser muito generalista.

    Tem o caso do NTP, já citado antes. Mesmo que o protocolo NTP tenha uma estimativa de correção de frequência de erro (drift file), isso não significa poder "penalizar" esse serviço, com base no "P2P generalista".

    Espero ter ajudado.

    [1] http://combatarms.nexon.net
    [2] http://www.nexon.net
    [3] http://combatarms.nexon.net/News/Vie...ontentNo=005p5
    [4] http://en.wikipedia.org/wiki/Layer_2_Tunneling_Protocol
    [5] http://en.wikipedia.org/wiki/Session...ation_Protocol

    Saudações,

    Trober
    -
    -
    -
    -
    -



  17. #37

    Padrão Re: Ajuda com P2P / Mikrotik

    Caro Trober,

    Coloquei sua regra para controle p2p e aqui funcionou, só ainda não sei o efeito colateral, gostaria de saber se por acaso tenha alguma dica para ter um controle melhor sem afetar serviço essências.

    Na marcação de pacote coloquei estas portas UDP que mencionou para não marca.

    att...

  18. #38

    Padrão Re: Ajuda com P2P / MikroTik

    Citação Postado originalmente por nikollas Ver Post
    Caro Trober,

    Coloquei sua regra para controle p2p e aqui funcionou...
    Opa! Acredito que há um equívoco. Não postei nenhuma regra de controle de P2P. Inclusive fiz o contrário, expondo argumentos para desencorajar a prática de controle de P2P, por não ser eficiente.

    Citação Postado originalmente por trober Ver Post
    Cara, sugiro abandonar esses interpretadores de camada 7, que vem embutidos no RouterOS. Isso só serve para comer processamento, e não é totalmente funcional com P2P.
    Citação Postado originalmente por trober Ver Post
    Essa incapacidade de controlar banda, baseado em filtros P2P, é limitação da maioria dos firewalls L7 (no qual o está incluso o filtro P2P do RouterOS). Aliada à incapacidade do filtro L7, tem a "malandragem" do RC4
    Saudações,

    Trober



  19. #39

    Padrão Re: Ajuda com P2P / Mikrotik

    mesmo assim flw pelo resposta, grato...

  20. #40

    Smile Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por nikollas Ver Post
    mesmo assim flw pelo resposta, grato...
    Uso esta regra,tambem estava sofrendo deste mal de p2p,agora ja estou um pouco aliviado.


    Copiar e colar no terminal:

    /ip firewall layer7-protocol
    add name=bittorrent regexp="^(\13bittorrent protocol|azver\01\$|get/scrape\\\?info_hash=)|d1:ad2:id20:|\08'7P\\)[RP]"
    add name=ares regexp="^\03[]Z].\?.\?\05\$"

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN Ares disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT Ares disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN Bittorrent disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT Bittorrent disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=p2p_out packet-mark=p2p_out parent=global-out priority=\
    8 queue=default

    Agora tem que ser na unha,pois sou leigo e não sei fazer a regra pelo terminal:

    vai em ip/firewall/mangle 2 cliques na regra P2P_IN Ares,na aba advanced localize a opção Layer7 protocol selecione "ares" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_OUT Ares,na aba advanced localize a opção Layer7 protocol selecione "ares" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_IN Bittorrent,na aba advanced localize a opção Layer7 protocol selecione "bittorrent" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_OUT Bittorrent,na aba advanced localize a opção Layer7 protocol selecione "bittorrent" e clique em apply.

    *Não alterar a regra mark packet,somente mark connection.

    Pronto!