Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa Trade.
    Estamos tendo problema pra implementar uma rede PPPOE junto com outra rede que já esta funcionado: HOTSPOT+OSPF tudo via radius.
    Porem, quando o cliente pppoe autentica, e o OSPF divulga a rota, alguns minutos depois, o OSPF para de divulgar todas as rotas.
    Verificando no OSPF, vi que as interfaces do PPPOE estão sendo levantadas no OSPF como Point-to-Point.

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	112
Tamanho: 	27,4 KB
ID:      	47264

    Clientes Hotspot 100% funcionando

    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	130
Tamanho: 	132,6 KB
ID:      	47266

    Rascunho da rede:
    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	148
Tamanho: 	68,3 KB
ID:      	47265

    • Minhas configurações

    PowerEdige
    Loopback: 10.0.0.1/32
    ether1: Link Internet
    ether6: Hotspot (todos os cliente com ip dinâmico /30)
    ether2: OSPF___para____Rb1100_A (via_NBMA)
    ether5: OSPF___para____Rb1100_B (via_NBMA)
    ether7: OSPF___para____Rb1100_C (via_NBMA)
    /routing ospf instance
    set [ find default=yes ] name=LIMO_1 redistribute-connected=as-type-1 router-id=10.0.0.1
    /routing ospf area range
    add area=backbone range=186.y.y.0/20
    add area=backbone range=177.y.y.0/20
    /routing ospf interface
    add interface=LOOPBACK network-type=broadcast
    add interface=ether2 network-type=nbma
    add interface=ether5 network-type=nbma
    add interface=ether7 network-type=nbma
    /routing ospf nbma-neighbor
    add address=10.x.x.22 comment="Rb_1100_A"
    add address=10.x.x.10 comment="Rb_1100_B"
    add address=10.x.x.30 comment="Rb_1100_C"
    /routing ospf network
    add area=backbone comment=Loopback disabled=yes network=10.0.0.1/32
    add area=backbone comment="Rb_1100_A" network=186.y.y.144/28
    add area=backbone comment="Rb_1100_B" network=186.y.y.96/28
    add area=backbone comment="Rb_1100_C" network=186.y.y.112/28


    Rb1100_A
    Loopback: 10.0.2.5
    ether1: 10.x.x.22/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_B
    Loopback: 10.0.2.6
    ether1: 10.x.x.30/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_C
    Loopback: 10.0.2.7
    ether1: 10.x.x.10/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether3_vlan1: (OSPF para Rb433AH)
    ether4: (pretendemos usar pppoe)
    Rb433AH
    Loopback: 10.0.3.7
    ether1_vlan1: ----------- ( fechando OSPF) -------- Rb1100_C
    ether2: Hotspot (todos os cliente com ip dinâmico /30)
    ether3: (pretendemos usar pppoe)

  2. verifiquei que sua rede ospf e tipo nbma ou seja uma rede não broadcast ,numa rede deste tipo os roteadores não anunciam suas rotas visto que ele ja se conhecem então se uma interface cai ai fu#@$% para uma parte da rede o grande barato do ospf e poder criar redes que se uma interface cair ela muda para uma outra rota backup assim da tempo de descobrir o que aconteceu sem parar a rede .notei tambem que sua interface pppoe esta em estado down ja e um começo para começar a investigar ok.



  3. Citação Postado originalmente por fsoaress76 Ver Post
    Boa Trade.
    Estamos tendo problema pra implementar uma rede PPPOE junto com outra rede que já esta funcionado: HOTSPOT+OSPF tudo via radius.
    Porem, quando o cliente pppoe autentica, e o OSPF divulga a rota, alguns minutos depois, o OSPF para de divulgar todas as rotas.
    Verificando no OSPF, vi que as interfaces do PPPOE estão sendo levantadas no OSPF como Point-to-Point.

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	112
Tamanho: 	27,4 KB
ID:      	47264

    Clientes Hotspot 100% funcionando

    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	130
Tamanho: 	132,6 KB
ID:      	47266

    Rascunho da rede:
    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	148
Tamanho: 	68,3 KB
ID:      	47265

    • Minhas configurações

    PowerEdige
    Loopback: 10.0.0.1/32
    ether1: Link Internet
    ether6: Hotspot (todos os cliente com ip dinâmico /30)
    ether2: OSPF___para____Rb1100_A (via_NBMA)
    ether5: OSPF___para____Rb1100_B (via_NBMA)
    ether7: OSPF___para____Rb1100_C (via_NBMA)
    /routing ospf instance
    set [ find default=yes ] name=LIMO_1 redistribute-connected=as-type-1 router-id=10.0.0.1
    /routing ospf area range
    add area=backbone range=186.y.y.0/20
    add area=backbone range=177.y.y.0/20
    /routing ospf interface
    add interface=LOOPBACK network-type=broadcast
    add interface=ether2 network-type=nbma
    add interface=ether5 network-type=nbma
    add interface=ether7 network-type=nbma
    /routing ospf nbma-neighbor
    add address=10.x.x.22 comment="Rb_1100_A"
    add address=10.x.x.10 comment="Rb_1100_B"
    add address=10.x.x.30 comment="Rb_1100_C"
    /routing ospf network
    add area=backbone comment=Loopback disabled=yes network=10.0.0.1/32
    add area=backbone comment="Rb_1100_A" network=186.y.y.144/28
    add area=backbone comment="Rb_1100_B" network=186.y.y.96/28
    add area=backbone comment="Rb_1100_C" network=186.y.y.112/28


    Rb1100_A
    Loopback: 10.0.2.5
    ether1: 10.x.x.22/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_B
    Loopback: 10.0.2.6
    ether1: 10.x.x.30/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_C
    Loopback: 10.0.2.7
    ether1: 10.x.x.10/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether3_vlan1: (OSPF para Rb433AH)
    ether4: (pretendemos usar pppoe)
    Rb433AH
    Loopback: 10.0.3.7
    ether1_vlan1: ----------- ( fechando OSPF) -------- Rb1100_C
    ether2: Hotspot (todos os cliente com ip dinâmico /30)
    ether3: (pretendemos usar pppoe)
    Boa tarde amigo,

    1º - Primeiro, levante os anúncios de loopback em ranges do OSPF (em todos os routers);
    2º - Não distribua rotas conectadas;
    3º - Sumarize as rotas dos clientes PPPoE e crie filtros para que os mesmos não sejam anunciados nas outras áreas de sua rede, deixando assim sua tabela de roteamento menos inflada e por consequência, mais ágil as consultas;
    4º - Não trabalhe com nbma, é desnecessário, lembre-se de fechar seus enlaces sempre em ap-wds + stations wds.

    Faça estas alterações e nos retorne o resultado obtido;

    O caso das interfaces PPPoE aparecerem no OSPF, é normal, o que vc tem que fazer e filtrá-los para que não saiam de seu roteador para os vizinhos, fazendo da forma que citei no 3º item.

    Espero ter ajudado.
    Abraço

  4. Estou testando em laboratórios, e postarei os resultados...



  5. Relatório de bancadas.


    • 3 notebook conectados em cada ponta com pppoe.
    • Não teve como testar junto, maquinas com hotspot e IP-staticos
    • Não aplicado filtro.
    • Area-A: CloudCore-1036
    • Areb-B: 2 Rbs 600


    Lembramos que em produção vai rodar junto com Hotspot+IP-staticos e tudo com IP-Publico.


    CloudCore-1036

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	104
Tamanho: 	141,0 KB
ID:      	47290

    RB600_1

    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	92
Tamanho: 	37,2 KB
ID:      	47291

    RB600_2

    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	85
Tamanho: 	54,5 KB
ID:      	47292


    Aguardo comentários.






Tópicos Similares

  1. O que usar numa rede Wifi com antena externa
    Por raszytko no fórum Redes
    Respostas: 1
    Último Post: 07-11-2013, 07:13
  2. ajuda compra placa de rede compativel com speedr
    Por armr1000 no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-01-2013, 01:22
  3. Rotear PPPOE por rede bridge - Ajuda com a regra
    Por virtuainf no fórum Redes
    Respostas: 0
    Último Post: 22-06-2011, 07:09
  4. Ajuda configuração de no-ip numa rede com firewall
    Por tiagocal no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 14-08-2009, 10:24
  5. Kurumin com Apache numa Rede Windows (??!!!)
    Por Alexandre Mauricio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-06-2004, 09:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L