+ Responder ao Tópico



  1. Olá PessoALL :

    Estou tentando subir o DHCPD num fedora 18 e não consigo nem a pau.

    Ao dar o comando "service dhcpd start" ele não retorna nem um erro. Mas eu dou um "ps -ax" e não vejo o DHCPD na lista de processos.

    Se eu coloco alguma maquina windows pra receber IP automaticamente, elas recebem o IP do APIPA (169.............).

    Estou sem saber o que fazer, visto que não sei nem se existe log pra olhar.

    Eu revisei o arquivo dhcpd.conf e não me ocorreu nenhum erro.

    Segue uma cópia:

    ddns-update-style none;
    ignore client-updates;

    subnet 10.1.1.0 netmask 255.0.0.0 {

    # --- default gateway
    option routers 10.1.1.1;
    option subnet-mask 255.0.0.0;

    option nis-domain "domain.org";
    #option domain-name "jk.local";
    option domain-name-servers 201.48.229.4;

    option time-offset -18000; # Eastern Standard Time
    # option ntp-servers ntp.cais.rnp.br;
    # option netbios-name-servers none;
    # --- Selects point-to-point node (default is hybrid). Don't change this unless
    # -- you understand Netbios very well
    # option netbios-node-type 2;

    range dynamic-bootp 10.1.1.254 10.1.1.10;
    default-lease-time 600;
    max-lease-time 7200;

    # we want the nameserver to appear at a fixed address
    host ns {
    #next-server jk.local;
    #hardware ethernet 12:34:56:78:AB:CD;
    fixed-address 201.48.229.4;
    }
    }

    alguem pode me ajudar ?

  2. Citação Postado originalmente por leonardobruno Ver Post
    Olá PessoALL :

    Estou tentando subir o DHCPD num fedora 18 e não consigo nem a pau.

    Ao dar o comando "service dhcpd start" ele não retorna nem um erro. Mas eu dou um "ps -ax" e não vejo o DHCPD na lista de processos.

    Se eu coloco alguma maquina windows pra receber IP automaticamente, elas recebem o IP do APIPA (169.............).

    Estou sem saber o que fazer, visto que não sei nem se existe log pra olhar.

    Eu revisei o arquivo dhcpd.conf e não me ocorreu nenhum erro.

    Segue uma cópia:

    Código :
    ddns-update-style none;
    ignore client-updates;
     
    subnet 10.1.1.0 netmask 255.0.0.0 {
     
    # --- default gateway
        option routers            10.1.1.1;
        option subnet-mask        255.0.0.0;
     
        option nis-domain        "domain.org";
        #option  domain-name        "jk.local";
        option domain-name-servers    201.48.229.4;
     
        option time-offset        -18000;    # Eastern Standard Time
    #    option ntp-servers        ntp.cais.rnp.br;
    #    option netbios-name-servers    none;
    # --- Selects point-to-point node (default is hybrid). Don't change this unless
    # -- you understand Netbios very well
    #    option netbios-node-type 2;
     
        range dynamic-bootp 10.1.1.254 10.1.1.10;
        default-lease-time 600;
        max-lease-time 7200;
     
        # we want the nameserver to appear at a fixed address
        host ns {
            #next-server  jk.local;
            #hardware  ethernet 12:34:56:78:AB:CD;
            fixed-address 201.48.229.4;
        }
    }

    alguem pode me ajudar ?
    Inicialmente, recomendo usar TAG CODE para formatar as porções de código na mensagem, proporcionando assim melhor leitura, e consequentemente aumentando a chance de obtenção de ajuda

    Quanto ao arquivo de configuração do seu serviço de DHCP, há vários pequenos erros, tornando mais fácil e produtivo indicar outros tópicos[1][2], com soluções já prontas, e ricas em detalhes, do que depurar a configuração que você apresentou.

    Apenas para citar alguns dos pequenos erros:

    1) range dynamic-bootp está com a ordem invertida de endereço inicial e fim, além de não ser aplicável à atribuição de endereço que você deseja, em que é previsto o uso de range apenas.

    2) Você está atribuindo ao host ns um endereço fora do escopo de range (que não existe, e se existisse estaria virada a ordem), e o endereço físico está comentado.

    3) É muito provável que você não tem um servidor NIS (nis-domain), portanto a opção é desncessária.

    4) option time-offset está com cinco horas de desvio, sendo que o Brasil possui três fusohorários apenas (-2, -3 e -4).

    Leia os tópicos[1][2] indicados, faça pequenos ajustes na sua configuração, como alteração de faixa de endereços e nome do domínio, e nos reporte se funcionou.

    [1] https://under-linux.org/showthread.php?t=149495
    [2] https://under-linux.org/showthread.php?t=161433






Tópicos Similares

  1. Msn não entra nem a pau!
    Por Linux no fórum Redes
    Respostas: 6
    Último Post: 30-09-2009, 22:53
  2. Respostas: 1
    Último Post: 03-07-2008, 09:04
  3. Respostas: 8
    Último Post: 01-04-2008, 21:03
  4. Não Roda nem a pau
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-07-2005, 15:35
  5. Wireless não vai nem a pau ...
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 12-11-2002, 17:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L