Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. boa noite pessoal queria um script pra enviar backup e log pra email uso uma 450g v5.24 e nao conseguir fazer isso de jeito nenhum uso o seguinte script


    log info message="enviando backup por email":global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="italope2010@hotmail.com" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup start-tls=yes
    :log info message="enviando log por email":global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="italope2010@hotmail.com" subject="log-mikrotik $data $hora" file=log-mikrotik.txt start-tls=yes

    mim ajudem por favor desde ja agradeço

  2. Amigo olha esse post ai.

    https://under-linux.org/showthread.php?t=137010

    Aqui eu uso esses scripts e está funcionando 100%

    Caso tenha alguma dificuldade em fazer, é só falar que lhe ajudo. Mais se seguir vai funcionar tranquilamente.

    Abraço e boa sorte!



  3. foi esse mesmo que usei o nao deu nao

  4. Citação Postado originalmente por italope Ver Post
    foi esse mesmo que usei o nao deu nao
    Seguiu todos os passos a risca?

    Você foi em tools>email e configurou o servidor de e-mail ceto?
    Bom se quiser posso lhe ajudar. Mais passa mais informações de porque não conseguir, algum erro coisa do tipo.

    E o script que você colocou no inicio do post não é o mesmo que eu lhe enviei não.

    Abraço!



  5. Citação Postado originalmente por Arthur Bernardes Ver Post
    Seguindo à risca o link do Arthur, consegui criar com sucesso, não tem erro!

    Vamos descrever os passos aqui, um de cada vez, rsrsrs!

    Primeiro vamos configurar o e-mail em "Tool ==> E-mail", e lá adicione o servidor de e-mail, a porta e o seu e-mail.

    Eu aqui uso Gmail, então no server coloque o seguinte: 74.125.196.108

    Em "port" coloque 587

    Em "from" coloque seu e-mail: arthur.bernardes1@gmail.com (no caso esse é o meu).

    Em "user" coloque novamente seu e-mail e agora clique no botão "Apply" e depois em "OK".

    Agora vamos criar os scripts, no menu "System ==> Scripts".

    Adicione um script chamado "salvar-log" e no "source" cole o seguinte:

    Código :
    /log print file=log-mikrotik.txt

    Adicione outro script chamado "salvar-backup" e no "source" cole o seguinte:

    Código :
    /system backup save name=backup-mikrotik.backup

    Agora vamos criar mais dois scripts para o envio do "salvar-backup" e do "salvar-log".

    Crie um novo script chamado "enviar-log" e no "source" cole o seguinte:

    Código :
    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="email_de_destino01@dominio.com" subject="log-mikrotik $data $hora" file=log-mikrotik.txt tls=yes

    Crie outro script chamado "enviar-backup" e no "source" cole o seguinte:

    Código :
    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="email_de_destino01@dominio.com" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup tls=yes

    Repare que na linha /tool e-mail send to="email_de_destino01@dominio.com" você deve trocar o "email_de_destino01@dominio.com" pelo seu e-mail.

    Agora vamos criar dois scripts de envio/salvar automático de log/backup, abra um "new terminal" e cole o seguinte:

    Código :
     
    Código :
    /system scheduler add comment="" disabled=no interval=1d name=enviar-backup-automatico \
    on-event=enviar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/24/2014 start-time=12:00:00
    /system scheduler add comment="" disabled=no interval=1d name=salvar-backup-automatico \
    on-event=salvar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/24/2014 start-time=12:00:00
    /system scheduler add comment="" disabled=no interval=6h name=salvar-log-automatico on-event=\
    salvar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/24/2014 start-time=12:00:00
    /system scheduler add comment="" disabled=no interval=6h name=enviar-log-automatico on-event=\
    enviar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/24/2014 start-time=12:00:00


    Lembre-se de mantar a hora de seu servidor mikrotik sincronizado com o NTP!

    Bom já que o amigo ai detalhou todo o Script que mandei no link e deixou bem explicado e quero deixar o meu obrigado a ele.

    Aqui vai como deixar a hora do seu MK sempre sincronizada com o NTP

    Primeiro vai em System>NTP Client

    Marca a opção Enable
    Mode: Unicast
    Primary NTP SERVER: 64.90.182.55
    Secundary NTP Server: 200.160.7.192

    Clica em Apply depois em OK

    Agora vamos criar um script p atualizar a hora ok.

    Primeiro vai em System>Scritps

    E cria um Scritp com o nome.

    Name: Ajustar_Hora
    Policy: write/policy/read/test <marque essas opções
    Lá em Source coloco o script abaixo:

    Código :
    /system ntp client set enabled=yes mode=unicast primary-ntp=64.90.182.55 secondary-ntp=200.160.7.192

    Depois só aplicar e confirmar.

    Agora vai em System>Schedule
    E faz da seguinte forma

    Name:AtualizaHora
    Start Time: startup
    Interval: 00:10:00
    On Event:
    Código :
    / system script run Ajustar_Hora

    Em Policy, marque todos.

    Depois só aplicar e confirmar

    Você verá sua data e hora atualizados.

    Abraço.






Tópicos Similares

  1. Script para Link de Backup
    Por marcelorodrigues no fórum Redes
    Respostas: 6
    Último Post: 16-03-2015, 21:06
  2. Respostas: 2
    Último Post: 24-02-2014, 17:36
  3. Respostas: 1
    Último Post: 05-06-2012, 16:16
  4. script para varrer certas strings e enviar por email
    Por Saddones no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 22-04-2010, 08:59
  5. Como criar um shell script para monitoramento de log(url)
    Por nozey no fórum Linguagens de Programação
    Respostas: 7
    Último Post: 30-10-2005, 20:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L