+ Responder ao Tópico



  1. PessoALL,

    Peguei um exemplo aqui no fórum de página de bloqueio e aviso sem usar hotspot e nem servidor externo. Porem não estar funcionando corretamente, ao bloquear um cliente e este cliente tentar navegar, ao invés de aparecer a página html configurada, o navegador dar um erro e aparece a mensagem abaixo:

    Clique na imagem para uma versão maior

Nome:	         erro.png
Visualizações:	245
Tamanho: 	78,0 KB
ID:      	56659

    As regras abaixo (ainda estou testando as regras):

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=\
    600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=8080,8079 serialize-connections=no src-address=\
    0.0.0.0

    /ip proxy access
    add action=deny disabled=no dst-port="" local-port=8079 redirect-to=gantzweb.16mb.com/aviso.html
    add action=deny disabled=no dst-port="" local-port=8080 redirect-to=gantzweb.16mb.com/bloqueio.html

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="AVISO DE DEBITO - CONTROLE" connection-state=new disabled=no dst-port=80 new-connection-mark=Aviso-Conexao1 passthrough=yes protocol=tcp src-address-list=Cliente-Debito
    add action=mark-connection chain=prerouting comment="" connection-mark=Aviso-Conexao1 disabled=no new-connection-mark=Aviso-Conexao2 passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-mark=Aviso-Conexao2 disabled=no new-connection-mark=Aviso-Conexao1 passthrough=yes src-address-list=Cliente-Leu-Aviso

    /ip firewall filter
    add action=add-src-to-address-list address-list=Cliente-Leu-Aviso address-list-timeout=1m chain=input comment="AVISO DE DEBITO A CLIENTES" connection-mark=Aviso-Conexao2 disabled=no
    add action=passthrough chain=forward comment="" disabled=no src-address-list=Cliente-Leu-Aviso

    /ip firewall nat
    add action=redirect chain=dstnat comment="AVISO DE DEBITO A CLIENTES" connection-mark=Aviso-Conexao2 disabled=no dst-port=80 protocol=tcp to-ports=8079
    add action=redirect chain=dstnat comment="BLOQUEIO DE CLIENTES INADIMPLENTES" disabled=no dst-port=80 protocol=tcp src-address-list=Cliente-Bloqueado to-ports=8080

    Qualquer sugestão ou correção será bem vinda! Agradeço a ajuda do pessoall!

  2. Amigo, a solução que postei é sem usar servidor externo. Obrigado pela sugestão, mas não é meu caso. Uso ACL para aviso e bloqueio.



  3. Obrigado Arthur! De acordo com este tópico: https://under-linux.org/showthread.php?t=147295 a ideia funciona, mas para mim estar dando erro de redirecionamento incorreto. É isso que não estou entendo!






Tópicos Similares

  1. Respostas: 1
    Último Post: 09-08-2016, 00:46
  2. Respostas: 3
    Último Post: 22-06-2014, 16:10
  3. Respostas: 9
    Último Post: 08-05-2014, 21:06
  4. Pagina de Aviso - Sem hotspot e PPOE
    Por leonardolinux no fórum Redes
    Respostas: 1
    Último Post: 06-05-2011, 06:30
  5. Respostas: 1
    Último Post: 02-10-2007, 20:14

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L