Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Load Balance pcc não esta usando todos os link

    Olá galera boa tarde sou novo aqui fiz um load balance pcc com 3 links
    Link A 10mb
    Link B 15mb
    link c 15MB
    o que acontece quando vou no speedtestcopel.com da a velocidade de 25mb então ele usa apenas o A e o B aí em police router marcação esta assim Link A 3/0 Link B 3/1 Link C 3/2 total de três marcações quando eu desligo o link A o speedtest.copel dar os 30 mb sei que o load balance não soma os links, mas percebi que o load balance quando esta ativo os 3 link usa link a e link b mais que o link c o link C fica praticamente quase sei uso.. gostaria de saber se esta certo as marcações???? tendo em vista que os links são assimétrico...

  2. #2
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    amigo nada vai somar link, testes baseado em http como o teste copel as vezes ele aceita mais frames, ai da a impressão de usar todos os linnks mas nem sempre funciona, PLUGUE O SEU BALANCE NA REDE, VEJA O TRAFEGO DOS LINKS SE TIVER USANDO TODOS AI TA PRONTO

    se estiver usando somente o link1 e link2 é sinal que os pesos estao errado ai tem que ver seu mangle e route



  3. #3

    Padrão Re: Load Balance pcc não esta usando todos os link

    Seria importante vc dar um export no seu mangle e em Routes, para analisarmos e outra vc esta usando link de velocidades diferentes então a conta terá que ser diferente, primeiramente vá no post do M4D3, Luciano Rampanelli e tem o PCC e suas explicações e tem a forma de se calcular links assimétricos e simétricos.


    Ivan Galves

  4. #4
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    fiz este tudo simples e resolve para 2 linhas

    https://under-linux.org/showthread.php?t=151067



  5. #5
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    Clique na imagem para uma versão maior

Nome:	         2 links-450g.jpg
Visualizações:	285
Tamanho: 	158,8 KB
ID:      	59428 Clique na imagem para uma versão maior

Nome:	         suelen.jpg
Visualizações:	287
Tamanho: 	327,7 KB
ID:      	59429 Clique na imagem para uma versão maior

Nome:	         leonardo-pppoe-qos.jpg
Visualizações:	265
Tamanho: 	415,2 KB
ID:      	59430

  6. #6

    Padrão Re: Load Balance pcc não esta usando todos os link

    olha ái minha configuração gostaria de saber como faço para balancear os links assimétrico pq agora esta assim ISP 1 25mb gvt, ISP 2 15mb gvt ISP 3 10MB gvt, agora gostaria de saber como fazer as marcações certas...segue o exporte do load balance

    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall mangle
    add action=mark-connection chain=pollicy_router comment=\
    "====================================================================" \
    dst-address-type=!local new-connection-mark=ISP1_conn \
    per-connection-classifier=both-addresses:2/0
    add chain=prerouting comment=\
    "==================================================================" \
    dst-address=192.168.88.0/30 src-address=192.168.88.0/30
    add chain=prerouting disabled=yes dst-address=10.0.20.0/30 src-address=\
    192.168.88.0/30
    add chain=prerouting disabled=yes dst-address=192.168.1.0/24 src-address=\
    192.168.88.0/30
    add action=mark-connection chain=eprerouting comment=\
    "====================================================================" \
    disabled=yes in-interface=pppoe-out1 new-connection-mark=ISP1_conn \
    packet-mark=no-mark
    add action=mark-connection chain=prerouting comment=\
    "====================================================================" \
    in-interface=pppoe-out3 new-connection-mark=ISP3_conn packet-mark=no-mark
    add action=mark-connection chain=prerouting in-interface=pppoe-out2 \
    new-connection-mark=ISP2_conn packet-mark=no-mark
    add action=jump chain=prerouting comment=\
    "====================================================================" \
    connection-mark=no-mark in-interface=Local jump-target=pollicy_router
    add action=mark-routing chain=prerouting comment=\
    "====================================================================" \
    connection-mark=ISP1_conn new-routing-mark=ISP1_trafic src-address=\
    192.168.88.0/30
    add action=mark-routing chain=prerouting connection-mark=ISP2_conn \
    new-routing-mark=ISP2_trafic src-address=192.168.88.0/30
    add action=mark-routing chain=prerouting connection-mark=ISP3_conn \
    new-routing-mark=ISP3_trafic src-address=192.168.88.0/30
    add action=mark-routing chain=output comment=\
    "====================================================================" \
    connection-mark=ISP1_conn new-routing-mark=ISP1_trafic
    add action=mark-routing chain=output connection-mark=ISP2_conn \
    new-routing-mark=ISP2_trafic
    add action=mark-routing chain=output connection-mark=ISP3_conn \
    new-routing-mark=ISP3_trafic
    add action=mark-connection chain=pollicy_router dst-address-type=!local \
    new-connection-mark=ISP1_conn per-connection-classifier=\
    both-addresses:3/0
    add action=mark-connection chain=pollicy_router dst-address-type=!local \
    new-connection-mark=ISP2_conn per-connection-classifier=\
    both-addresses:3/1
    add action=mark-connection chain=pollicy_router dst-address-type=!local \
    new-connection-mark=ISP3_conn per-connection-classifier=\
    both-addresses:3/2
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat out-interface=pppoe-out1
    add action=masquerade chain=srcnat out-interface=pppoe-out2
    add action=masquerade chain=srcnat out-interface=pppoe-out3
    add action=dst-nat chain=dstnat comment="ACESSO AO SERVIDOR=======" disabled=\
    yes dst-port=8292 protocol=tcp to-addresses=192.168.88.2 to-ports=8291



  7. #7
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    nossa amigo este balance foi falado no mum de 2010, o geronimo fez um video depois o apollo copiou, ele esta defasado, ele precisa de regras de https, da problema em jogos, satura um link problemas com bancos, nao se usa mais isso

  8. #8

    Padrão Re: Load Balance pcc não esta usando todos os link

    Clique na imagem para uma versão maior

Nome:	         load balance.jpg
Visualizações:	85
Tamanho: 	142,9 KB
ID:      	59431print



  9. #9

    Padrão Re: Load Balance pcc não esta usando todos os link

    de fato usa todos os links vi no youtube que esta fazendo o balance mas agora queria saber se nesse cenário se todos os links estão de cargas iguas pq como disse tenho LINK A 25MB LINKB 15 e LINKC 10, agora como fazer as marcações em bootandress

  10. #10
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    25+15+10=50 50/10=5 então seria

    3 para 25
    2 para 15
    1 para 10


    agora se desejar vc pode colocar tb desta forma

    5 para 25
    3 para 15
    2 para 10



  11. #11
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    mas veja bem amigo dificil encontrar algo na net que é para sua rede, então vc deve pegar a base e ler e aprender, so assim terá sucesso, pesquisar, ja fizeram muito postando o video, agora cabe cada usuário, entender a essência do que precisa


    não tente copiar e colar, faça o possivel pra aprender

  12. #12

    Padrão Re: Load Balance pcc não esta usando todos os link

    Cara este balance não tive problemas com site de bancos foi baseado nesse aqui do youtube.. , e quando um link cai o outro assume e quando volta o link começa a conta certinho não precisei de adicionar sites de banco acho que esse load balance esta tudo certo olha o print no speedtest.copel


    Clique na imagem para uma versão maior

Nome:	         laod speed.jpg
Visualizações:	122
Tamanho: 	219,3 KB
ID:      	59432



  13. #13

    Padrão Re: Load Balance pcc não esta usando todos os link

    Blz.. fiz não foi copiando e colando regras e sim passo a passo quando estava com 2 links iguais estava perfeito, agora quero entender agora nesse cenário com 10, 15, e 25. mega como equilibrar cetinho achei na net com link tipo 512K, 1024, e 2 MB aí fica fácil de assimilar agora link quebrado de 10, 15, e 25, para que possa usar certinhos as cargas de acordo com tamanho de cada link..

  14. #14
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    amigo balace é a coisa mais simpels que tem, vc nao tem problema em sistes bancarios nem em https parabens,

    olha a diferença do mangle de um pcc atual para um pcc antigo,

    Clique na imagem para uma versão maior

Nome:	         3-gvt.jpg
Visualizações:	162
Tamanho: 	168,8 KB
ID:      	59433



  15. #15

    Padrão Re: Load Balance pcc não esta usando todos os link

    blz agora entendi era disso que estava falando dessas marcações pq no meu caso só funcionária perfeito se fosse cargas iguais.. vou tentar aqui...

  16. #16

    Padrão Re: Load Balance pcc não esta usando todos os link

    então seria mais ou menos assim

    3 para 25
    2 para 15
    1 para 10

    6/0 para 25mb 6/1 para 15 6/2 para o de 10mb, 6/3 para o de 25mb 6/4 para o de 15MB e 6/5 para o de 25MB ????



  17. #17
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    rrsr seguindo o passo a passo e copiar tem diferença?

    isso ai vai lhe ajudar a entender ok

    https://under-linux.org/showthread.php?t=131343

    Clique na imagem para uma versão maior

Nome:	         bbb.jpg
Visualizações:	59
Tamanho: 	25,5 KB
ID:      	59435

  18. #18

    Padrão Re: Load Balance pcc não esta usando todos os link

    É pq no passo a passo a pessoa estava descrevendo para que serve cada coisa que nós estamos adicionando... esse tutorial me ajudou mas queira ter certeza de como fazer marcações o equilíbrio dos links mas vejo que isso já envolve mais matemática com relação simetria e assimetria.. logo tenho 50MB divido por menor link que é de 10 então teria 5 marcações então ou posso fazer 5 para de 25mb 3 para de 15 e 2 para de 10 = então tendo o máximo de divisor comum de 50, já umas coisas que envolve matemática.. lógico que meus links fosse iguais faria apenas 3/0, 3/1 e 3/2. então se eu aumentar meus link de 10 e de 15 para 25 cada acabava com meus problemas com cálculos, mas esse paradigma continuaria..mas valeu.. vou tentar raciocinar isso para que eu posso resolver esse cálculo... obrigado a todos...



  19. #19
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Load Balance pcc não esta usando todos os link

    tenha em mente que perderá banda em alguns links isto é obvio, mas o link do m4d3 esclarece sem duvidas, vc ja tem a logica, eu expliquei em um post acima, e vc explicou agora, então o que mais deseja? rsr boa sorte amigo sucesso ai

  20. #20

    Padrão Re: Load Balance pcc não esta usando todos os link

    Blz cara valeu Acronimo, vou bater cabeça aqui, melhor do que pegar tudo mastigado e depois nem saber o pq de cada coisa.. valeu cara!!!!