Página 1 de 5 12345 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Mikrotik PPPOE desconectando clientes

    Olá pessoal, aqui estou novamente, na busca pelo conhecimento, com mais um problema em minha rede, o bendito por assim dizer é o seguinte:

    Estou eu a monitorar minha rede, do nada, percebo que o trafego diminui, vou ver o que é, metade dos clientes PPPOE desconectados. Eles desconectam e logo após reconectam. Alguns ficam distantes uns dos outros, alguns da rede cabeada outros da rede wireless. Exemplo: Sergio utiliza no cabo e caiu neste momento, Claudio vizinho dele continua logado(e provavelmente utilizando normalmente). Estou sem entender isto, alguns deslogam e relogam, outros continuam navegando "normalmente", alguns são no WIRELESS, outros na rede cabeada.

    Já mudei o Keep Alive, mudei agora a pouco o MTU e MRU(1492 E 1483 respectivamente). A primeira mudança não surtiu efeito algum, a segunda ainda verei.

    Coisas que podemos descartar:

    - Switchs e rede cabeada: A pouco menos de 2 semanas refiz toda a parte que leva internet para meus clientes, porém pelo problema ser em áreas diferentes por assim dizer podemos descartar isso, mas pessoas que pegam da nova rede também vem caindo o que me leva a crer ser alguma configuração.
    - Sinal das antenas: Já chequei todas, o maior sinal que encontrei aqui foi 70-71, então, duvido que seja, tendo em mente que se um da antena cai, todos deveriam cair, mas não é isto que ocorre.

    Tenho no momento 200 clientes, agora a pouco teve essa queda, 100 destes clientes desconectaram enquanto os outros 100 continuaram usando a internet normalmente.

    - Energia e RB: Energia não tem como ser, já chequei tudo, do inicio ao fim. RB duvido que seja, tendo em vista que metade da rede continua usando a internet enquanto a outra metade, não tem internet até que a RB autentique seus users.

    E ai, alguém tem alguma luz para este bendito problema? Já estou sem saber para onde correr! Segue abaixo foto do que ocorre em partes, isto aparece logo após a onde de desconexões.
    Clique na imagem para uma versão maior

Nome:	         123.png
Visualizações:	1454
Tamanho: 	261,4 KB
ID:      	63946
    Aqui a foto do erro que segue durante a queda das pessoas no log: Clique na imagem para uma versão maior

Nome:	         1234.png
Visualizações:	1327
Tamanho: 	209,7 KB
ID:      	63947

    Sugestões?

  2. #2

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Quando resolvemos migrar de hotspot para pppoe encontramos este problema de forma aleatória, exatamente como descreveu.
    Daí sempre vem aquela "ajuda" dizendo que é MTU, ou então é energia, etc etc...
    Mas como explicar que no mesmo AP no caso do wireless um cliente cai e outro não e os dois com o mesmo sinal e mesmo nível de CCQ? E nos clientes configurados do mesmo modo.
    Não temos cabeamento. Mas pelo seu relato como explicar o ocorrido em cabo, pois quando normalmente acontece isso se recebe dicas de revisar o sinal do wireless e outras manobras nas instalações... Em cabo não deveria acontecer a não ser que o problema seja realmente o desempenho do servidor PPPoe.

    Voltamos tudo para hotspot.

    Por outro lado tenho lido relatos de redes com PPPoe funcionando perfeito... Talvez tenha algum segredo na configuração do servidor PPPoe que desconhecemos...



  3. #3

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Bom dia eu tenho o msm problema, tanto na rede sem fio tanto na rede cabeada e não e nunca usei hostpost


    Enviado via SM-G318ML usando UnderLinux App

  4. #4

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Segue a foto igual do nosso amigo do topico, obs. Tenho dois servidores microtik e ambos estão em lugar diferente e em outra rede


    Enviado via SM-G318ML usando UnderLinux App
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         1463741856257.jpg
Visualizações:	708
Tamanho: 	32,6 KB
ID:      	63949  



  5. #5

    Padrão Re: Mikrotik PPPOE desconectando clientes

    bom dia, envia umas fotos da configuração ppp e o profile.
    obrigado.

  6. #6

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Bom dia a tds amigos. Não seria coincidência não.
    Pois aqui tenho este mesmo problema é não tenho nen 60 clientes.
    Foi configurado por uma empresa séria e reconhecida no Brasil.
    Penso e montar um servidor Proxmox ou BFW para testar paralelo.
    Antes era de 5 a 10 min caia a conexão.
    Desligo td e volta ao normal após no Max 10 dias começa td de novo.
    Se alguma boa alma caridosa poder explicar ficaríamos grato.



  7. #7

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Segue a foto ppp profile

    Enviado via SM-G318ML usando UnderLinux App
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         1463746351678.jpg
Visualizações:	775
Tamanho: 	23,6 KB
ID:      	63952  

  8. #8

    Padrão Re: Mikrotik PPPOE desconectando clientes

    pode ser loop ou broadcast, sua rede é toda bridge? se for tenta dividir por partes e usa rb com rota estatica.



  9. #9

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Segue 3 prints de tudo, profiles e profiles servers, ao meu ver está tudo comum. Esqueci de mencionar que utilizo ambos os protocolos em minha rede, PPPOE e HOTSPOT, em HOTSPOT nunca tive tal problema, coloquei as 2 redes para funcionar juntas.
    Clique na imagem para uma versão maior

Nome:	         profile1.png
Visualizações:	787
Tamanho: 	204,4 KB
ID:      	63953Clique na imagem para uma versão maior

Nome:	         profile2.png
Visualizações:	772
Tamanho: 	210,4 KB
ID:      	63954Clique na imagem para uma versão maior

Nome:	         profile3.png
Visualizações:	742
Tamanho: 	201,8 KB
ID:      	63955

  10. #10

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Citação Postado originalmente por 1929 Ver Post
    Quando resolvemos migrar de hotspot para pppoe encontramos este problema de forma aleatória, exatamente como descreveu.
    Daí sempre vem aquela "ajuda" dizendo que é MTU, ou então é energia, etc etc...
    Mas como explicar que no mesmo AP no caso do wireless um cliente cai e outro não e os dois com o mesmo sinal e mesmo nível de CCQ? E nos clientes configurados do mesmo modo.
    Não temos cabeamento. Mas pelo seu relato como explicar o ocorrido em cabo, pois quando normalmente acontece isso se recebe dicas de revisar o sinal do wireless e outras manobras nas instalações... Em cabo não deveria acontecer a não ser que o problema seja realmente o desempenho do servidor PPPoe.

    Voltamos tudo para hotspot.

    Por outro lado tenho lido relatos de redes com PPPoe funcionando perfeito... Talvez tenha algum segredo na configuração do servidor PPPoe que desconhecemos...
    É exatamente isto que não entendo, tenho aqui uma antena com 6 clientes conectados, destes 6, cairam 2 ontem, enquanto os outros ficaram conectados no PPPOE, todos estão configurados do mesmo modo, sem diferença alguma! O que me leva crer ainda mais que seja alguma configuração. Esta mudança foi muito grande, o tempo para retornar para o antigo HOTSPOT estes clientes demoraria, e muito, ja que já se acostumaram a não precisar colocar mais LOGIN e SENHA, se eu voltasse à isto 90% da rede ficaria confusa e sem saber o que houve.



  11. #11

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Citação Postado originalmente por isaquebrumel Ver Post
    pode ser loop ou broadcast, sua rede é toda bridge? se for tenta dividir por partes e usa rb com rota estatica.
    Duvido que seja tal coisa. Rede toda em bridge, switchs já foram checados, troquei a rede que leva internet aos meus clientes toda por assim dizer(até onde ocorre a divisa das direções), e mesmo clientes nesta mesma "nova" rede por assim dizer, desconectam da mesma forma. Fora que já tive a bendita "sorte" de já presenciar um LOOP em minha rede feito por mim mesmo, sem querer, quando estava instalando a nova rede, coloquei acidentalmente o cabo antigo que ainda possuia internet no novo switch junto ao novo cabo que também possuia internet, o resultado foi um grande susto, a RB ficou travada completamente pelo WINBOX, não conseguia conectar nem HOTSPOT nem PPPOE. Passaram mais ou menos 3 minutos desta forma, mas foi o suficiente para eu saber o que é um "loop".

  12. #12

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Tenta switch com Vlan, como sua rede é toda em Bridge pode ter algum cliente fazendo essa bagunça,mesmo sem saber.



  13. #13

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Bom dia eu passei por essa mesma situação. Sou meio inexperiente em configuração. Mas para mim o que resolveu foi desmarcar a opção "One Session Per Host" Na aba Ppoe Server. Como mostra na imagem 3.

  14. #14

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Citação Postado originalmente por FMANDU Ver Post
    Tenta switch com Vlan, como sua rede é toda em Bridge pode ter algum cliente fazendo essa bagunça,mesmo sem saber.
    Já utilizo switchs VLAN em minha rede, pontos estrategicos onde possuo divisões.



  15. #15

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Citação Postado originalmente por oliari Ver Post
    Bom dia eu passei por essa mesma situação. Sou meio inexperiente em configuração. Mas para mim o que resolveu foi desmarcar a opção "One Session Per Host" Na aba Ppoe Server. Como mostra na imagem 3.
    Não acho que desmarcar a opção resolveria, já que ela faz a função principal de que se a pessoa cair, ela irá deslogar e relogar, se eu desmarcasse haveria um tumulto de usuarios por assim dizer, tendo 2-3-4 usuarios de uma mesma pessoa conectados.

  16. #16

    Padrão Re: Mikrotik PPPOE desconectando clientes

    @edmilson2709,

    Bom dia

    Nao tenho esses problemas, fazendo uma comparação com o meu server ppoe e profiles seguem as oservações:

    1 - no meu ppoe server esta desabilitado o MRRU e esta sem o keepalive timeout, está também setado como default profile e tbm marcada todas as opções de autenticações (pap, chap, etc).

    2 - Nos meus profiles, tenho marcado como default na opção de protocolos MPLS, Compression e Encryption.

    Vi que vc está utilizando a 6.24, tenta upgrade para 6.28, foi uma das melhores versões para pppoe que sairam.

    Veja isso e nos comunique.



  17. #17

    Padrão Re: Mikrotik PPPOE desconectando clientes

    No meu caso eu ja desmarquei marquei de novo aumemtei o tempo tbm e é a mesma coisa, minha 2 redes separadas são todas em ppoe

    Enviado via SM-G318ML usando UnderLinux App

  18. #18

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Citação Postado originalmente por faelldantas Ver Post
    @edmilson2709,

    Bom dia

    Nao tenho esses problemas, fazendo uma comparação com o meu server ppoe e profiles seguem as oservações:

    1 - no meu ppoe server esta desabilitado o MRRU e esta sem o keepalive timeout, está também setado como default profile e tbm marcada todas as opções de autenticações (pap, chap, etc).

    2 - Nos meus profiles, tenho marcado como default na opção de protocolos MPLS, Compression e Encryption.

    Vi que vc está utilizando a 6.24, tenta upgrade para 6.28, foi uma das melhores versões para pppoe que sairam.

    Veja isso e nos comunique.
    Olá amigo, bom dia.

    1 - Se eu retirar o keepalive timeout, os usuarios não seriam deslogados, mesmo que o roteador ou computador de tal fosse desligado, correto? Mas mesmo tendo isso em mente, a internet para estes tais provavelmente cai, o que daria no mesmo, seja ele logado ou deslogado, a conexão irá cair? O que o MRRU faz? Qual sua função por assim dizer, sou leigo nesse assunto de MTU, MRU E MRRU.

    2 - Se deixar default poderá ocorrer algo de errado em minha rede? Desde o inicio que criei esse PPPOE esteve assim, todavia irei fazer o teste.

    3 - Nunca atualizei um MK por que nunca houve necessidade, pelo menos não para mim, existe riscos, correto? Se eu dar um upgrade, a licença do meu MK vai continuar a mesma coisa? E as configurações, serão apagadas?



  19. #19

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Vamos lá:

    1 - eu tirei o meu pq nao está funcionando na 6.35 (atualizei a minha da 6.28).

    " O padrão pra servidor é 1500 B, mas pra estação se precisar setar você desconta 20, 28 ou mesmo 32 bytes de cabeçalho (Basico em rede cabeada são 20 bytes, em wifi dependendo do tipo de encriptação pode perder 28 ou 32B), ficando 1480, 1472 ou 1468.
    Nada no mundo é "melhor" ou "pior", tem que ver cada caso. Mas falando genericamente, servidor usar MTU de 1500, existe a praxe de usar MTU de 1492 em servidor de autenticação PPPOE, mas o que deve ser limitado a 1492 em PPPOE é o MRU, o MTU mesmo em PPPOE pode ser setado pra 1500 sem problemas.

    (Se está falando de Mikrotik, dependendo da configuração o pacote sai do pc do cliente grande, tipo 1472B, mas nalguma bridge no caminho ele é dividido, porque mais roteamento no caminho implicam em mais dados nos cabeçalhos, de modo que um pacote de 1472B viram 2 pacotes, um de 740B e outro com o restante. Opções como 1472 ou 1468 no MRU não são multiplos de 185 então geram umas quebras de pacotes, o que leva a menos erros quando a rede wifi está ruim, aquelas rede que um ping a -l 50 retorna em 20mS, mas um a -l 1400 retorna em 300mS. Nesse caso não é problema de MTU, mas sim de rede ruim, alterar MTU é um paleativo que as vezes reduz umas perdas de pacote quando não há muito consumo de banda, mas não gera uma conexão efetivamente melhor)

    Sobre o assunto:
    http://tools.ietf.org/html/rfc4638
    E no www.teleco.com.br tem conteúdo em PT_BR" by @rubem

    O MRRU -
    MLPPP over single link

    Typically size of the packet sent over PPP link is reduced due to overhead. MP can be used to transmit and receive full frame over single ppp link. To make it work the Multilink Protocol uses additional LCP configuration options Multilink Maximum Received Reconstructed Unit (MRRU)
    To enable Multi-link PPP over single link you must specify MRRU (Maximum Receive Reconstructed Unit) option. If both sides support this feature there are no need for MSS adjustment (in firewall mangle). Study shows that MRRU is less CPU expensive that 2 mangle rules per client. MRRU allows to divide packet to multiple channels therefore increasing possible MTU and MRU (up to 65535 bytes)
    Under Windows it can be enabled in Networking tag, Settings button, "Negotiate multi-link for single link connections". Their MRRU is hard coded to 1614. by Wiki Mikrotik
    Pelo que entendi é para trabalho com vários links.

    2 - eu deixei o meu default, pois gerencio ele diretamente no profile e não no servidor pppoe.

    3 - Nao existe (pelo menos não é para) problemas em atualizar o sistema, vc ficara com a mesma licença e com as mesmas configurações, o que pode acontecer é uma função mais especializada deixar de funcionar ( no meu caso da 6.28 para 6.35) o keepalive timeout não ta funcionando. Pensei em fazer downgrade (voltar para a versão 6.28), mas eu perderia a implementação do fastpath (ai seria assunto para outro tópico).

    Espero ter ajudado!





  20. #20

    Padrão Re: Mikrotik PPPOE desconectando clientes

    Citação Postado originalmente por faelldantas Ver Post
    Vamos lá:

    1 - eu tirei o meu pq nao está funcionando na 6.35 (atualizei a minha da 6.28).

    " O padrão pra servidor é 1500 B, mas pra estação se precisar setar você desconta 20, 28 ou mesmo 32 bytes de cabeçalho (Basico em rede cabeada são 20 bytes, em wifi dependendo do tipo de encriptação pode perder 28 ou 32B), ficando 1480, 1472 ou 1468.
    Nada no mundo é "melhor" ou "pior", tem que ver cada caso. Mas falando genericamente, servidor usar MTU de 1500, existe a praxe de usar MTU de 1492 em servidor de autenticação PPPOE, mas o que deve ser limitado a 1492 em PPPOE é o MRU, o MTU mesmo em PPPOE pode ser setado pra 1500 sem problemas.

    (Se está falando de Mikrotik, dependendo da configuração o pacote sai do pc do cliente grande, tipo 1472B, mas nalguma bridge no caminho ele é dividido, porque mais roteamento no caminho implicam em mais dados nos cabeçalhos, de modo que um pacote de 1472B viram 2 pacotes, um de 740B e outro com o restante. Opções como 1472 ou 1468 no MRU não são multiplos de 185 então geram umas quebras de pacotes, o que leva a menos erros quando a rede wifi está ruim, aquelas rede que um ping a -l 50 retorna em 20mS, mas um a -l 1400 retorna em 300mS. Nesse caso não é problema de MTU, mas sim de rede ruim, alterar MTU é um paleativo que as vezes reduz umas perdas de pacote quando não há muito consumo de banda, mas não gera uma conexão efetivamente melhor)

    Sobre o assunto:
    http://tools.ietf.org/html/rfc4638
    E no www.teleco.com.br tem conteúdo em PT_BR" by @rubem

    O MRRU -
    MLPPP over single link

    Typically size of the packet sent over PPP link is reduced due to overhead. MP can be used to transmit and receive full frame over single ppp link. To make it work the Multilink Protocol uses additional LCP configuration options Multilink Maximum Received Reconstructed Unit (MRRU)
    To enable Multi-link PPP over single link you must specify MRRU (Maximum Receive Reconstructed Unit) option. If both sides support this feature there are no need for MSS adjustment (in firewall mangle). Study shows that MRRU is less CPU expensive that 2 mangle rules per client. MRRU allows to divide packet to multiple channels therefore increasing possible MTU and MRU (up to 65535 bytes)
    Under Windows it can be enabled in Networking tag, Settings button, "Negotiate multi-link for single link connections". Their MRRU is hard coded to 1614. by Wiki Mikrotik
    Pelo que entendi é para trabalho com vários links.

    2 - eu deixei o meu default, pois gerencio ele diretamente no profile e não no servidor pppoe.

    3 - Nao existe (pelo menos não é para) problemas em atualizar o sistema, vc ficara com a mesma licença e com as mesmas configurações, o que pode acontecer é uma função mais especializada deixar de funcionar ( no meu caso da 6.28 para 6.35) o keepalive timeout não ta funcionando. Pensei em fazer downgrade (voltar para a versão 6.28), mas eu perderia a implementação do fastpath (ai seria assunto para outro tópico).

    Espero ter ajudado!




    Obrigado, ajudou bastante, irei fazer tais testes aqui e ver no que dá.