+ Responder ao Tópico



  1. #7
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão LG LW2110P

    Tem tambem um site brasileiro que o cara da umas dicas: http://www.emota.com.br/wireless/

    Após instalar o drive da edimax usei este script para faze-la funcionar:

    #Load module
    #/sbin/insmod -f rtl8180_24x.o

    #Set SSID
    /usr/sbin/iwpriv wlan0 wlan_para basicrates=0xf
    /usr/sbin/iwpriv wlan0 wlan_para oprates=0xf
    /usr/sbin/iwpriv wlan0 wlan_para fraghres=512
    /usr/sbin/iwpriv wlan0 wlan_para preamble=auto
    /usr/sbin/iwpriv wlan0 wlan_para authtype=sharedkey
    /usr/sbin/iwpriv wlan0 wlan_para channel=10
    /usr/sbin/iwpriv wlan0 wlan_para ssid2scan=MEU_ESSID
    /usr/sbin/iwpriv wlan0 wlan_para networktype=auto
    /usr/sbin/iwpriv wlan0 wlan_para ssid=MEU_ESSID


    /usr/sbin/iwpriv wlan0 wlan_para encmode=wep
    /usr/sbin/iwpriv wlan0 wlan_para wepmode=wep40,wepdkeyid=0,wepkey40_1=1A2B3C4D5F

    #Desliga o driver da wlan0
    /usr/sbin/iwpriv wlan0 disable

    #Liga o driver da wlan0
    /usr/sbin/iwpriv wlan0 enable

    #Configure wlan0 IP address
    /sbin/ifconfig wlan0 IPDAEDIMAX netmask 255.255.255.0

    /sbin/route add default gw GATEWAYDAEDIMAX wlan0
    echo "$(/sbin/ifconfig wlan0)"

  2. #8
    PhaEduX
    Visitante

    Padrão RTL8180

    Estou tentando rodar a placa da LG LW2110P ela usa o mesmo chip da Realter RTL8180.
    Slack 9.0 2.4.20.
    Wireless-Toos 26
    Usei os driver 1.2 e 1.5.
    Quando vou rodar o script dá:
    Invalid Command wlan_para.
    Alguem tem uma pista de que pode ser?
    Como sei se o suporte a wireless está ativado?

    INFORMAÇÃO INSERIDA EM 06/05/2004 - 21:38
    Condegui rodar a placa e funciona com desempenho superior ao Windows.



  3. #9
    Skullcan
    Visitante

    Padrão LG LW2110P

    Ae, usei esse script pra levantar a placa, ela subiu beleza.
    Adicionei o gateway dela usando o route add default gw ****
    Configurei os DNS no resolv.conf tudo certinho.

    mas mesmo assim nao consigo navegar, falta algo ainda?

    Detalhe: Quando dou iwconfig ele fala: "Esse driver foi compilado usando o Wireless tools versao 0. Este programa esta rodando a versao 15. Algumas coisas erradas podem ocorrer."
    Alguma solução?

    Estou usando:
    Slackware 9.0
    Kernel 2.4.22
    Wirless tools 2.6

    Obrigado.

  4. #10
    PhaEduX
    Visitante

    Padrão LG LW2110P

    Citação Postado originalmente por Skullcan
    Ae, usei esse script pra levantar a placa, ela subiu beleza.
    Adicionei o gateway dela usando o route add default gw ****
    Configurei os DNS no resolv.conf tudo certinho.

    mas mesmo assim nao consigo navegar, falta algo ainda?

    Detalhe: Quando dou iwconfig ele fala: "Esse driver foi compilado usando o Wireless tools versao 0. Este programa esta rodando a versao 15. Algumas coisas erradas podem ocorrer."
    Alguma solução?

    Estou usando:
    Slackware 9.0
    Kernel 2.4.22
    Wirless tools 2.6

    Obrigado.
    Acabei de conseguir rodar meu wireless no slack.
    Seguinte, para vc rodar vai ter que fazer um downgrade de seu kernel para 2.4.20 pois o driver 1.5 so roda nesse kernel. Depois faca o mesmo procedimento que e garantido.



  5. #11
    Skullcan
    Visitante

    Padrão LG LW2110P

    Edit: Mensagem duplicada.

  6. #12
    Skullcan
    Visitante

    Padrão LG LW2110P

    Ae... deu certo mesmo PhaEduX!

    Agora ja consegui linkar a minha placa com o AP.
    Ta pingando o Gateway e consegui configurar meu programa de e-mail.

    Soh tem um problema, eu nao consegui fazer com que ele reconhecesse os DNS's
    no meu caso sao 2
    200.153.70.194 e
    200.153.70.195

    apesar deles estarem lá no /etc/resolv.conf não acessa paginas fora do meu host.

    eu coloquei da seguinte forma no resolv.conf

    search 200.153.70.194
    nameserver 200.153.70.194
    search 200.153.70.195
    nameserver 200.153.70.195


    algo errado aí?