+ Responder ao Tópico



  1. #61

    Padrão tela cliente atrazo

    Citação Postado originalmente por catvbrasil Ver Post
    por thiago

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no[/quote]


    CARO COLEGAS FIZ ESTE DIRECIONAMENTO CERTO COMO CITADO ACIMA MAS DA UM ERRO QUANDO VOU TENTAR NAVEGAR TIPO NÃO EXIBE A PAGINA CORRETA APENAS DA ESTE ERRO. E SE EU NAVEGAR NORMAL PELO NAVEGADOR SEM O DIRECIONAMENTO A PAGINA DE NOTIFICAÇÃO FUNCIONA SEM PROBLEMAS.

    erro:
    Great Success !
    Apache is working on your cPanel® and WHM™ Server


    If you can see this page, then the people who manage this server have installed cPanel and WebHost Manager (WHM) which use the Apache Web server software and the Apache Interface to OpenSSL (mod_ssl) successfully. They now have to add content to this directory and replace this placeholder page, or else point the server at their real content.
    ATTENTION!

    If you are seeing this page instead of the site you expected, please contact the administrator of the site involved. (Try sending an email to <[email protected]domain>.) Although this site is running cPanel, WebHost Manager, and Apache software it almost certainly has no other connection to cPanel Inc. or the Apache Group. Please do not send mail about this site or its contents to cPanel Inc. or the Apache Group.
    About cPanel:

    cPanel is a leading provider of software for the webhosting industry. If you would like to learn more about cPanel please visit our website at www.cpanel.net. Please be advised that cPanel Inc. is not a web hosting company, and as such has no control over content found elsewhere on this site.
    About Apache HTTP Server:

    The Apache HTTP Server is an open source web server which powers many of the worlds web sites. The Apache HTTP server is part of the Apache Group's many influential projects. Their efforts have helped shape much the world wide web, and they continue to be a dominating force in the web hosting industry.
    http://www.cyberpointcandoi.com.br/s...powered_by.gifhttp://www.cyberpointcandoi.com.br/s.../apache_pb.gif

    este erro q ocorre alguem pode me ajudar.

    e o endereço de bloqueio é este:

    BLOQUEIO DE CLIENTES EM ATRAZO.

  2. #62

    Padrão

    Citação Postado originalmente por neon Ver Post
    meu mkt esta como router.

    tenho esse bloqueio de clientes atrasados funcionando assim:

    ;;; BLOQUEIO - CLIENTES EM ATRASO
    chain=dstnat dst-address=!10.x.x.254 src-address-list=BLOQUEIO-ATRASO action=dst-nat to-addresses=10.x.x.254 to-ports=81

    todo acesso que nao seja ao meu servidor, seja qual for o protocolo e/ou porta é redirecionado para o meu servidor na porta 81.

    dessa forma nao precisa fazer regra para bloqueio dos outros serviços que nao sejam HTTP (porta 80).

    fiz um VirtualHost no apache na portat 81 com a pagina de bloqueio.

    ai so vou no ip firewall address list e adiciono o ip do cliente inadimplente na lista BLOQUEIO-ATRASO

    funfa blz.

    PS: Sobre o aviso de tempos em tempos, eu creio que seja possivel sim, vou tirar um tempo esta semana para fazer esses testes

    Neon

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no[/quote]


    CARO COLEGAS FIZ ESTE DIRECIONAMENTO CERTO COMO CITADO ACIMA MAS DA UM ERRO QUANDO VOU TENTAR NAVEGAR TIPO NÃO EXIBE A PAGINA CORRETA APENAS DA ESTE ERRO. E SE EU NAVEGAR NORMAL PELO NAVEGADOR SEM O DIRECIONAMENTO A PAGINA DE NOTIFICAÇÃO FUNCIONA SEM PROBLEMAS.

    erro:
    Great Success !
    Apache is working on your cPanel® and WHM™ Server


    If you can see this page, then the people who manage this server have installed cPanel and WebHost Manager (WHM) which use the Apache Web server software and the Apache Interface to OpenSSL (mod_ssl) successfully. They now have to add content to this directory and replace this placeholder page, or else point the server at their real content.
    ATTENTION!

    If you are seeing this page instead of the site you expected, please contact the administrator of the site involved. (Try sending an email to <[email protected]domain>.) Although this site is running cPanel, WebHost Manager, and Apache software it almost certainly has no other connection to cPanel Inc. or the Apache Group. Please do not send mail about this site or its contents to cPanel Inc. or the Apache Group.
    About cPanel:

    cPanel is a leading provider of software for the webhosting industry. If you would like to learn more about cPanel please visit our website at www.cpanel.net. Please be advised that cPanel Inc. is not a web hosting company, and as such has no control over content found elsewhere on this site.
    About Apache HTTP Server:

    The Apache HTTP Server is an open source web server which powers many of the worlds web sites. The Apache HTTP server is part of the Apache Group's many influential projects. Their efforts have helped shape much the world wide web, and they continue to be a dominating force in the web hosting industry.
    http://www.cyberpointcandoi.com.br/s...powered_by.gifhttp://www.cyberpointcandoi.com.br/s.../apache_pb.gif

    este erro q ocorre alguem pode me ajudar.

    e o endereço de bloqueio é este:

    BLOQUEIO DE CLIENTES EM ATRAZO.

    NO MEU CASO FIZ IGUAL O THIAGO PASSOU MAS NÃO VAI IGUAL A TUA REGRA TAMBEM BATE NESTE ERRO PODERIA ME EXPLICAR MAIS SOBRE ESTE VIRTUALHOST COM CONFIGURAR ONDE. FICO GRATO.



  3. #63

    Red face Bloqueio Hotspot pagina externa

    Pessoal, to precisando de uma ajuda, depois de ler muito sobre o assunto aqui no forum, criei o usuário bloqueado no ip/hotspot/profile porém na opção ADVERTISE optei em utilizar uma pagina hospedada, ex http://xxxxxx.com.br/aviso_1/ escolho o profile pra bloquear o cliente, até ai td certinho, porém qd ele loga da pagina não exibida e ele continua a navegar se abre outras paginas.
    Minha pergunta, precisa alterar algum arquivo dentro da pasta Hotspot? o que fazer pra não conseguir navegar depois de abrir a pagina de avisos?
    Obrigada pela força..
    Elis..

  4. #64

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no

    Ai onde diz IP_SERVIDOR_WEB_AVISO pode ser tipo assim: http://www.paginadeaviso.com.br??

    outra coisa: só ira funcionar o redirecionamento se o cliente colocar o login e a senha, pois eu uso o ipbinding pra eles nao precisarem ficar digitando senha
    Última edição por iafury; 01-06-2008 às 21:10.



  5. #65

    Padrão

    Citação Postado originalmente por lipossani Ver Post
    Pessoal, to precisando de uma ajuda, depois de ler muito sobre o assunto aqui no forum, criei o usuário bloqueado no ip/hotspot/profile porém na opção ADVERTISE optei em utilizar uma pagina hospedada, ex http://xxxxxx.com.br/aviso_1/ escolho o profile pra bloquear o cliente, até ai td certinho, porém qd ele loga da pagina não exibida e ele continua a navegar se abre outras paginas.
    Minha pergunta, precisa alterar algum arquivo dentro da pasta Hotspot? o que fazer pra não conseguir navegar depois de abrir a pagina de avisos?
    Obrigada pela força..
    Elis..
    No user profile, defina o valor de session timeout..
    flw

  6. #66

    Padrão

    Citação Postado originalmente por iafury Ver Post
    Ai onde diz IP_SERVIDOR_WEB_AVISO pode ser tipo assim: http://www.paginadeaviso.com.br??

    outra coisa: só ira funcionar o redirecionamento se o cliente colocar o login e a senha, pois eu uso o ipbinding pra eles nao precisarem ficar digitando senha
    Amigo.. se vc nao quer que os usuarios digitem o username e senha, por que usar hotspot?
    flw



  7. #67

    Padrão

    Opa, aqui utilizo um sistema assim, mas faço tudo manual, tipo...

    eu criei uma pagina de aviso o coloquei ela no mk, criei um profile para essas pessoas, quando o cliente atrasa eu faço a alteracao no plano dele, nesse plano de 5 em 5 minutos aparece a pagina de aviso falando que ele tem algo pendente...
    isso para mim tem me ajudando muito, porque antes bloqueava a pessoa reclamava bastante hoje só bloqueio acina de 10 dias pendente.

    crie uma pagina de aviso do seu gosto e jogue no mk, depois crie um profile em user, com a velocidade que voce quiser, em advertise coloque o nome da sua pagina que enviou para o mk (no meu caso, aviso.html)
    coloque a frequencia que a pagina vai aparecer para o usuario....

    depois va em ip>dns... cadastre o ip de saida do seu link, e pronto, os seus clientes vao ver essa pagina toda vez, ate que voce volte ao profile normal!

    espero ter ajudado!!
    falou!

  8. #68

    Padrão

    [quote=leandroapm;324775]
    depois va em ip>dns... cadastre o ip de saida do seu link, e pronto, quote]


    Cara aqui nao ta rolando ja fiz varias vezes, esse ip de saida que voce citou é o ip do servidor? tipo meu servidor é 192.168.200.1 seria esse o ip pra colocar la, e onde vai a pagina tem que ser http://192.168.200.1/aviso.html ou soh aviso .html ja tentei de varias formas e nao funfou



  9. #69

    Padrão

    [quote=iafury;324788]
    Citação Postado originalmente por leandroapm Ver Post
    depois va em ip>dns... cadastre o ip de saida do seu link, e pronto, quote]


    Cara aqui nao ta rolando ja fiz varias vezes, esse ip de saida que voce citou é o ip do servidor? tipo meu servidor é 192.168.200.1 seria esse o ip pra colocar la, e onde vai a pagina tem que ser http://192.168.200.1/aviso.html ou soh aviso .html ja tentei de varias formas e nao funfou
    opa, coloque o gateway de saida do seu link do mikrotik, tipo..
    em ip>route voce tem o ip de saida geral do seu link, só add ele em ip>dns, da certo, nao tem erro, se nao der me fala..

    a pagina de aviso voce coloca somente o aviso.html, porque se voce tiver mais de uma categoria de rede, vai ser feito automatico o endereço..

  10. #70

    Padrão Problema....

    Ola, eu estou com um problema para "Redireccionar clientes para pagina local com APache"

    Eu configurei isto em Mikrotik 2.9.27:
    /ip firewall nat
    chain=dstnat protocol=tcp src-address=[Client IP] dst-port=80 action=dst-nat to-addresses=[Webserver IP] to-ports=8001

    Mas nao esta funcionando
    O cliente nao pode usar o firefox (se ele intenta ingresar www.google.com nao tem resultado) mas nao mostre minha pagina com Apache.
    ele só tem uma página de erro de Firefox e não de meu apache de WebServer

    Se eu browse em http://192.168.0.5:8001 (meu ip de apache e porto) trabalham bem e eu vejo o "não-pagar-página.
    Eu tenho alguns regras "mangle" para tráfico entrante no porto 80 (mas eu não sei se isto tem relação com meu problema).
    Eu tentei mudar o porto, Disable regras de Mangle, SET outra gama em porto (não só um) mas eu não posso achar onde é o problema.


    Se alguém pode me falar o que posso ver eu para achar onde é o problema seria muito útil.

    Grato.

    -Eu nao uso HotSpot -
    Última edição por erniman; 20-06-2008 às 10:42.



  11. #71

    Padrão

    Citação Postado originalmente por erniman Ver Post
    Ola, eu estou com um problema para "Redireccionar clientes para pagina local com APache"

    Eu configurei isto em Mikrotik 2.9.27:
    /ip firewall nat
    chain=dstnat protocol=tcp src-address=[Client IP] dst-port=80 action=dst-nat to-addresses=[Webserver IP] to-ports=8001

    Mas nao esta funcionando
    O cliente nao pode usar o firefox (se ele intenta ingresar www.google.com nao tem resultado) mas nao mostre minha pagina com Apache.
    ele só tem uma página de erro de Firefox e não de meu apache de WebServer

    Se eu browse em http://192.168.0.5:8001 (meu ip de apache e porto) trabalham bem e eu vejo o "não-pagar-página.
    Eu tenho alguns regras "mangle" para tráfico entrante no porto 80 (mas eu não sei se isto tem relação com meu problema).
    Eu tentei mudar o porto, Disable regras de Mangle, SET outra gama em porto (não só um) mas eu não posso achar onde é o problema.


    Se alguém pode me falar o que posso ver eu para achar onde é o problema seria muito útil.

    Grato.

    -Eu nao uso HotSpot -
    Olá amigo,
    Faça deste jeito:

    Note: 10.10.0.1 representa o ip do mikrotik, 10.10.0.2 o ip do apache, 10.10.0.3 o cliente e ether1 a placa onde o apache e o cliente estão conectados.

    1 - Adicionar o ip do Apache Server em Address List do mikrotik:
    /ip address add address=10.10.0.2/24 interface=ether1 comment="Apache WebServer"

    2 - Para protocolo tcp que chegarem ao servidor:
    /ip firewall nat add chain=dstnat src-address=10.10.0.3 dst-address=10.10.0.1 protocol=tcp dst-port=4040 action=dst-nat to-addresses=10.10.0.2 to-ports=8001

    3 - Para protocolo udp que chegarem ao servidor:
    /ip firewall nat add chain=dstnat src-address=10.10.0.3 dst-address=10.10.0.1 protocol=udp dst-port=4040 action=dst-nat to-addresses=10.10.0.2 to-ports=8001

    6 - Redireciona o cliente para o apache:
    /ip firewall nat add chain=dstnat src-address=10.10.0.3 protocol=tcp dst-port=80 action=dst-nat to-addresses=10.10.0.2 to-ports=8001

  12. #72

    Padrão

    Ola Mr. RG obrigado pela dica.

    Eu testei mas nao funcionou. O problema é que quando eu adiciono o ip do Apache Server em Address List do mikrotik o LINK do Internet cai (eu nao tenho link).
    Lá eu tenho o address do mikrotik e do Cablemodem (dinamic).

    Eu vou a testar novamente mais tarde (quando nao tenha tanto trafego).



  13. #73

    Padrão

    Citação Postado originalmente por erniman Ver Post
    Ola Mr. RG obrigado pela dica.

    Eu testei mas nao funcionou. O problema é que quando eu adiciono o ip do Apache Server em Address List do mikrotik o LINK do Internet cai (eu nao tenho link).
    Lá eu tenho o address do mikrotik e do Cablemodem (dinamic).

    Eu vou a testar novamente mais tarde (quando nao tenha tanto trafego).
    Me informe onde ip do mikrotik e do linux e se o linux conecta no mikrotik. E outras informações: ip e etc.

  14. #74

    Padrão

    Oi, eu anexo um jpg onde tem a Topologia de meu Rede.

    O cliente que eu quer bloquear é 192.168.0.6 ele tem configurado com DNS: 192.168.0.254

    Eu testei novamente o que voce recomendou fazer mas nao consegui que funcione.

    Veja que eu nao tenho um PC com Linux (solamente o Mikrotik). Em PC 192.168.0.5 eu tenho um WinXP com o Apache instalado em port 8001

    Se você precisa outras informações eu posso enviar.

    Muito obrigado novamente
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         topologiaErniman.jpg
Visualizações:	104
Tamanho: 	97,4 KB
ID:      	2328  



  15. #75

    Padrão

    Citação Postado originalmente por erniman Ver Post
    Oi, eu anexo um jpg onde tem a Topologia de meu Rede.

    O cliente que eu quer bloquear é 192.168.0.6 ele tem configurado com DNS: 192.168.0.254

    Eu testei novamente o que voce recomendou fazer mas nao consegui que funcione.

    Veja que eu nao tenho um PC com Linux (solamente o Mikrotik). Em PC 192.168.0.5 eu tenho um WinXP com o Apache instalado em port 8001

    Se você precisa outras informações eu posso enviar.

    Muito obrigado novamente
    Vou fazer uns testes e posto para você o resultado com as regras que eu usei.

  16. #76

    Padrão

    Olá amigo,
    Adicone as seguintes regras em seu mikrotik:

    Note: usei o slackware 11 com apache na porta 8080.

    /ip firewall nat add chain=dstnat src-address=10.10.1.3 protocol=tcp action=jump jump-target=linux

    /ip firewall nat add chain=linux action=dst-nat to-addresses=10.10.1.2 to-ports=808

    Note: o ip 10.10.1.2 é do linux e o 10.10.1.3 é do cliente. O servidor 10.10.1.1/24

    Testei e funcionou blz.

    Qualquer coisa...



  17. #77

    Padrão

    Opa esqueci de uma dica:

    Como toda vez que for redirecinado para o apache-linux, sempre irá ficar o endereço do site que foi digitado na barra.

    Dica: Fazer uma página em branco com um uma função javascript para abrir um pop-up ou uma nova janela com a pagina informativa.

    Note: Pode-se usar o ddns ou outro para dar nome ao seu site.

  18. #78

    Padrão

    Blz cara...funcionou !!

    Muito obrigado por sua ajuda.

    Um abraço



  19. #79

    Padrão Hotspot Bloqueio

    Tenho um Hotspot funcionando blz, e queria que assim que que o usuário loga-se aparece-se a tela de bloqueio sendo que esta página de bloqueio já está pronta inserir o bloqueio no plano mais quando altero o plano dele de 300K por exemplo para bloqueio ele não direciona para o html bloqueio como posso resolver isso sem muito trabalho.

  20. #80

    Padrão

    Citação Postado originalmente por alexrj2001 Ver Post
    Tenho um Hotspot funcionando blz, e queria que assim que que o usuário loga-se aparece-se a tela de bloqueio sendo que esta página de bloqueio já está pronta inserir o bloqueio no plano mais quando altero o plano dele de 300K por exemplo para bloqueio ele não direciona para o html bloqueio como posso resolver isso sem muito trabalho.
    Olá amigo,
    A sua página de bloqueio está no proprio mikrotik ou em um servidor apache-linux?