Página 6 de 11 PrimeiroPrimeiro ... 2345678910 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #101

    Padrão Erro no make

    compilei o libevent, agora esta dando somente esse erro abaixo:

    Código :
    [[email protected] msn-proxy]# make
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c msn-proxy.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c server.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c sb.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c command.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c config.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c net-io.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c client.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c syslog.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c ns.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c mysql.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c sql.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c protocol.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c check-cmd.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c contacts.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c msg.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c p2p.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c user.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c string.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c io.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c sig.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c fmt.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c xml.c
    cc -g -Wall -O2 -pipe -I/usr/local/include -I/usr/local/include -fno-builtin-log -c ctl.c
    cc -o msn-proxy msn-proxy.o server.o sb.o command.o config.o net-io.o client.o syslog.o ns.o mysql.o sql.o protocol.o check-cmd.o contacts.omsg.o p2p.o user.o string.o io.o sig.o fmt.o xml.o ctl.o -L/usr/local/lib -levent -L/usr/local/lib/mysql -lmysqlclient
    /usr/bin/ld: cannot find -lmysqlclient
    collect2: ld returned 1 exit status
    make: ** [msn-proxy] Erro 1
    Última edição por rogeriokde; 16-06-2008 às 21:32.

  2. #102

    Padrão Funcionou..

    Amigo obrigado pela dica, funcionou, agora só tem um problema, todos da rede ficam caindo com uma freqüência enorme, o que será que está acontecendo?


    Citação Postado originalmente por glaucioklipel Ver Post
    Posso estar vesgo hehehe, mas não vi nenhum redirecionamento pra porta do proxy...

    iptables -t nat -A PREROUTING -p tcp --dport 1863 -s (intervalo de ips da rede)/24 -j REDIRECT --to-port 1863



  3. #103

    Padrão gw/fw + proxy: máquinas separadas

    Bom dia galera!
    Espero que alguém possa me dar uma luz...

    o problema é o seguinte:
    existe um servidor que tem a conexão com a net, $GW ok?
    e existe outro servidor, onde ficará o msn-proxy (por motivos que não cabem ser descritos rsrs), $proxy ok?

    como faria com os redirecionamentos / drops / qqroutracoisaqueovalha para conseguir fazer funcionar o msn-proxy?!

    já quebrei a cabeça e realmente não consigo ver uma saída (ok, sei que sou meio leigo hehe)...

    Conto com a colaboração de vocês!

  4. #104

    Padrão

    Pessoal, descobri o pq ficava caindo depois q atualizei da 0.5 para 0.6, existe no msn-proxy.conf o
    # max clients
    #
    # set the number of simultaneous messenger clients on your network
    # with this knob
    #
    max_clients=10

    certo, o meu estava setado para 300 000, baixei esse numero para 300, e bingo, está funcionando ok agora!
    ahh ouve campos tbem q mmudaram na tabela do .5 para o .6



  5. #105

    Question

    Ae galera, ótima solução, estou configurando em um cliente para teste, instalei tudo como descrito acima sem maiores problemas, só estou tendo dificuldade na hora de conectar, versões do MSN mais antigas funcionam sem problemas, as mais novas como a 8.5 em algumas maquinas funcionam e outras não. rodei o msn-proxy com o parametro -v e para minha surpresa a versão 8.5 em algumas maquinas utiliza o protocolo msnp13 e em outras além desse utiliza também o msnp14 e msnp15. Nos testes as maquinas que utilizam os três protocolos conectaram sem problemas! Alguma idéia ou sugestão?

  6. #106

    Padrão

    Pessoal,

    Estou usando msn-proxy-0.6.2.

    Esta funcionando, mas estou com problema de estar prendendo a sessão, tipo dou um logof no msn, mas pagina do msn-proxy continua online, alguem já passou por isso?



  7. #107

    Padrão

    Aqui ele gravou 1 dia só e parou.

    Alguma dica?

    root:# /usr/local/bin/msn-proxy -v

    info: reading config file [/usr/local/etc/msn-proxy/msn-proxy.conf]
    SQL: (SHOW TABLES)
    SQL: (SELECT connect, save_msg, save_contacts, commands, internal_host FROM defaults LIMIT 1)
    config file : /usr/local/etc/msn-proxy/msn-proxy.conf
    default ns host : messenger.hotmail.com
    default ns port : 1863
    listen host : 0.0.0.0
    listen port : 1863
    backlog : 10
    max clients : 10000
    max ctl clients : 10
    port range begin : 25000
    port range end : 30000
    ctl read timeout : 5
    client read timeout : 600
    client write timeout : 60
    server read timeout : 600
    server write timeout : 60
    client connect timeout: 180

    ACLs
    connect : ALLOW
    log messages : YES
    save_contacts : YES

    listen on [0.0.0.0:1863]
    SQL: (DELETE FROM sb)
    SQL: (UPDATE contacts SET contact_status = 'OFF', contact_deny = contact_deny & ~4194304)
    SQL: (UPDATE users SET status = 'OFF')

    E não gravou mais..

    OBS: uso squid3 transparente na porta 3128, e firewall em accept, utilizando esse direcionamento:

    iptables -t nat -I PREROUTING -i eth1 -p tcp --dport 1863 -j REDIRECT --to-port 1863

    eth0 = rede externa
    eth1 = rede interna

    Obrigado a qualquer ajuda..

  8. #108

    Padrão

    Amigo somente com essa regra funcionou? Pois sempre que eu coloco ela eu não consigo enviar mensagens mais. E o serviço está rodando blz.

    Citação Postado originalmente por g0han Ver Post
    Aqui ele gravou 1 dia só e parou.

    Alguma dica?

    root:# /usr/local/bin/msn-proxy -v

    info: reading config file [/usr/local/etc/msn-proxy/msn-proxy.conf]
    SQL: (SHOW TABLES)
    SQL: (SELECT connect, save_msg, save_contacts, commands, internal_host FROM defaults LIMIT 1)
    config file : /usr/local/etc/msn-proxy/msn-proxy.conf
    default ns host : messenger.hotmail.com
    default ns port : 1863
    listen host : 0.0.0.0
    listen port : 1863
    backlog : 10
    max clients : 10000
    max ctl clients : 10
    port range begin : 25000
    port range end : 30000
    ctl read timeout : 5
    client read timeout : 600
    client write timeout : 60
    server read timeout : 600
    server write timeout : 60
    client connect timeout: 180

    ACLs
    connect : ALLOW
    log messages : YES
    save_contacts : YES

    listen on [0.0.0.0:1863]
    SQL: (DELETE FROM sb)
    SQL: (UPDATE contacts SET contact_status = 'OFF', contact_deny = contact_deny & ~4194304)
    SQL: (UPDATE users SET status = 'OFF')

    E não gravou mais..

    OBS: uso squid3 transparente na porta 3128, e firewall em accept, utilizando esse direcionamento:

    iptables -t nat -I PREROUTING -i eth1 -p tcp --dport 1863 -j REDIRECT --to-port 1863

    eth0 = rede externa
    eth1 = rede interna

    Obrigado a qualquer ajuda..



  9. #109

    Padrão

    entao.. aqui tambem NAO esta funcionando.. =|

    o msn-proxy esta rodando normal, mas nao grava conversa nenhuma..

    dicas?!

  10. #110

    Padrão

    Já eu estou com um problema diferente.
    Eu comecei usando a versão 0.5.
    Depois de mais ou menos 1 mês e meio do nada parou de funcionar.
    Na época tinha acabado de sair a 0.6.
    Instalei ela e até ontem estava funcionando beleza.
    Hoje, o que começou a acontecer:

    - Os msn´s conectam de boa
    - Na hora de enviar uma mensagem, clicando em "Enviar", o MSN desconecta
    - Reconecta normalmente, cai se tentar mandar uma mensagem PRA QUALQUER CONTATO

    Atualizei pra versão 0.6.2 (estou usando MySQL), mas o problema persiste.
    Abaixo o log exato quando eu mando enviar a mensagem. Destaquei em negrito algumas linhas que acho podem ser importantes:

    OBS: [email protected] é o e-mail da minha conta do MSN que uso dentro da empresa
    Meu_nome é o meu nome que aparece no meu MSN


    [[email protected]] send to ns server ==> XFR 17 SB

    command buf: [XFR 17 SB 207.46.26.172:1863 CKI 1237656804.2816291.14137100 U messenger.msn.com 1
    ]
    SQL: (INSERT INTO sb (email, since) VALUES ('[email protected]', NOW()))
    listen on [192.168.0.1:28947]
    SQL: (INSERT INTO log (sb_id, `date`, email, display_name, type) VALUES (63807, NOW(), '[email protected]', 'Meu_nome', 'start'))
    SQL ERROR: (INSERT INTO log (sb_id, `date`, email, display_name, type) VALUES (63807, NOW(), '[email protected]', 'Meu_nome', 'start')) MySQL: (Duplicate entry '264020' for key 1)
    debug: ns server command not accepted
    XFR 17 SB 192.168.0.1:28947 CKI 1237656804.2816291.14137100 U messenger.msn.com 1
    payload: [(null)]
    SQL: (INSERT INTO log (sb_id, `date`, email, display_name, type) VALUES (63807, NOW(), '[email protected]', 'Meu_nome', 'stop'))
    SQL ERROR: (INSERT INTO log (sb_id, `date`, email, display_name, type) VALUES (63807, NOW(), '[email protected]', 'Meu_nome', 'stop')) MySQL: (Duplicate entry '264020' for key 1)
    SQL: (DELETE FROM sb WHERE id = 63807)
    SQL: (UPDATE contacts SET contact_status = 'OFF', contact_deny = contact_deny & ~4194304 WHERE email = '[email protected]')
    SQL: (UPDATE users SET status = 'OFF' WHERE email = '[email protected]')
    Eu vi essas linhas que falam sobre entradas duplicadas, mas eu sou um completo noob em banco de dados, então não sei até onde isso pode ser um problema.
    O problema talvez seja sobre o comando "ns" não sendo aceito, mas eu não sei como tratar isso, ou o que isso quer dizer.
    A última mensagem em negrito é a hora que eu sou desconectado.

    Complicado, pra mim agora só falta tentar limpar a base do MySQL, mas eu tava querendo evitar isso :-/
    Última edição por Thakowbbery; 01-07-2008 às 12:17.



  11. #111

    Padrão

    Thakowbbery, tenta apagar as tabelas e deixar o msn-proxy criar novamente! da versão .5 pra .6 foi mudado o nome de um campo, e verifica tbem dentro do msn-proxy.conf, quanto esta setado no max_clients= eu tinha no .5 setado como 100.000 depois q fiz o upgrade, só caia, baixei pra 300 ta funfando beleza!
    se vc quiser existe uma ferramenta chamada phpmyadmin, q vc pode administrar o banco de dados muito facilmente! é o q uso, pois é um saco fazer via linha de comando

  12. #112

    Padrão

    O meu problema persiste que é não deixar enviar mensagens, já olhei tudo o que podia no firewall, o msn-proxy está rodando, estou vendo as configurações etc.. mais quando eu coloco as regras para ele rodar não funciona o msn ou seja, não consegue enviar mensagem.



  13. #113

    Padrão

    passei por isso, mas, verifiquei q na tabela contacts, o campo contact_allowed para contact_deny, algo assim! e começa a essa folia de cair constantemente!

  14. #114

    Padrão

    Citação Postado originalmente por agl77 Ver Post
    Thakowbbery, tenta apagar as tabelas e deixar o msn-proxy criar novamente! da versão .5 pra .6 foi mudado o nome de um campo, e verifica tbem dentro do msn-proxy.conf, quanto esta setado no max_clients= eu tinha no .5 setado como 100.000 depois q fiz o upgrade, só caia, baixei pra 300 ta funfando beleza!
    se vc quiser existe uma ferramenta chamada phpmyadmin, q vc pode administrar o banco de dados muito facilmente! é o q uso, pois é um saco fazer via linha de comando
    Então...

    Eu já estava com a versão 0.6 rodando aqui de boa.
    Simplesmente parou de funcionar da noite pro dia (na verdade tivemos problemas com quedas de energia durante a noite passada, mas apenas esse serviço específico parou de funcionar).
    Eu também fiz o que você sugeriu, de reduzir a quantidade de conexões. Isso também não funcionou.
    No meu caso o MSN fica aberto o tempo que for, contanto que eu não envie nenhuma mensagem. A primeira mensagem que eu tentar mandar, pra qualquer contato, o MSN cai (o que ocorre nesse momento está descrito no log que eu passei no meu último post).
    Foi que nem eu falei, pra mim agora só falta matar as tabelas e começar tudo de novo. Mas eu estava querendo evitar de fazer isso :-/. Acho que vou guardar todas as conversas e mandar ver, tudo de novo, do zero.



  15. #115

    Padrão

    Bom, foi bem por aí. Criei outro usuário e outra base no MySQL e agora voltou a funcionar. Porém, eu ainda estou com vários problemas:

    - Ao tentar bloquear um contato para alguma pessoa, aparece a mensagem: Falha ao gravar alteração
    - Quando eu faço alguma alteração geral, cujo intuito seja afetar todos os usuários, ela não funciona. Não propaga para os usuários. Ela só propaga para usuários que ainda vão ser criados no banco de dados. Usuários já existentes não recebem a alteração.

    Para ambos os casos eu chequei o log, sem sucesso (não há nenhuma atividade nele).
    Tentei fazer as alterações, parar o msn-proxy, parar o mysql e então iniciar todos de novo, também sem sucesso.
    Esses problemas eu tenho desde a versão 0.5, e eu vi que parece que isso funciona para todas as outras pessoas :-/. Eu devo estar fazendo algo muito errado.

  16. #116

    Padrão

    Boa Tarde.
    fiz a instalação do msn-proxy hoje no servidor está funcionando beleza e por enquanto a contento, não tive tempo de testar suas funcionalizades, minha dúvida é a seguinte: aparentemente a mensagem de aviso do monitoramento só esta indo para o próprio usuário conectado, existe uma forma dessa mensagem ir para as duas pontas?no caso para o usuário e para a pessoa com quem o mesmo está conversando?já vi algumas empresas que funciona dessa forma.O msn-proxy faz isso?qual a configuração caso faça?

    []'s



  17. #117

    Padrão

    Consegui colocar as regras sem que parasse o msn de enviar as mensagens, só que tem outro problema não está capturando as mensagens, não aparece nada na tela do msn-proxy, e o serviço está rodando.

  18. #118

    Padrão

    brunodisk colocou as regras de direcionamento da porta?
    fiz assim pra iniciar e ta beleza

    internet="eth0"

    echo "Iniciando o MSN-Proxy"
    /usr/local/bin/msn-proxy & >> /dev/null
    iptables -t nat -I PREROUTING -i $internet -p tcp --dport 1863 -j REDIRECT --to-port 1863 >> /dev/null



  19. #119

    Padrão

    Eu acho que tem mais algum problema, pois não funciona de forma alguma, o serviço está rodando mais não captura nada, já estou quase desistindo de mexer nesse programa..

    Citação Postado originalmente por agl77 Ver Post
    brunodisk colocou as regras de direcionamento da porta?
    fiz assim pra iniciar e ta beleza

    internet="eth0"

    echo "Iniciando o MSN-Proxy"
    /usr/local/bin/msn-proxy & >> /dev/null
    iptables -t nat -I PREROUTING -i $internet -p tcp --dport 1863 -j REDIRECT --to-port 1863 >> /dev/null

  20. #120

    Padrão

    olha não aconselho a desistir, hehehe, me bati muito, mas a hora q funcionou, compensou!
    a Libevent deve estar funcionando pois o msn-proxy está rodando.
    bom tbem tem como tentar instalar o phpmyadmin e verificar o ip da interface interna se está correto

    tenta tbem modificar a interface da regra q lhe passe4i anteriormente, tenta c a interna e c a externa
    mas qq mudança nao irá funcionar se vc nao desconectar e conectar o msn novamente