+ Responder ao Tópico



  1. #21

    Padrão Voltou O CARA !!! ... rs

    Aprendi a configurar o primeiro MK com um Tutorial desse cara ...

    ,,,


    Valeu CATV.

  2. #22
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    CATV só para ficar claro, a pessoa no caso cliente, ele só vai fazer download de arquivo com tamanho ate 500k? Arquivo maior que 500k vai drop?



  3. #23

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    CATV só para ficar claro, a pessoa no caso cliente, ele só vai fazer download de arquivo com tamanho ate 500k? Arquivo maior que 500k vai drop?
    Se você usar as 2 regras que coloquei no exemplo sim, vai dropar tudo acima de 500k.

  4. #24

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Isso ai meu garoto...Estava fazendo falta aqui!!!
    Valeu!!!!!!!!! Estamos voltando devagarinho.. rsssssssss



  5. #25

    Padrão

    Citação Postado originalmente por rafaeltdk Ver Post
    gostaria de saber como fica o cliente que quiser baixar um arquivo de 10 megas ou mesmo mais, quer dizerque ele nao ira conseguir certo, ou mesmo fazer um upgrade do windows como ficaria isso, gostaria de entender melhor desculpa nao entender mas e perguntando que se aprende.
    Amigo, depende de como você irá configurar a regra... No exemplo que citei, você pode simplesmente dropar tudo acima de um limite (no caso do exemplo, 500k), mas você pode fazer outras coisas, como foi mostrado pelos colegas, como dar um tipo de prioridade ou banda para até um certo tamanho de arquivo e dar outro tipo de prioridade ou banda para outros tamanhos.

  6. #26
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por sergio Ver Post
    e ai David? levou uma sumida grande.... hehehehe

    qq coisa estamos na area tb.

    Rapazzz,

    que negócio é esse de levou uma sumida grande???

    hehehehehe



  7. #27

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Bom, sei que estou meio sumido, devido problemas particulares, mas como sempre estou por ae, prestando aquele excelente suporte, treinamentos e etc...

    Segue uma dica para aqueles usuários que desejam controlar ou dropar arquivos de acordo com o tamanho.

    função: CONNECTION BYTES

    Funciona assim:

    0 (zero no início) = apartir de (0-500000 = apartir de 0k até 500k)
    0 (zero no final) = infinito (500000-0 = apartir de 500k para cima)

    Vamos supor que desejamos aceitar conexões com no máximo 500k, ficaria assim:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 connection-bytes=0-500000 \
    action=accept comment="" disabled=no

    Vamos supor que desejamos rejeitar todas as outras conexões acima de 500k, ficaria assim:

    Versão 2.9.xx:

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-4294967295 \
    action=drop comment="" disabled=no

    Versão 3.xx

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-0 \
    action=drop comment="" disabled=no


    Vamos supor agora que desejamos rejeitar apenas conexões acima de 500k para um usuário ou um grupo de usuários, ficaria assim:

    Versão 2.9.xx:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-4294967295 src-address-list=no_download \
    action=drop comment="" disabled=no

    /ip firewall address-list
    add list=no_download address=10.0.0.1 comment="" disabled=no


    Versão 3.xx:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-0 src-address-list=no_download \
    action=drop comment="" disabled=no

    /ip firewall address-list
    add list=no_download address=10.0.0.1 comment="" disabled=no

    Lembrando que essa mesma dica, você pode fazer outras coisas interessantes, como, marcar conexões de acordo com o tamanho e colocar em uma QOS com prioridades e bandas e disciplinas diferentes, entre outras coisas que a imaginação mandar!!


    Fica essa dica simples, porém que parece muito complexa para muitos aqui (tenho acompanhado os tópicos!!). Qualquer dúvida estamos por ae...

    Valeuu Esse é o Cara do MK Queria uns 10 funcionarios assim aqui na minha empresa!!!! rsrsrssrs

  8. #28

    Padrão

    Citação Postado originalmente por WWANInternet Ver Post
    Valeuu Esse é o Cara do MK Queria uns 10 funcionarios assim aqui na minha empresa!!!! rsrsrssrs
    Só ele já chega. Vale por 10.. hehehe!!!

    Tem muita gente boa em MK, mas dispostas a abrir o jogo não são muitos.
    Sei de gente que nem entra em forum para não passar conhecimento adiante.



  9. #29
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    Amigo o que eu poderia está fazendo de alteração nessa regra para funcionar com hotspot?

    Desde ja agradeço a atenção e ajuda de todo do Under-Linux.... Grande abraço CATV

  10. #30

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    Amigo o que eu poderia está fazendo de alteração nessa regra para funcionar com hotspot?

    Desde ja agradeço a atenção e ajuda de todo do Under-Linux.... Grande abraço CATV

    olha amigo vc teria que criar um script para que a queues sempre fique no topo da lista o script é esse

    :foreach I in=[/queue simple find name="Nome_da QUEUE"] do={/queue simple move $I [/queue simple find dynamic=yes]}
    e fazer ele ser executadado de tempo em tempo

    Obs.: substitua o Nome_da QUEUE pelo nome que vc deu a ela



  11. #31

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Rapazzz,

    que negócio é esse de levou uma sumida grande???

    hehehehehe

    kkkkkkkkkkkkkkk............ esse negócio não é comigo não!!! kkkkkkkkkkkkkkkk

  12. #32

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    kkkkkkkkkkkkkkk............ esse negócio não é comigo não!!! kkkkkkkkkkkkkkkk



    kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk



  13. #33

    Padrão

    Bom, primeiramente gostaria de parabenizar ao CATV e ao J34nsch pela preciosa ajuda. Segundo, gostaria de esclarecer uma dúvida: eu tenho diversas classes de clientes; por exemplo, tenho clientes de 150kbps e 256kbps, entre outros. Aí vem a questão, como eu faço para aplicar essas regras do tópico para ambas as classes? Os clientes de 256 kbps baixariam a 1 Mbps arquivos até 1 Mb, a 512 kbps até 5 Mb, daí por diante voltaria pra velocidade contratada.
    Aproveitando e abusando, para aplicar o burst limit a todos os meus clientes, considerando suas diferentes bandas contratadas, existe algum script? Eu rodei o site do under e não achei isso. Se alguém puder me dar uma luz eu agredeço desde já.

    Abçs.

  14. #34

    Padrão

    Citação Postado originalmente por Pantanero2006 Ver Post
    Bom, primeiramente gostaria de parabenizar ao CATV e ao J34nsch pela preciosa ajuda. Segundo, gostaria de esclarecer uma dúvida: eu tenho diversas classes de clientes; por exemplo, tenho clientes de 150kbps e 256kbps, entre outros. Aí vem a questão, como eu faço para aplicar essas regras do tópico para ambas as classes? Os clientes de 256 kbps baixariam a 1 Mbps arquivos até 1 Mb, a 512 kbps até 5 Mb, daí por diante voltaria pra velocidade contratada.


    Abçs.
    amigo vamos por partes, para fazer o que vc quer tem que criar 2 listas de ips, vai em address list no firewall e cria 2 lista de clientes uma para o plano 150kbps e outra para o plano 256kbps, apos isso faça as regras que esta no topico, mais sem o "connection-mark", esta logo abaixo

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Pack full" connection-bytes=0-500000 disabled=no dst-port=80 new-connection-mark=PackFull passthrough=\
    yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no new-connection-mark=PackFull passthrough=yes protocol=tcp \
    src-port=80
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no new-connection-mark=PackFull passthrough=yes protocol=tcp \
    src-port=53
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no new-connection-mark=PackFull passthrough=yes protocol=udp \
    src-port=53
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no dst-port=53 new-connection-mark=PackFull passthrough=yes \
    protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-bytes=0-500000 disabled=no dst-port=53 new-connection-mark=PackFull passthrough=yes \
    protocol=tcp
    agora vamos adicionar o connection-mark a regua é a seguinte

    add action=mark-packet chain=prerouting comment="" connection-mark=PackFull disabled=no new-packet-mark=PackFullMARK passthrough=yes
    vc vai ter que fazer essa regra duas vezes uma com cada lista que vc criou, vc vai colocar a lista em Advanced > Src. Address List, e em Action vc coloca um nome diferente no New Packet Mark, pronto assim vc já diferenciou uma categoria da outra e marcou os pacotes e so falta fazer o queue

    é só criar duas queue com a velocidade que vc quer dar para os o grupo de clientes, e em cada queues colocar advanced > Packet Mark vc coloca um dos grupos que marcamos no mark-packet.



  15. #35

    Padrão

    Citação Postado originalmente por Pantanero2006 Ver Post
    Aproveitando e abusando, para aplicar o burst limit a todos os meus clientes, considerando suas diferentes bandas contratadas, existe algum script? Eu rodei o site do under e não achei isso. Se alguém puder me dar uma luz eu agredeço desde já.

    Abçs.

    amigo não entendi a sua pergunta, vc que um script para mudar as configs de banda do cliente?

  16. #36

    Padrão

    Citação Postado originalmente por Pantanero2006 Ver Post
    Bom, primeiramente gostaria de parabenizar ao CATV e ao J34nsch pela preciosa ajuda. Segundo, gostaria de esclarecer uma dúvida: eu tenho diversas classes de clientes; por exemplo, tenho clientes de 150kbps e 256kbps, entre outros. Aí vem a questão, como eu faço para aplicar essas regras do tópico para ambas as classes? Os clientes de 256 kbps baixariam a 1 Mbps arquivos até 1 Mb, a 512 kbps até 5 Mb, daí por diante voltaria pra velocidade contratada.
    Aproveitando e abusando, para aplicar o burst limit a todos os meus clientes, considerando suas diferentes bandas contratadas, existe algum script? Eu rodei o site do under e não achei isso. Se alguém puder me dar uma luz eu agredeço desde já.

    Abçs.
    Veja ae meu amigo, talvez te sirva esta ferramenta calcula o tempo necessário para cada tamanho de arquivo a ser baixado e permite este download antes de aplicar o corte de velocidade.
    Mikrontrol + ConLog + ConPlan - Pacote de sofwares gratis para MikrotikROS



  17. #37

    Padrão dropar pacotes???

    ola amigo!

    fala ai qual a finalidade de dropar e como funfa isso.
    sou leigo e tenho interesse em dar um ajuste fino avançado no meu mk 2.9.27.

  18. #38

    Padrão

    CATV e todos do forum..

    so um poko leigo no mikrotik (por um bom tempo, pois tem gente com muita experiencia aki)

    eu implantei com um poco de dificultades o proxy paralelo, e agora estou tentando configura da seguinte maneira o mikrotik.

    arquivos de 0mb a 4mb ir a 4mbps compartilhada
    arquivos de 4mb a 8mb ir a 3mbps compartilhada
    arquivos de 8mb a 12mb ir a 2mbps compartilhada

    e > que 12mb ir a 1mbps compartilhando pelo numero de conexao simultaneas.

    ai eu tava pensando para fazer dessa forma eu teria q marca a porta padrao do squid correto ?
    para min fazer a mesma coisa com thundercache seria a mesma logica q no squid ??

    porque c eu jogar sem esse controle os radinho não vai aguentar vai travar muiito...

    estou tentando fazer.. logo logo posto as regras..

    espero a ajuda de vc´s obrigado.
    Última edição por mktguaruja; 15-05-2009 às 16:45.



  19. #39

    Padrão

    mktguaruja,
    Tem uma galera ae de plantão esperando sua solução. Já leu outros posts ?
    Dando certo poste ae ....

  20. #40

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    mktguaruja,
    Tem uma galera ae de plantão esperando sua solução. Já leu outros posts ?
    Dando certo poste ae ....
    li o post do roberto.. o do thunder cache, e estou estudando atraves dessas regras que colocaram no post...

    add chain=forward protocol=tcp content="THUNDER: THUNDER" action=mark-connection new-connection-mark=thunder-connection \
    passthrough=yes comment="THUNDER CACHE FULL" disabled=no
    add chain=forward protocol=tcp connection-mark=thunder-connection action=mark-packet new-packet-mark=thunder-packs \
    passthrough=yes comment="" disabled=no

    / queue tree
    add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=1000000 queue=thunder priority=8 \
    max-limit=3000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="cache-antigo" parent=global-out packet-mark=cache-hits limit-at=1000000 queue=default priority=8 \
    max-limit=2000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="ThunderCache" parent=global-out packet-mark=thunder-packs limit-at=1000000 queue=thunder priority=8 \
    max-limit=3000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

    mais em questao do tamanho do arquivo e limitar a velocidade vo usar o connection-bytes, estou dando uma olhada ainda...
    flow